Cells(i,4)="=WENN(.....)"-Problem!



Excel-Version: 2000
nach unten

Betrifft: Cells(i,4)="=WENN(.....)"-Problem!
von: Thorsten K.
Geschrieben am: 10.05.2002 - 14:59:12

Hallo,

könnt ihr mir sagen, wieso so etwas nicht geht ?

Cells(i,4)="=WENN(......)"

Bei einfachen Formeln wie Cells(i,4)="=MAX(A1:A14)" geht es.
Aber warum nicht bei komplexeren ?

Danke!

nach oben   nach unten

Re: Cells(i,4)="=WENN(.....)"-Problem!
von: Hajo
Geschrieben am: 10.05.2002 - 15:02:50

Hallo Thorsten

es muß die englische Funktion verwendet werden

ActiveCell.FormulaR1C1 = "=IF(R[-3]C[1]=1,""Test"",""Ok"")"


Gruß Hajo


nach oben   nach unten

Re: Cells(i,4)="=WENN(.....)"-Problem!
von: Thorsten K.
Geschrieben am: 10.05.2002 - 15:13:50

Hallo Hajo,

das Problem dabei ist, dass die Formel sehr lang und sehr komplex ist. Dafür das FormulaR1C1 zu benutzen ist mir zu kompliziert.
Ich schreibe die Formel jetzt so hin: xxx(....) und ersetze danach das xxx manuell durch =WENN
Obwohl es manuell klappt, kann ich es nicht als Makro schreiben. Selbst wenn ich es mit dem Makrorekorder aufgezeichnet habe , geht es nicht.
weisst du warum nicht ?

nach oben   nach unten

Re: Cells(i,4)="=WENN(.....)"-Problem!
von: Hajo
Geschrieben am: 10.05.2002 - 15:20:46

Hallo Torsten

ich hatte jetzt nur kopiert was der Recorder aufgezeichnet hat Du kannst natürlich auch
ActiveCell.Formula = "=IF(A1<>1,A1+A3,""Ok"")"

Schreiben

Gruß Hajo


nach oben   nach unten

Re: Cells(i,4)="=WENN(.....)"-Problem!
von: Rolf, Lgh.
Geschrieben am: 10.05.2002 - 15:40:06

Hallo Thorsten,
schau Dir das mal an:

Gruss Rolf
nach oben   nach unten

Beispiel:
von: Rolf, Lgh.
Geschrieben am: 10.05.2002 - 15:48:28


MS Excel von Rolf, Lgh. an Rolf, Lgh.
 ABC
13=WENN(A2>A3;A4;A5)=FormulaAsText($A$1;0)
25=IF(A2>A3,A4,A5)=FormulaAsText($A$1;1)
34=WENN(Z(1)S>Z(2)S;Z(3)S;Z(4)S)=FormulaAsText($A$1;2)
43=IF(R[1]C>R[2]C,R[3]C,R[4]C)=FormulaAsText($A$1;3)
52 


nach oben   nach unten

Uiii !!
von: Thorsten K.
Geschrieben am: 10.05.2002 - 15:52:47

Hi Rolf,

Mann! Das geht aber jetzt über meinen Horizont hinaus! ;-)
Das werde ich mir mal näher anschauen!

Danke Dir!


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Excel-Datei als Email"