"dynamisches" aendern der bedingung?



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: "dynamisches" aendern der bedingung?
von: clemens
Geschrieben am: 16.07.2002 - 08:27:39

hallo

ich haett folgendes problem.
ich moechte in abhaengigkeit in welchen tabellenblatt ich bin, jeweils auf eine andere Liste zugreifen.
sprich wenn ich in tabellenblatt Liste 1 im workbook test2.xls bin. moechte ich dass dort steht

=WENN('[test.xls]Liste 1'!B15 = "";"";'[test.xls]Liste 1'!B15)

wenn ich jetzt im tabellenblatt Liste 2 bin moechte ich dass dort steht

=WENN('[test.xls]Liste 2'!B15 = "";"";'[test.xls]Liste 2'!B15)

ich haette im jeweiligen blatt
an der stelle B3 "Liste 1" bzw. "Liste 2" stehen.

aber ich kann ja nicht folgendes machen:

=WENN('[test.xls]B3'!B15 = "";"";'[test.xls]B3'!B15)

sprich als variable das irgendwie uebergeben, oder?
ich braeuchte ein echo B3 oder aehnliches :-)
gibts abhilfe?

mfg
clemens

nach oben   nach unten

Indirekt-Funktion
von: sam
Geschrieben am: 16.07.2002 - 09:08:28

Hallo!

Du kannst die INDIREKT-Funktion verwenden.
In der Zelle B3 muss aber der gesamte Bezug stehen, also nicht nur der Registername. Du kannst ja mit einer Hilfszelle einen Text zusammensetzen, und diese ausblenden.

z.B.
B3: "Liste 2"
C3: "[Test.xls]" & B3 & "!B15"

dann lautet die WENN-Funktion
=WENN(INDIREKT(C3) = "";"";INDIREKT(C3))

Achtung: Die Mappe Test muss dabei offen sein, sonst bekommst du als Ergebnis #bezug#

nach oben   nach unten

Indirekt-Funktion
von: sam
Geschrieben am: 16.07.2002 - 09:09:37

Hallo!

Du kannst die INDIREKT-Funktion verwenden.
In der Zelle B3 muss aber der gesamte Bezug stehen, also nicht nur der Registername. Du kannst ja mit einer Hilfszelle einen Text zusammensetzen, und diese ausblenden.

z.B.
B3: "Liste 2"
C3: "[Test.xls]" & B3 & "!B15"

dann lautet die WENN-Funktion
=WENN(INDIREKT(C3) = "";"";INDIREKT(C3))

Achtung: Die Mappe Test muss dabei offen sein, sonst bekommst du als Ergebnis #bezug#

 nach oben

Beiträge aus den Excel-Beispielen zum Thema ""dynamisches" aendern der bedingung?"