Auf Doppeleintrag überprüfen



Excel-Version: XL10
nach unten

Betrifft: Auf Doppeleintrag überprüfen
von: Mike
Geschrieben am: 02.05.2002 - 10:53:33

Hallo zusammen,
wie kann man einen Zellbereich auf einen Doppeleintrag überprüfen und diesen dann farblich kennzeichnen lassen?

Gruß
Mike


nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Robert Werner
Geschrieben am: 02.05.2002 - 11:20:57

Mit Hilfe der bedingten Formatierung kann man dies erreichen.

Beispiel: Der Bereich A1:B10 soll überprüft werden

Den Bereich markieren, wenn A1 die aktive Zelle ist bei Bedingte Formatierung "Formel ist" auswählen und folgende Formel eingeben

=ZÄHLENWENN($A$1:$B$10;A1)>1

Dann noch das gewünschte Format auswählen, fertig.

Gruß
Robert

nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Peter H. Erdmann
Geschrieben am: 02.05.2002 - 11:22:20

Hallo

Bereich markieren - bedingete Formatierung -
Formel ist
=ZÄHLENWENN(A1:$A$10;A1)>1
Farbe bestimmen

es werden alle Duplikate hinterlegt

Gruß aus dem Land der Bayern
Peter

nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Mike
Geschrieben am: 02.05.2002 - 11:46:59

Danke euch beiden. Funktioniert.
Wie müsste die Variante lauten, dass nicht die erste doppelte Zahl farblich gekennzeichnet wird, sondern die doppelte selbst?
Oder geht das nicht?

Gruß Mike


nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Robert Werner
Geschrieben am: 02.05.2002 - 12:34:53

Geht auch.

Um bei meinem Beispiel zu bleiben (Datenbereich A1:B10 und A1 ist aktive Zelle):

=ZÄHLENWENN($A$1:A1;A1)>1

$A$1 bleibt dabei immer fest, A1 ändert sich dabei immer in die aktuelle Zellenadresse.

Gruß
Robert

nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Mike
Geschrieben am: 02.05.2002 - 13:53:13

Danke Robert. Funktioniert prima. Allerdings werden jetzt auch alle leeren Zellen in der Spalte farblich gekennzeichnet. Könnte man das noch ändern?

Gäbe es auch die Möglichkeit, beide Zellen farblich zu markieren?
Also die Bezugszelle und die Zelle mit dem doppelten Eintrag. Man müsste dann nicht suchen.

Gruß
Mike


nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Robert Werner
Geschrieben am: 02.05.2002 - 14:38:42

Bei meinem Excel 97 werden leere Zellen nicht markiert. Sollte es bei dir anders sein, kannst du die Formel wie folgt erweitern:

=UND(A1<>"";ZÄHLENWENN($A$1:A1;A1)>1)

Beide Zellen werden mit meinem ersten Vorschlag markiert

=ZÄHLENWENN($A$1:$B$10;A1)>1)

Sollen die Zellen bei jeder weiteren Wiederholung andersfarbig markiert werden, dann muss ich leider passen. Da fällt mir im Moment keine Lösung ein.

Gruß
Robert

nach oben   nach unten

Re: Auf Doppeleintrag überprüfen
von: Mike
Geschrieben am: 02.05.2002 - 15:49:18

Hallo Robert,
funktioniert mit dieser Formel:
=UND(A1<>"";ZÄHLENWENN($A$1:$B150;A1)>1)

Danke für deine Hilfe.

Gruß
Mike

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Auf Doppeleintrag überprüfen"