Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

bestimmte buchstaben finden und zählen

bestimmte buchstaben finden und zählen
Ralph

Hallo Forum,
Ich habe mal meine datei drangehängt und darin beschrieben was für ein Problem ich habe
Ich hoffe es kann mir jemand helfen.
Danke
Ralph
https://www.herber.de/bbs/user/79441.xlsm

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: bestimmte buchstaben finden und zählen
19.03.2012 19:21:14
Hajo_Zi
Hallo Ralph,
für das Problem ist der Beitrag da. Warum soll ich mir eine Datei runterladen um festzustellen, das ist nicht mein Ding.

Zählen mit Bedingungen
19.03.2012 19:46:09
Erich
Hi Lena-Ralph,
vielleicht so?
 ABCDEFGHIJK
1Zi.Nr.NamevonbisErw.KindHp/Üf    
2102Pangerl13.01.201215.01.201222h DatumEssenFrühstück
3104Dr. Glas13.01.201215.01.201223h 08.01.201220
4108Meißner13.01.201215.01.201222h 09.01.201222
5113Hurt13.01.201215.01.201221h    
6333Bräu13.01.201215.01.201222f    
7107Schütz12.01.201216.01.201221f    
8216Reger15.01.201216.01.201210h    
9221Wißmann08.01.201221.01.201220h    
10103Edelmann18.01.201222.01.201210h    
11110Klement15.01.201222.01.201220f    

Formeln der Tabelle
ZelleFormel
J3=SUMMENPRODUKT((C$2:C$136<=I3)*(D$2:D$136>I3)*(G$2:G$136="h")*(E$2:E$136+F$2:F$136))
K3=SUMMENPRODUKT((C$2:C$136<I3)*(D$2:D$136>=I3)*(E$2:E$136+F$2:F$136))
J4=SUMMENPRODUKT((C$2:C$136<=I4)*(D$2:D$136>I4)*(G$2:G$136="h")*(E$2:E$136+F$2:F$136))
K4=SUMMENPRODUKT((C$2:C$136<I4)*(D$2:D$136>=I4)*(E$2:E$136+F$2:F$136))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
P.S.: Das mit der fehlenden Aufgabenbeschreibung im Beitrag sehe ich genau so wie Hajo.
Anzeige
AW: bestimmte buchstaben finden und zählen
19.03.2012 19:44:18
Josef

Hallo Ralph,
so?
Anreisen

 ABCDEFGHIJKLMN
1Zi.Nr.NamevonbisErw.KindHp/Üf       
2221Wißmann08.01.201221.01.201220h Datum   HPÜF
3107Schütz12.01.201216.01.201221f 13.01.2012   27
4102Pangerl13.01.201215.01.201222h       
5104Dr. Glas13.01.201215.01.201223h       

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((C2:C136<I3)*(D2:D136>=I3)*(G2:G136="h")*(E2:E136+F2:F136))
N3=SUMMENPRODUKT((C2:C136<=I3)*(D2:D136>I3)*(G2:G136="f")*(E2:E136+F2:F136))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
Andere Ergebnisse
19.03.2012 19:54:52
Erich
Hi Sepp,
für den 13.1. bekomme ich 18 Essen und insgesamt 5 Frühstücke:
 IJKL
2DatumEssen(HP)Frühstück(HP)Frühstück(ÜF)
313.01.20121823

Formeln der Tabelle
ZelleFormel
J3=SUMMENPRODUKT((C$2:C$136<=I3)*(D$2:D$136>I3)*(G$2:G$136="h")*(E$2:E$136+F$2:F$136))
K3=SUMMENPRODUKT((C$2:C$136<I3)*(D$2:D$136>=I3)*(G$2:G$136="h")*(E$2:E$136+F$2:F$136))
L3=SUMMENPRODUKT((C$2:C$136<I3)*(D$2:D$136>=I3)*(G$2:G$136="f")*(E$2:E$136+F$2:F$136))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige
AW: Andere Ergebnisse
19.03.2012 21:00:23
Josef

Hallo Erich,
klar bekommst du mit meiner Formel andere Ergebnisse, sie ist ja auch falsch;-))
Man(n) sollte halt nicht versuchen, zwei Sachen gleichzeitig zu erledigen.
Anreisen

 ABCDEFGHIJKLMN
1Zi.Nr.NamevonbisErw.KindHp/Üf       
2221Wißmann08.01.201221.01.201220h Datum   HPÜF
3107Schütz12.01.201216.01.201221f 13.01.2012   185
4102Pangerl13.01.201215.01.201222h       
5104Dr. Glas13.01.201215.01.201223h       
6108Meißner13.01.201215.01.201222h       
7113Hurt13.01.201215.01.201221h       
8333Bräu13.01.201215.01.201222f       
9216Reger15.01.201216.01.201210h       
10110Klement15.01.201222.01.201220f       
11111Klement15.01.201222.01.201220f       

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((C2:C136<=I3)*(D2:D136>I3)*(G2:G136="h")*(E2:E136+F2:F136))
N3=SUMMENPRODUKT((C2:C136<I3)*(D2:D136>=I3)*(E2:E136+F2:F136))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
AW: bestimmte buchstaben finden und zählen
19.03.2012 20:44:39
Vernay
Hallo Sepp,
danke für deine Antwort, aber die rechnung ist falsch.
Wenn ich nur mal die 4 Gäste nehme, die ich in deiner kopie sehe, dann müsste folgendes rauskommen:
Frühstück am 13.01.2012 5 Personen (Wißmann (2) und Schütz (2+1))
HP am 13.01.2012 11 Personen (Wißmann (2) und Pangerl (2+2) und Dr.Glas (2+3)
Ralph

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige