Jeweilige Anzahl versch. Zeichen in einer Zeile?



Excel-Version: 97
nach unten

Betrifft: Jeweilige Anzahl versch. Zeichen in einer Zeile?
von: Marc
Geschrieben am: 07.05.2002 - 13:42:10

Hallo Leute,
lange gesucht, nichts passendes gefunden...
Ich habe in einer Zeile in die Zellen mal ein "A", mal zwei "AA" aber auch mal "AB" oder "BC" geschrieben. Nun möchte ich ermitteln, wie oft der Buchstabe "A" oder "B" oder "C" in dieser Zeile vorkommt.
ZÄHLENWENN ermittelt nur die Anzahl der Zellen (ich müsste also für jede Kombinationsmöglichkeit eine eigene Anweisung schreiben - aber Excel soll mir ja das Leben erleichtern...oder wie oder was?).
Auch SUMME(LÄNGE()) hat mich nicht weitergebracht.

Das kann doch nicht so schwer sein??!

Gruß von Marc (und schon mal vielen Dank)


nach oben   nach unten

Re: Jeweilige Anzahl versch. Zeichen in einer Zeile?
von: Andreas
Geschrieben am: 07.05.2002 - 13:47:46

Hallo Marc,

schau mal hier:
http://www.excelformeln.de/formeln.html?welcher=96

Viel Spaß,
Andreas

nach oben   nach unten

Re: Jeweilige Anzahl versch. Zeichen in einer Zeile?
von: Marc
Geschrieben am: 07.05.2002 - 16:51:34

Ja, das war schon mal ein prima Tipp - vielen Dank. Allerdings reagieren die beiden Befehle nicht auf Bereiche. Einzelne Zelle: gut, Mehrere Zellen: nicht gut...
Ich verstehe allerdings auch den SPALTE-Befehl nicht, was macht der in dieser Formel:
=SUMME((TEIL(A1;SPALTE(1:1);1)="x")*1) und kann ich hier einen Bereich einfügen, also z.B. =SUMME((TEIL(C5:FH5;SPALTE();1)="A")*1)?
Gruß Marc
nach oben   nach unten

Re: Jeweilige Anzahl versch. Zeichen in einer Zeile?
von: Andreas
Geschrieben am: 07.05.2002 - 17:36:13

Hallo Marc,

um einen Bereich zu überprüfen nimm diese Formel:
{=SUMME(LÄNGE(A1:B100)-LÄNGE(WECHSELN(A1:B100;"A";"")))}

Denke daran, es ist eine Array-Formel, also mit STRG+SHIFT+ENTER abschliessen und die geschweiften Klammern {] nicht eingeben!

Viel Spaß,
Andreas

nach oben   nach unten

Re: Jeweilige Anzahl versch. Zeichen in einer Zeile?
von: Marc
Geschrieben am: 08.05.2002 - 07:42:20

Hallo Andreas, genau das war's - vielen Dank!
Gruß
Marc

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Jeweilige Anzahl versch. Zeichen in einer Zeile?"