Microsoft Excel

Herbers Excel/VBA-Archiv

Teilstring finden Anzahl >1

Betrifft: Teilstring finden Anzahl >1 von: Astrid
Geschrieben am: 04.11.2020 10:56:54

Guten Tag,

ich komme leider an einer Stelle nicht weiter.

Teilstrings die sich in Spalte K befinden, sollen in Spalte I gesucht werden.

Sobald ein Teilstring mehr als einmal vorhanden ist, sollen die jeweiligen Zeilen nach Tabelle 2 kopiert werden.

Die Positionen zu dem jeweiligen Teilstring untereinander, da sie noch weiter verarbeitet werden.

https://www.herber.de/bbs/user/141303.xlsx


Vielen Dank.

Astrid

Betrifft: AW: nachgefragt ...
von: neopa C
Geschrieben am: 04.11.2020 11:08:10

Hallo Astrid,

... wie viele Datensätze sind denn max. ca. auszuwerten? Wenn es keine Massendatenauswertung ist, wäre es mit Formel möglich.
Was Du mit "Die Positionen zu dem jeweiligen Teilstring untereinander, da sie noch weiter verarbeitet werden" erschließt sich mir momentan aber auch noch nicht.

Gruß Werner
.. , - ...

Betrifft: AW: nachgefragt ...
von: Astrid
Geschrieben am: 04.11.2020 12:39:56

Hallo Werner,
in den schlimmsten Zeiten hatte das Konto 900 offene Posten. Momentansind es durchschnittlich bis 500.
Ich hatte es ursprünglich mit Array´s versucht, wegen der Performance, aber irgendwie habe ich das Thema nicht richtig verstanden.
Gruß Astrid

Betrifft: AW: die Zeilennnummern ermitteln ...
von: neopa C
Geschrieben am: 04.11.2020 14:18:38

Hallo Astrid,

... kannst Du z.B. mit folgender Formel in L2:

=WENN((K2="")+(ZÄHLENWENN(I:I;"*"&K2&"*")=1);"";WENNFEHLER(AGGREGAT(15;6;ZEILE(I$2:I$99)/SUCHEN($K2;$I$2:$I$99)^0;SPALTE(A1));""))

Diese Formel nach unten ziehend kopieren und nach rechts.

Dann können mit einer Formel auch die Datensätze in Tabelle 2 in Bezug auf die ermittelten Zeilennmmern gelistet werden. Sind es immer nur zwei je Teilstring oder können es auch mehr sein?

Gruß Werner
.. , - ...

Betrifft: AW: die Zeilennnummern ermitteln ...
von: Astrid
Geschrieben am: 04.11.2020 14:34:10

Hallo Werner,
es können auch mal drei sein.
So ist es ja schon mal sehr toll, dann muss ich jetzt nur noch versuchen die Schritte ins VBA zu bekommen, weil der Sachverhalt ein Schritt in einem Makro ist.
Viele Grüße
Astrid

Betrifft: AW: nachgefragt ...
von: Astrid
Geschrieben am: 04.11.2020 19:19:40

Hallo Werner,
ich habe gerade gesehen, dass ich deine erste Frage nicht komplett beantwortet hatte. Zu dem Punkt:
Was Du mit "Die Positionen zu dem jeweiligen Teilstring untereinander, da sie noch weiter verarbeitet werden" erschließt sich mir momentan aber auch noch nicht....
Die Exceldatei ist eine Darstellung aus einem SAP-Konto. Da nicht alle Spalten aus der Excel im "normalen" Buchungsbetrieb zu sehen ist (Langtext, ist nicht auf der obersten SAP Ebene zu sehen),
Soll diese Makro meiner Kollegin und mir helfen, die auszugleichenden Positionen leichter und vor allem schneller zu finden sind und man die übrigen Positionen in "Ruhe" recherchieren kann.
Vielen Dank nochmal und einen schönen Abend.

Betrifft: AW: danke, wünsche ich Dir auch owT
von: neopa C
Geschrieben am: 04.11.2020 20:13:45

Gruß Werner
.. , - ...

Betrifft: zählen / filtern / kopieren
von: WF
Geschrieben am: 04.11.2020 13:07:54

Hi,

schreib in L2:
=SUMMENPRODUKT(ISTZAHL(SUCHEN(K2;I$1:I$999))*1)
runterkopieren

Filter dann Spalte L nach größer 1

Die gesamte gefilterte Tabelle kopierst Du.

WF

Betrifft: AW: zählen / filtern / kopieren
von: Astrid
Geschrieben am: 04.11.2020 13:54:23

Hallo WF,
erst einmal Danke für die Antwort. Da aber Spalte K nicht bis zum Spalten Ende von I befüllt ist, zeigt der Filter bei Auswahl "2" nur die Zeilen, wo sich der Wert auch in K befindet. Steht der zweite Wert in I in einer Zeile wo die Zelle in K leer ist, dann wird dieser im Filter "2" nicht angezeigt.
Ich brauche aber beide Zeilen.
Ich hänge das Ergebnis einmal an, wegen dem Verständnis.
Hier einmal der Link zum Ergebnis von deinem Vorschlag.
https://www.herber.de/bbs/user/141308.xlsx
Viele Grüße
Astrid

Beiträge aus dem Excel-Forum zum Thema "Teilstring finden Anzahl >1 "