Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema Label
BildScreenshot zu Label Label-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Inhalt aus Textbox 4 in spalte D zählen

Betrifft: Inhalt aus Textbox 4 in spalte D zählen von: Vulferin
Geschrieben am: 08.10.2014 22:34:29

Hallo zusammen
ich hab in meiner Userform eine Nr stehen
ich würde gerne zählen wie oft ich diese nr in Spalte d habe.
und diese dann in Textbox 8 anzeigen lassen

Könnt ihr mir nen tip geben ?

  

Betrifft: Funktion Häufigkeit ? owT von: Matze Matthias
Geschrieben am: 08.10.2014 22:42:49




  

Betrifft: Besser so : =ZÄHLENWENN(A:A;A1) von: Matze Matthias
Geschrieben am: 08.10.2014 22:49:40

Hallo Vulverin,
wobei A1 auch direkt durch das Suchkriterium ersetzt werden kann
=ZÄHLENWENN(A:A;5) zählt alle 5en der Spalte A

Gruß Matze


  

Betrifft: AW: Besser so : =ZÄHLENWENN(A:A;A1) von: Vulferin
Geschrieben am: 08.10.2014 23:06:16

Wie gebe ich das in Vba ein ?


  

Betrifft: AW: Besser so : =ZÄHLENWENN(A:A;A1) von: Vulferin
Geschrieben am: 09.10.2014 06:46:02

Wie gebe ich das in Vba ein ?


  

Betrifft: AW: Inhalt aus Textbox 4 in spalte D zählen von: Daniel
Geschrieben am: 08.10.2014 23:38:20

Hi

wenn in der Tabelle die Nummern als Zahl stehen und Ganzzahlen sind:

Textbox8.Text = Worksheetfunction.CountIf(Columns(4), Val(TextboxDaWoDieNummerDrinsteht.Text))

Gruß Daniel


  

Betrifft: AW: Inhalt aus Textbox 4 in spalte D zählen von: Vulferin
Geschrieben am: 09.10.2014 07:09:03

Supi hat geklappt :=
Danke euch

Wie kann ich beim Start der Userform
Alle Autofilter auf 0 setzen
Hin und wieder wird vergessen vor dem Beenden die Autofilter zurück zu setzen.


  

Betrifft: AW: Inhalt aus Textbox 4 in spalte D zählen von: Daniel
Geschrieben am: 09.10.2014 10:43:36

HI
für jedes Tabellenblatt:

On Error Resume Next
ActiveSheet.ShowAllData
On Error Goto 0
etwas eleganter wäre, zu prüfen ob auf dem Blatt der Autofilter aktiv ist, aber da kann ich mir nie merken mit welcher Abfrage das genau geht.

Gruß Daniel


  

Betrifft: AW: Inhalt aus Textbox 4 in spalte D zählen von: Vulferin
Geschrieben am: 09.10.2014 12:09:54

danke dir :)


 

Beiträge aus den Excel-Beispielen zum Thema "Inhalt aus Textbox 4 in spalte D zählen"