Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhalt aus Textbox 4 in spalte D zählen
08.10.2014 22:34:29
Vulferin
Hallo zusammen
ich hab in meiner Userform eine Nr stehen
ich würde gerne zählen wie oft ich diese nr in Spalte d habe.
und diese dann in Textbox 8 anzeigen lassen
Könnt ihr mir nen tip geben ?

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Funktion Häufigkeit ? owT
08.10.2014 22:42:49
Matze

Besser so : =ZÄHLENWENN(A:A;A1)
08.10.2014 22:49:40
Matze
Hallo Vulverin,
wobei A1 auch direkt durch das Suchkriterium ersetzt werden kann
=ZÄHLENWENN(A:A;5) zählt alle 5en der Spalte A
Gruß Matze

AW: Besser so : =ZÄHLENWENN(A:A;A1)
08.10.2014 23:06:16
Vulferin
Wie gebe ich das in Vba ein ?

AW: Besser so : =ZÄHLENWENN(A:A;A1)
09.10.2014 06:46:02
Vulferin
Wie gebe ich das in Vba ein ?

AW: Inhalt aus Textbox 4 in spalte D zählen
08.10.2014 23:38:20
Daniel
Hi
wenn in der Tabelle die Nummern als Zahl stehen und Ganzzahlen sind:
Textbox8.Text = Worksheetfunction.CountIf(Columns(4), Val(TextboxDaWoDieNummerDrinsteht.Text))
Gruß Daniel

AW: Inhalt aus Textbox 4 in spalte D zählen
09.10.2014 07:09:03
Vulferin
Supi hat geklappt :=
Danke euch
Wie kann ich beim Start der Userform
Alle Autofilter auf 0 setzen
Hin und wieder wird vergessen vor dem Beenden die Autofilter zurück zu setzen.

Anzeige
AW: Inhalt aus Textbox 4 in spalte D zählen
09.10.2014 10:43:36
Daniel
HI
für jedes Tabellenblatt:
On Error Resume Next
ActiveSheet.ShowAllData
On Error Goto 0
etwas eleganter wäre, zu prüfen ob auf dem Blatt der Autofilter aktiv ist, aber da kann ich mir nie merken mit welcher Abfrage das genau geht.
Gruß Daniel

AW: Inhalt aus Textbox 4 in spalte D zählen
09.10.2014 12:09:54
Vulferin
danke dir :)

362 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Links zu Excel-Dialogen

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige