Anzahl Zeichen in Tabellenblatt eruieren

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: Anzahl Zeichen in Tabellenblatt eruieren von: Rudi
Geschrieben am: 22.02.2005 14:38:51

Hallo zusammen

Ich möchte von einer Datei nur diejenigen Blätter ausdrucken lassen, die geändert worden sind. Nun lässt sich ja mittels des Workbook_SheetChange()- Ereignisses feststellen, welches diese Blätter sind.

Jetzt kann es aber sein, dass der Benutzer ein Sheet ändert, die Änderung aber vor dem Druck wieder zurücknimmt (weil er merkt, dass es eine "Verschlimmbesserung" war; gar nicht so seltener Fall).

Frage: Wie lässt sich dieses Problem lösen? Gibt es eine Möglichkeit, die Anzahl Zeichen in einem Blatt zu zählen? Gibt es dafür allenfalls bereits eine Eigenschaft?

Danke für eure Hilfe!

Gruss Rudi

Bild


Betrifft: AW: Anzahl Zeichen in Tabellenblatt eruieren von: Sven
Geschrieben am: 22.02.2005 15:18:03

Inwiefern ist denn die Anzahl der Zeichen ein sicherer Beweis für einen Änderung?

mfg Sven


Bild


Betrifft: AW: Anzahl Zeichen in Tabellenblatt eruieren von: Boris
Geschrieben am: 22.02.2005 15:23:10

Hi Rudi,

Gibt es eine Möglichkeit, die Anzahl Zeichen in einem Blatt zu zählen?

Die gibt es - und zwar per Formel:
=SUMMENPRODUKT(LÄNGE(A1:Z100))
zählt alle Zeichen im Bereich A1:Z100.

In VBA kann man das so übersetzen:

Option Explicit

Sub anzahl_zeichen()
Dim myRange As Range, str As String
Set myRange = [a1:z100]
str = "=SUMPRODUCT(LEN(" & myRange.Address & "))"
MsgBox Evaluate(str)
End Sub


Möglicherweise reicht dir das ja schon.

Grüße Boris


Bild


Betrifft: AW: Anzahl Zeichen in Tabellenblatt eruieren von: Rudi
Geschrieben am: 22.02.2005 16:22:29

Vielen Dank, Boris. Dies reicht bestimmt.

Sven, zu deiner Frage: Ein sicherer Beweis ist es nicht...

Gruss Rudi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Anzahl Zeichen in Tabellenblatt eruieren"