Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema SpinButton
BildScreenshot zu SpinButton SpinButton-Seite mit Beispielarbeitsmappe aufrufen

Zahlen bedingt eintragen | Herbers Excel-Forum


Betrifft: Zahlen bedingt eintragen von: Frank H.
Geschrieben am: 31.01.2010 14:49:47

Hallo Zusammen!

Einen fantastischen Sonntag euch Allen!!!

Ich würde gerne wenn in Zelle U3 die Zahl 48 steht, dass die Zahlen 1 - 48 ab U5 untereinander eingetragen werden, also 1 - 48. Steht aber die Zahl 12 in Zelle U3 , dann sollen auch nur die Zahlen 1-12 eingetragen werden. Die Zahl in Zelle U3 ist immer veränderbar. Könnt ihr mir helfen??? Danke im Voraus!!!

Gruß Frank H!

  

Betrifft: AW: Zahlen bedingt eintragen von: Tino
Geschrieben am: 31.01.2010 14:56:06

Hallo,
in die Zelle U5

=WENN(ZEILE(A1)>$U$3;"";ZEILE(A1))

und soweit runder kopieren wie maximal benötigt.

Gruß Tino


  

Betrifft: AW: Zahlen bedingt eintragen von: Hajo_Zi
Geschrieben am: 31.01.2010 14:58:00

Halo Frank,
die letzte Formel soweit runterziehen wie notwendig.

Tabelle1

 U
312
4 
51
62
73
84
95
106
117
128
139
1410
1511
1612
17 
18 
19 
20 
21 

verwendete Formeln
Zelle Formel
U5 =WENN(U3="";"";1)
U6 =WENN(U5="";"";WENN(U5+1>$U$3;"";U5+1))
U7 =WENN(U6="";"";WENN(U6+1>$U$3;"";U6+1))
U8 =WENN(U7="";"";WENN(U7+1>$U$3;"";U7+1))
U9 =WENN(U8="";"";WENN(U8+1>$U$3;"";U8+1))
U10 =WENN(U9="";"";WENN(U9+1>$U$3;"";U9+1))
U11 =WENN(U10="";"";WENN(U10+1>$U$3;"";U10+1))
U12 =WENN(U11="";"";WENN(U11+1>$U$3;"";U11+1))
U13 =WENN(U12="";"";WENN(U12+1>$U$3;"";U12+1))
U14 =WENN(U13="";"";WENN(U13+1>$U$3;"";U13+1))
U15 =WENN(U14="";"";WENN(U14+1>$U$3;"";U14+1))
U16 =WENN(U15="";"";WENN(U15+1>$U$3;"";U15+1))
U17 =WENN(U16="";"";WENN(U16+1>$U$3;"";U16+1))
U18 =WENN(U17="";"";WENN(U17+1>$U$3;"";U17+1))
U19 =WENN(U18="";"";WENN(U18+1>$U$3;"";U18+1))
U20 =WENN(U19="";"";WENN(U19+1>$U$3;"";U19+1))
U21 =WENN(U20="";"";WENN(U20+1>$U$3;"";U20+1))

Tabellendarstellung in Foren Version 5.6



GrußformelHomepage


  

Betrifft: AW: Zahlen bedingt eintragen von: Frank H.
Geschrieben am: 31.01.2010 15:06:03

Hallo Ihr Zwei!!!

Ich habe wie so oft zu kompliziert gedacht, da hätte ich selber drauf kommen können!!! Danke euch beiden, funzt natürlich bestens!!!

Schönen Sonntag noch!!!

Danke und Gruß!!!


Beiträge aus den Excel-Beispielen zum Thema "Zahlen bedingt eintragen"