Microsoft Excel

Herbers Excel/VBA-Archiv

Nullwerte | Herbers Excel-Forum


Betrifft: Nullwerte von: anke2245
Geschrieben am: 31.01.2010 14:36:11

Hallo, liebe Experten,
wie kann ich ausgeblendete Nullwerte wieder sichtbar machen, wenn ich als Eingabe ein 0:0 habe.
Ich addiere auf einer Tabelle alle 0:0 Ergebnisse mit der Formel: ZÄHLENWENN
Ausblenden bei einer Verknüpfung indem ich "0" eingebe.
Habe ich aber ein 0:0 Ergebnis, kommt es nicht zur Addition ?
Kann mir jemand einen Tipp geben?
Danke"Anke"

  

Betrifft: AW: Nullwerte von: anke2245
Geschrieben am: 31.01.2010 16:06:15

falsch erklärt.
ich möchte anhand einer Tabelle wissen, wie viele Mitspieler, von 180 Spieler und 150 Spielen, 0:0 getippt haben.
Wenn ich die Formel WENN(UND einsetze, werden alle Zellen, in den nichts enthalten ist, schon addiert; also Ergenis: 180 x 150 = 27000
Dieses möchte ich verhindern, denn es hat ja noch niemand getippt.
Ich habe schon versucht, bei der WENN Formel die Null mit "" einzugeben; doch wenn ich das 0:0 Tippergebnis eintrage, bleibt immer noch die Zahl 27000 stehen.
Was tun ?
Danke " Anke "


  

Betrifft: nicht sicher... von: Tino
Geschrieben am: 31.01.2010 17:04:39

Hallo,
habe Deinen Beitrag jetzt drei Mal durchgelesen und bin mir immer noch nicht sicher
ob Du es so meinst.

=Zählenwenn(B1:B150;"0:0")
B1:B150 ist der Bereich wo 0:0 drin steht.


Gruß Tino


  

Betrifft: AW: nicht sicher... von: anke2245
Geschrieben am: 31.01.2010 18:04:47

Ja, Tino,
Du bist schon auf dem richtigen Weg;
doch wenn ich das Ergebnis 0:0 eintrage, ändert sich am Ergebnis nichts.
Beispiel: B1:B150 = 150 x 0:0 wenn ich es ohne "" eingegeben habe.
B1:B150 = 0 x , wenn ich die Formel WENN(UND( B1="0";E1="0");1) eingegeben habe.
Trage ich jetzt unter B1 und E1 0:0 ein, müßtte in dem Ergenis 1 erscheinen; das tut es aber nicht.
Wenn ich es könnte, würde ich ein Beispiel der Tabelle geben.
Danke " Anke "


  

Betrifft: AW: nicht sicher... von: Tino
Geschrieben am: 31.01.2010 18:32:42

Hallo,
also es steht in B1 nicht 0:0, sonder nur 0 und in E1 die andere 0

Vieleicht so.

 BCDE
10  0
20  0
31  0
4    
52   

Formeln der Tabelle
ZelleFormel
B5=SUMMENPRODUKT((B1:B3+E1:E3=0)*1)


Gruß Tino


  

Betrifft: AW: nicht sicher... von: anke2245
Geschrieben am: 31.01.2010 18:45:40

Danke Timo,
ich hoffe, es klappt.
Danke " Anke "


  

Betrifft: oder besser so von: Tino
Geschrieben am: 31.01.2010 18:56:49

Hallo,
, damit leere Zellen nicht mitgezählt werden.

 BCDEFGHI
10  0  Zähle 
20  0  00
31  0 Anzahl3 
40  0    
5        

Formeln der Tabelle
ZelleFormel
H3=SUMMENPRODUKT(((B1:B150=H2)*(E1:E150=I2)*(B1:B150<>"")*(E1:E150<>""))*1)


Gruß Tino


  

Betrifft: AW: oder besser so von: anke2245
Geschrieben am: 31.01.2010 20:20:01

Hallo Timo,
klappt nicht;
genau so habe ich es vorher auch gehabt.
Dieser Formel nach, zähle ich ja alle Nullen zusammen, die sich in der Spalte befinden;
ich möchte aber nur die Nullen addieren, die ich eingetragen habe.
noch einmal ein Beispiel: Leere Spalten B1 : B 150 = 0 ergibt Summe 150 ich möchte aber Ergebnis 0 haben.
Eintragung Spalte B1 : B 150 ; B5, B28 = 0 ; Summe = 2
Jetzt verständlich erklärt ?
Danke " Anke "


  

Betrifft: wieder mit Zählenwenn von: Tino
Geschrieben am: 31.01.2010 20:37:21

Hallo,
so gehjt es bei mir.

 ABC
1  2
2 0 
3   
4   
5   
6 0 
7   
8   

Formeln der Tabelle
ZelleFormel
C1=ZÄHLENWENN(B1:B150;0)


Gruß Tino


Beiträge aus den Excel-Beispielen zum Thema "Nullwerte"