Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zeichen entfernen + Text in Zahl umwandeln

Zeichen entfernen + Text in Zahl umwandeln
Nontacky
Hallo Allerseits,
wie so oft habe ich eine Frage und freue mich darauf, dass einer von euch diese wieder beantworten kann.
Meine liebe Bank ist nicht in der Lage CSV Kontodaten anzubieten. Deswegen muss ich meine Kontodaten vom Online Konto - also aus der HTML Seite in Excel kopieren. Das kriege ich soweit ganz gut hin, aber ich habe ein Formatproblem mit den Zahlen. Diese kommen in Excel nicht als Zahl an, sondern als Text.
Also z.B. so:
Spalte A
Ausgaben
1.000,00-
100,00-
Spalte B
Einnahmen
1.000,00+
100,00+
Jetzt wüsste ich gerne wie ich in einem Schritt - OHNE MAKRO - einfach nur über eine Formel in Spalte C und Spalte D aus den "Textzahlen" in Spalte A und B richtige Zahlen mache, die von Excel zum Rechnen verwendet werden können.
Ich habe über die "Wechseln" Funktion schon den Punkt und das + bzw. - entfernt, aber der Zellinhalt bleibt immer ein Text und wird nicht zur Zahl.
Wer hat eine Idee?
Vielen Dank,
Nontacky
AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 19:30:21
Hajo_Zi
Hallo,
es intressieren also nicht der Unterschied zwischen - und +
Multiplikation mit 1
Schreibe eine 1 in eine Zelle, diese Zelle kopieren, markiere Deinen Bereich, rechte Maustaste, Inhalte einfügen, im Dialog auswählen Multiplikation und ok
oder
Daten, Text in Spalten, Zellen vorher als Standard, Zahl formatieren

AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 19:58:12
Nontacky
Hallo Hajo,
vielen Dank für die schnelle Antwort. Das mit dem "Text in Spalten" klappt gut. Du hast mich aber jetzt natürlich auf eine Idee gebracht, dass es evtl. auch möglich ist die Zahlen direkt aus einer Spalte in positive und negative Zahlen umzuwandeln. Also:
Spalte A
Betrag
-1.000,00
+1.000,00
-100,00
+100,00
im besten Fall wird das über eine Formel gelöst, so dass ich in Spalte B eine Formel stehen habe, die den Text in Spalte A der den Betrag vom Konto anzeigt direkt in die richtige Zahl umwandelt.
Geht das auch?
Vielen Dank,
Nontacky
Anzeige
AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 20:02:45
Uduuh
Hallo,
wenn das so als Text in A steht, B2: =A2*1
Gruß aus’m Pott
Udo

AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 20:09:43
Hajo_Zi
Hallo Udo,
aus irgeneinem Grunde geht das nicht.
Tabelle1
 ABC
32'1.000,00--1000#WERT!
33'100,00--100#WERT!
34  00
35Spalte BSpalte B#WERT!
36EinnahmenEinnahmen#WERT!
37'1.000,00+1000#WERT!
38'100,00+100#WERT!

verwendete Formeln
Zelle Formel Bereich
B32 =WENN(RECHTS(A32;1)="-";LINKS(A32;LÄNGE(A32)-1)*-1;WENN(RECHTS(A32;1)="+";LINKS(A32;LÄNGE(A32)-1)*1;A32)) 
C32 =A32*1 
B33 =WENN(RECHTS(A33;1)="-";LINKS(A33;LÄNGE(A33)-1)*-1;WENN(RECHTS(A33;1)="+";LINKS(A33;LÄNGE(A33)-1)*1;A33)) 
C33 =A33*1 
B34 =WENN(RECHTS(A34;1)="-";LINKS(A34;LÄNGE(A34)-1)*-1;WENN(RECHTS(A34;1)="+";LINKS(A34;LÄNGE(A34)-1)*1;A34)) 
C34 =A34*1 
B35 =WENN(RECHTS(A35;1)="-";LINKS(A35;LÄNGE(A35)-1)*-1;WENN(RECHTS(A35;1)="+";LINKS(A35;LÄNGE(A35)-1)*1;A35)) 
C35 =A35*1 
B36 =WENN(RECHTS(A36;1)="-";LINKS(A36;LÄNGE(A36)-1)*-1;WENN(RECHTS(A36;1)="+";LINKS(A36;LÄNGE(A36)-1)*1;A36)) 
C36 =A36*1 
B37 =WENN(RECHTS(A37;1)="-";LINKS(A37;LÄNGE(A37)-1)*-1;WENN(RECHTS(A37;1)="+";LINKS(A37;LÄNGE(A37)-1)*1;A37)) 
C37 =A37*1 
B38 =WENN(RECHTS(A38;1)="-";LINKS(A38;LÄNGE(A38)-1)*-1;WENN(RECHTS(A38;1)="+";LINKS(A38;LÄNGE(A38)-1)*1;A38)) 
C38 =A38*1 

Tabellendarstellung in Foren Version 5.48


Gruß Hajo
Anzeige
AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 21:04:35
Uduuh
Hallo Hajo,
ich habe seinen letzten Beitrag so verstanden, dass er -100, +100 als Text in A hat. und dann geht das.
AB
1
2-100-100
3+100100

ZelleFormatWert
A1@
A2@-100
A3@+100

ZelleFormel
B2=A2*1
B3=A3*1

Wenn Vorzeichen hinten, kann man das auch erheblich kürzer lösen.
AB
1TextBetrag
2100--100
3200+200

ZelleFormel
B2=(RECHTS(A2;1)& LINKS(A2;LÄNGE(A2)-1))+0
B3=(RECHTS(A3;1)& LINKS(A3;LÄNGE(A3)-1))+0

Gruß aus’m Pott
Udo

Anzeige
AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 20:06:41
Hajo_Zi
von einer zusätzlichen Spalte war im ersten Beitrag nicht die Rede.
Tabelle1
 AB
32'1.000,00--1000
33'100,00--100
34  0
35Spalte BSpalte B
36EinnahmenEinnahmen
37'1.000,00+1000
38'100,00+100

verwendete Formeln
Zelle Formel Bereich
B32 =WENN(RECHTS(A32;1)="-";LINKS(A32;LÄNGE(A32)-1)*-1;WENN(RECHTS(A32;1)="+";LINKS(A32;LÄNGE(A32)-1)*1;A32)) 
B33 =WENN(RECHTS(A33;1)="-";LINKS(A33;LÄNGE(A33)-1)*-1;WENN(RECHTS(A33;1)="+";LINKS(A33;LÄNGE(A33)-1)*1;A33)) 
B34 =WENN(RECHTS(A34;1)="-";LINKS(A34;LÄNGE(A34)-1)*-1;WENN(RECHTS(A34;1)="+";LINKS(A34;LÄNGE(A34)-1)*1;A34)) 
B35 =WENN(RECHTS(A35;1)="-";LINKS(A35;LÄNGE(A35)-1)*-1;WENN(RECHTS(A35;1)="+";LINKS(A35;LÄNGE(A35)-1)*1;A35)) 
B36 =WENN(RECHTS(A36;1)="-";LINKS(A36;LÄNGE(A36)-1)*-1;WENN(RECHTS(A36;1)="+";LINKS(A36;LÄNGE(A36)-1)*1;A36)) 
B37 =WENN(RECHTS(A37;1)="-";LINKS(A37;LÄNGE(A37)-1)*-1;WENN(RECHTS(A37;1)="+";LINKS(A37;LÄNGE(A37)-1)*1;A37)) 
B38 =WENN(RECHTS(A38;1)="-";LINKS(A38;LÄNGE(A38)-1)*-1;WENN(RECHTS(A38;1)="+";LINKS(A38;LÄNGE(A38)-1)*1;A38)) 

Tabellendarstellung in Foren Version 5.48


Gruß Hajo
Anzeige
AW: Zeichen entfernen + Text in Zahl umwandeln
15.03.2012 20:25:50
Nontacky
hallo Hajo & Udo,
die Lösung von HaJo klappt - ihr wisst schon, dass ihr Excel Götter seid, oder? Der Wahnsinn, hilft mir sehr weiter.
Vielen Dank!
AW: Zeichen entfernen + Text in Zahl umwandeln
16.03.2012 07:51:05
ing.grohn
Hallo ....
ich denke das Problem liegt in dem + rechts von der "Text"-Zahl.
Wenn ich mit Daten Text in Spalten als Trennzeichen "+" angebe, funktioniert das auch ohne Hilfszeilen. Die negativen Zahlen werden problemlos übernommen.
Mit freundlichen Grüßen
Albrecht

249 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige