Herbers Excel-Forum - das Archiv

Text in Zahl umwandeln

Bild

Betrifft: Text in Zahl umwandeln
von: Tom

Geschrieben am: 24.12.2006 14:52:47
Hallo!
Ich habe folgendes Problem:
Ich habe aus einer Zelle mit Zahlen und Texten die Zahlen herausgelös.
Beim Vesuch, mit diesen herausgelösten Zahlen zu rechnen (z. B. Multiplikation *1), bekomme ich nun aber die Fehlermeldung "WERT".
Ist es möglich, die herausgelöste Zahl so umzukonvertieren, damit man damit auch rechnen kann?
Wäre für eure Hilfe sehr dankbar!
LG
Tom
Bild

Betrifft: AW: Text in Zahl umwandeln
von: M@x
Geschrieben am: 24.12.2006 15:47:00
Hi Tom,
da man normalerweise aus "Textzahlen" Zahlen macht, indem man mit 1 multipliziert, steh ich etwas ratlos da.
erzählmal, mir du die Zahlen herausgelöst hast oder lad einen Beispielfile hoch, dann gehts am schnellsten
Gruss
M@x
Bild

Betrifft: AW: Text in Zahl umwandeln
von: Korl

Geschrieben am: 24.12.2006 18:43:18
Hallo M@x,
 
 ABC
1Test123123246
Formeln der Tabelle
B1 : =RECHTS(A1;3)
C1 : =B1*1*2
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Korl
Bild

Betrifft: AW: Text in Zahl umwandeln
von: jockel

Geschrieben am: 25.12.2006 14:43:36
hi Tom, bei formelfragen empfiehlt sich immer erst ein blick nach http://www.excelformeln.de - dort findest du auch:
Tabelle1
 ABCD
11qw23er4512345224690
2Test123123 246
301qw96er78019678 39356
4Test123123 246
Formeln der Tabelle
B1 : {=SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE(1:256);1)*1);ZEILE(1:256);1);ZEILE(1:256));1)*1)*10^(ZEILE(1:256)-1))}
D1 : =$C$1*B1
B2 : {=SUMME((TEIL(0&A2;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A2;ZEILE(1:256);1)*1);ZEILE(1:256);1);ZEILE(1:256));1)*1)*10^(ZEILE(1:256)-1))}
D2 : =$C$1*B2
B3 : {=TEXT(SUMME((TEIL(0&A3;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A3;ZEILE(1:256);1)*1);ZEILE(1:256);1);ZEILE(1:256));1)*1)*10^(ZEILE(1:256)-1));WIEDERHOLEN(0;SUMME(ISTZAHL(TEIL(A3;ZEILE(1:256);1)*1)*1)))}
D3 : =$C$1*B3
B4 : =RECHTS(A4;3)
D4 : =$C$1*B4
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
 Bild
Excel-Beispiele zum Thema "Text in Zahl umwandeln"
Abkürzungen umwandeln URLs eines ausgewählten Bereiches in HyperLinks umwandeln
Textstring in berechenbare Formel umwandeln Als Text vorhandene Werte in Zahlen umwandeln
Zeichen in Zeichenfolgen umwandeln und Leerzeichen entfernen TextBox-Eingaben im Format TTMMJJ in gültiges Datum umwandeln
5-Längen-Zeichenfolgen in Zeit mit Format mss,00 umwandeln Zeichenfolgen über Doppelklick in externen Bezug umwandeln.
Alle "u" bis zum aktuellen Datum in "U" umwandeln Strings, die wie Zahlen aussehen, in Zahlen umwandeln