Herbers Excel-Forum - das Archiv

Felder in ein Datum umwandeln



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Felder in ein Datum umwandeln
von: Bernd


Geschrieben am: 22.05.2002 - 13:32:33

Hallo,

ich habe in einer Excel-Tabelle 3 Spalten (A, B, C) mit folgenden Informationen (Tag: z.B. Mittwoch; Kalenderwoche: z.B. 21, Jahr: z.B. 2002). Ich möchte erreichen, dass in die 4. Spalte (D) das dazugehörige Datum (22.05.2002)über eine VBA-Prozedur geschrieben wird. Ist dies mit VBA möglich?

Gruß
Bernd

nach oben   nach unten

Re: Felder in ein Datum umwandeln
von: Frank_

Geschrieben am: 22.05.2002 - 13:40:36

Hallo Bernd,

hätte eine Lösung mit Formel:
Schreibe in D1 --> =(A1&"."&B1&"."&C1)*1 und formatiere auf Datumsformat.

Gruß Frank

nach oben   nach unten

Re: Felder in ein Datum umwandeln
von: Andreas


Geschrieben am: 22.05.2002 - 14:24:56

Hallo Bernd,

jetzt nicht erschrecken, hier eine Lösung OHNE VBA. Ist ne ziemlich lange Formel geworden, dafür aber in einer Zelle!
Wenn in Zelle A2: Mittwoch (Wochentag als Text)
in Zelle B2: 21 (Kalenderwoche)
in Zelle C2: 2002 (Jahreszahl)
dann liefert diese Formel, den dazu gehörenden Tag:

=SUMME(WENN(KÜRZEN((DATUM(C2;1;1)+ZEILE(A1:A365)-1-WOCHENTAG(DATUM(C2;1;1)+ZEILE(A1:A365)-1;2)-DATUM(JAHR(DATUM(C2;1;1)+ZEILE(A1:A365)-1+4-WOCHENTAG(DATUM(C2;1;1)+ZEILE(A1:A365)-1;2));1;-10))/7)=B2;WENN(GROSS(A2)=WAHL(WOCHENTAG(DATUM(C2;1;1)+ZEILE(A1:A365)-1;2);"MONTAG";"DIENSTAG";"MITTWOCH";"DONNERSTAG";"FREITAG";"SAMSTAG";"SONNTAG");DATUM(C2;1;1)+ZEILE(A1:A365)-1;0);0))
Diese Formel ist eine Array-Formel, deswegen mit STRG+SHIFT+ENTER abschließen!!!
Die Zelle (Spalte) in der die Formel steht, bitte mit dem gewünschten Datumsformat formatieren!

Viel Spaß,
Andreas

PS: Darin enthalten ist Formel 7 von www.excelformeln.de zur Bestimmung der Kalenderwoche!!!

nach oben   nach unten

Re: Felder in ein Datum umwandeln
von: Bernd


Geschrieben am: 22.05.2002 - 14:28:48

Hallo Frank,

funktioniert leider nicht richtig. Wenn ich die Formel einschließlich *1 eingebe, erscheint in Spalte D #WERT.
Wenn ich *1 entferne, erscheint dort Mittwoch.21.2002.
Ich bräuchte in Spalte D jedoch das folgende Ergebnis: 22.05.2002.

Gruß
Bernd

nach oben   nach unten

Re: Felder in ein Datum umwandeln
von: Bernd
Geschrieben am: 23.05.2002 - 06:14:27

Hallo Andreas,

vielen Dank für Deine Formel. Funktioniert super!!!

Gruß
Bernd


 nach oben

Excel-Beispiele zum Thema "Felder in ein Datum umwandeln"
Freiraum am linken Rand von MS-FORMS-Textfeldern löschen Felder über VBA sortieren
Textfelder in UserForm beim Start vorbelegen ComboBox-Felder in UserForm aufklappen
Gruppe von Optionsfeldern kopieren und Makro zuweisen Synchronisieren von Optionsfeldern in verschiedenen Blättern
UserForm-Optionsfelder prüfen Selektieren von über ComboBox-Felder ausgewählten Werten
UserForm-Optionsfelder über eine Schleife zurücksetzen Wert aus Optionsfelder in verschiedenen Frames auslesen