Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Kalenderwoche in Datum ??????

Kalenderwoche in Datum ?
19.10.2008 11:49:00
ReSt
Hallo
Ich möchte gerne jeweils im MOntagsdatum die Kalenderwoche integriert haben. Also in der gleichen Zelle. Leider habe ich bis jetzt noch keine Lösung gefunden. Entweder hatte ich Probleme mit dem Format oder ich bekam einen Zirkelbezug.
Villeicht kann mir jemand weiterhelfen ? Danke
Reto
Kal

 ABCD
1   Schnellkalender
2 2007  
3 JanFebMrz
4 01 Mo01 Do01 Do
5 02 Di02 Fr02 Fr
6 03 Mi03 Sa03 Sa
7 04 Do04 So04 So
8 05 Fr05 Mo05 Mo
9 06 Sa06 Di06 Di
10 07 So07 Mi07 Mi
11 08 Mo08 Do08 Do
12 09 Di09 Fr09 Fr
13 10 Mi10 Sa10 Sa
14 11 Do11 So11 So
15 12 Fr12 Mo12 Mo
16 13 Sa13 Di13 Di
17 14 So14 Mi14 Mi
18 15 Mo15 Do15 Do
19 16 Di16 Fr16 Fr
20 17 Mi17 Sa17 Sa
21 18 Do18 So18 So
22 19 Fr19 Mo19 Mo
23 20 Sa20 Di20 Di
24 21 So21 Mi21 Mi

Formeln der Tabelle
ZelleFormel
B4=DATUM($B$2;1;1)
C4=DATUM($B$2;2;1)
D4=DATUM($B$2;3;1)
B5=B4+1
C5=C4+1
D5=D4+1
B6=B5+1
C6=C5+1
D6=D5+1
B7=B6+1
C7=C6+1
D7=D6+1
B8=B7+1
C8=C7+1
D8=D7+1
B9=B8+1
C9=C8+1
D9=D8+1
B10=B9+1
C10=C9+1
D10=D9+1
B11=B10+1
C11=C10+1
D11=D10+1
B12=B11+1
C12=C11+1
D12=D11+1
B13=B12+1
C13=C12+1
D13=D12+1
B14=B13+1
C14=C13+1
D14=D13+1
B15=B14+1
C15=C14+1
D15=D14+1
B16=B15+1
C16=C15+1
D16=D15+1
B17=B16+1
C17=C16+1
D17=D16+1
B18=B17+1
C18=C17+1
D18=D17+1
B19=B18+1
C19=C18+1
D19=D18+1
B20=B19+1
C20=C19+1
D20=D19+1
B21=B20+1
C21=C20+1
D21=D20+1
B22=B21+1
C22=C21+1
D22=D21+1
B23=B22+1
C23=C22+1
D23=D22+1
B24=B23+1
C24=C23+1
D24=D23+1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Kalenderwoche in Datum ?
19.10.2008 12:17:00
Daniel
Hi
das wird so nicht funktionieren.
wenn du in den Zellen die Kalenderwoche mit anzeigen lässt, hast du keinen datumswert mehr drinstehen, sondern einen Text und zu einem Text kannst du nicht den Wert +1 für den nächsten Tag hinzu addieren.
wenn könnte folgende Formel in B4 funktionieren:
= Text(Datum($B$2;Spalte()-1;Zeile()-3);"TT TTT")&" KW "&...'hier Formel für Kalenderwoche eintragen
diese Formel kannst du sowohl nach unten als auch nach rechts kopieren.
innerhalb der Formel für die Kalenderwochenberechnung musst du das gleiche Datum verwenden, wie im Teil davor: Datum($B$2;Spalte()-1;Zeile()-3)
Gruß, Daniel
Anzeige
AW: Kalenderwoche in Datum ?
19.10.2008 12:49:29
ReSt
Hallo
Besten Dank für die Mühe, aber auch hier bekomme ich einen Zirkelbezug wenn ich die Formel der Kalenderwoche einfüge.
=WENN(WOCHENTAG(B4)=4;KÜRZEN((B4-WOCHENTAG(B4;2)-DATUM(JAHR(B4+4-WOCHENTAG(B4;2));1;-10))/7);"")
Reto
AW: Kalenderwoche in Datum ?
19.10.2008 21:48:00
Daniel
Hi
ist doch klar, eine Formel kann nicht ihr eigenes Ergebnis verarbeiten, dh wenn die Formel in B4 steht, darf sie nicht B4 als Zellbezug enthalten.
deswegen schrieb ich ja auch, daß du in der Kalenderwochenformel die Zellbezüge zum Datumswert durch die neue Datumsberechnung ersezten musst, dh, du musst in der Formel:
=WENN(WOCHENTAG(B4)=4;KÜRZEN((B4-WOCHENTAG(B4;2)-DATUM(JAHR(B4+4-WOCHENTAG(B4;2));1;-10))/7);"")

jedes B4 durch Datum($B$2;Spalte()-1;Zeile()-3) ersetzen:
=WENN(WOCHENTAG(Datum($B$2;Spalte()-1;Zeile()-3))=4;KÜRZEN((Datum($B$2;Spalte()-1;Zeile()-3)-WOCHENTAG(Datum($B$2;Spalte()-1;Zeile()-3);2)-DATUM(JAHR(Datum($B$2;Spalte()-1;Zeile()-3)+4-WOCHENTAG(Datum($B$2;Spalte()-1;Zeile()-3);2));1;-10))/7);"")

Gruß, Daniel
Anzeige
AW: Kalenderwoche in Datum ?
19.10.2008 12:24:10
Tino
Hallo,
hier mal zwei Möglichkeiten.
Rechnen kannst Du aber nicht mehr damit, die Formel kannst Du aber nach unten und nach rechts ziehen..
 BCD
5JanuarFebruarMärz
6KW:1 01 Mo 01 Do 01 Do
7 02 Di 02 Fr 02 Fr
8 03 Mi 03 Sa 03 Sa
9 04 Do 04 So 04 So
10 05 FrKW:6 05 MoKW:10 05 Mo
11 06 Sa 06 Di 06 Di
12 07 So 07 Mi 07 Mi
13KW:2 08 Mo 08 Do 08 Do
14 09 Di 09 Fr 09 Fr
15 10 Mi 10 Sa 10 Sa

Formeln der Tabelle
ZelleFormel
B6=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A1)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A1))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A1))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A1))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A1)); "TT TTT")
C6=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A1)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A1))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A1))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A1))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A1)); "TT TTT")
D6=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A1)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A1))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A1))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A1))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A1)); "TT TTT")
B7=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A2)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A2))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A2))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A2))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A2)); "TT TTT")
C7=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A2)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A2))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A2))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A2))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A2)); "TT TTT")
D7=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A2)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A2))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A2))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A2))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A2)); "TT TTT")
B8=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A3)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A3))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A3))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A3))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A3)); "TT TTT")
C8=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A3)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A3))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A3))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A3))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A3)); "TT TTT")
D8=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A3)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A3))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A3))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A3))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A3)); "TT TTT")
B9=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A4)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A4))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A4))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A4))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A4)); "TT TTT")
C9=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A4)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A4))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A4))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A4))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A4)); "TT TTT")
D9=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A4)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A4))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A4))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A4))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A4)); "TT TTT")
B10=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A5)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A5))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A5))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A5))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A5)); "TT TTT")
C10=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A5)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A5))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A5))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A5))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A5)); "TT TTT")
D10=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A5)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A5))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A5))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A5))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A5)); "TT TTT")
B11=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A6)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A6))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A6))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A6))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A6)); "TT TTT")
C11=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A6)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A6))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A6))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A6))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A6)); "TT TTT")
D11=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A6)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A6))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A6))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A6))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A6)); "TT TTT")
B12=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A7)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A7))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A7))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A7))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A7)); "TT TTT")
C12=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A7)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A7))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A7))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A7))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A7)); "TT TTT")
D12=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A7)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A7))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A7))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A7))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A7)); "TT TTT")
B13=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A8)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A8))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A8))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A8))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A8)); "TT TTT")
C13=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A8)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A8))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A8))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A8))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A8)); "TT TTT")
D13=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A8)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A8))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A8))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A8))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A8)); "TT TTT")
B14=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A9)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A9))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A9))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A9))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A9)); "TT TTT")
C14=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A9)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A9))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A9))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A9))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A9)); "TT TTT")
D14=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A9)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A9))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A9))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A9))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A9)); "TT TTT")
B15=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A10)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A10))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A10))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A10))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A10)); "TT TTT")
C15=WENN(WOCHENTAG(DATUM($B$2;SPALTE(B$1); ZEILE($A10)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(B$1); ZEILE($A10))-DATUM(JAHR(DATUM($B$2;SPALTE(B$1); ZEILE($A10))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(B$1); ZEILE($A10))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(B$1); ZEILE($A10)); "TT TTT")
D15=WENN(WOCHENTAG(DATUM($B$2;SPALTE(C$1); ZEILE($A10)))=2;"KW:"&KÜRZEN((DATUM($B$2;SPALTE(C$1); ZEILE($A10))-DATUM(JAHR(DATUM($B$2;SPALTE(C$1); ZEILE($A10))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(C$1); ZEILE($A10))-2;7)-9))/7); "")&" "&TEXT(DATUM($B$2;SPALTE(C$1); ZEILE($A10)); "TT TTT")

Gruß Tino
Anzeige
AW: Kalenderwoche in Datum ?
19.10.2008 12:48:00
ReSt
Hallo
Ja das wäre in etwa das was ich suche.
Am allerliebsten hätte ich aber, wenn die Kalenderwoche nach dem Datum steht.
Vielleicht kannst du mir das noch einbauen.
Danke und schönner Sonntag
Reto
AW: Kalenderwoche in Datum ?
19.10.2008 12:59:03
Tino
Hallo,
so?
 B
22007
301 Mo KW:1

Formeln der Tabelle
ZelleFormel
B3=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A1)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A1)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A1))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A1))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A1))-2;7)-9))/7); "")

Gruß Tino
Anzeige
AW: Kalenderwoche in Datum ?
19.10.2008 16:48:00
ReSt
Hallo
So sieht es richtig aus. Jedoch ist noch ein Fehler in der Formel. Es zeigt mir nur die Montage an.
Kannst du mir das noch korrigieren?
Reto
AW: Kalenderwoche in Datum ?
19.10.2008 17:35:17
Tino
Hallo,
sorry für den Fehler.
 B
22007
301 Mo KW:1
402 Di
503 Mi
604 Do
705 Fr
806 Sa
907 So
1008 Mo KW:2

Formeln der Tabelle
ZelleFormel
B3=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A1)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A1)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A1))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A1))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A1))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A1)))
B4=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A2)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A2)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A2))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A2))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A2))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A2)))
B5=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A3)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A3)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A3))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A3))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A3))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A3)))
B6=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A4)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A4)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A4))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A4))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A4))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A4)))
B7=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A5)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A5)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A5))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A5))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A5))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A5)))
B8=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A6)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A6)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A6))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A6))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A6))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A6)))
B9=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A7)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A7)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A7))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A7))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A7))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A7)))
B10=WENN(WOCHENTAG(DATUM($B$2;SPALTE(A$1); ZEILE($A8)))=2;TEXT(DATUM($B$2;SPALTE(A$1); ZEILE($A8)); "TT TTT")&" KW:"&KÜRZEN((DATUM($B$2;SPALTE(A$1); ZEILE($A8))-DATUM(JAHR(DATUM($B$2;SPALTE(A$1); ZEILE($A8))+3-REST(DATUM($B$2;1;1)-2;7)); 1;REST(DATUM($B$2;SPALTE(A$1); ZEILE($A8))-2;7)-9))/7); DATUM($B$2;SPALTE(A$1); ZEILE($A8)))

Gruß Tino
Anzeige

316 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige