Microsoft Excel

Herbers Excel/VBA-Archiv

Datum mit in eine Formel einbeziehen

Betrifft: Datum mit in eine Formel einbeziehen
von: Michael
Geschrieben am: 17.04.2003 - 14:10:06

Hallo zusammen,
ich habe mal wieder ein Problem und wieder mal möchte ich euch um eine kleine Hilfe bitten. Es stellt sich wie folgt dar:
Ich versuche mich an einer Aufstellung in der ein Stoff bis zum 19.12.02 80,00 €, ab dem 20.12.02 100,00 € und ab dem 01.01.03 wieder 80,00 € kostet. Und je nachdem was man für ein Datum eingibt soll der richtige Preis erscheinen.
Ich habe keine Ahnung wie, das gehen könnte, da es mit der Wenn-Funktion nicht funktioniert hat fände ich es sehr nett wenn mir jemand helfen könnte

  

Re: Datum mit in eine Formel einbeziehen
von: Christian
Geschrieben am: 17.04.2003 - 14:17:07

Mal angenommen die Daten stehen in Spalte A und die Preise in Spalte B jeweils Zeilen 1 - 3. Das zu prüfende Datum steht in A5 dann schreibst Du
=WENN(A5<=A1;B1;WENN(UND(A5>=A2;A5=A3;B3;0)))

  

Re: Datum mit in eine Formel einbeziehen
von: Peter H. Erdmann
Geschrieben am: 17.04.2003 - 14:21:06

Hallo,
bau Dir eine Preistabelle auf mit Datum und Preis (Bereich A2:B4 als Beispiel)
1. Zeile
Datum ab wann Stoff im Handel und Preis 80,00 Euro
2. Zeile
Datum 20.12.2002 Preis 100,00 Euro
3. Zeile
Datum 1.1.2003 Preis 80,00 Euro

gesuchtes Datum in C1 eingeben
in D1 Formel
=SVERWEIS(D1;A2:B4;2;WAHR)

Gruß aus dem Land der Bayern
und Frohe Ostern
(Eier nicht schütteln, sonst wirds denen schlecht)
Peter



  

Warum nicht Wenn?
von: Harald Kapp
Geschrieben am: 17.04.2003 - 14:21:34

Hallo Michael,
probier mal:

=WENN(A2<=DATUM(2002;12;19);80;WENN(A2<=DATUM(2003;1;1);100;80))

Datum steht in A2

Gruß Harald


  

Re: Datum mit in eine Formel einbeziehen
von: Christian
Geschrieben am: 17.04.2003 - 14:22:22

Sorry vertippt,
=WENN(A5<=A1;B1;WENN(UND(A5>=A2;A5

  

=VERWEIS(B1;{0;37610;37681};{80;100;80})
von: WF
Geschrieben am: 17.04.2003 - 14:29:54

in A1 steht der 20.12.2002
in A2 der 01.03.2003


http://www.excelformeln.de/
die ultimative Formelseite

  

Quatsch: in A1 und B1 steht nichts !
von: WF
Geschrieben am: 17.04.2003 - 14:31:41

.

  

nichts in A2 - ich geh heute besser
von: WF
Geschrieben am: 17.04.2003 - 14:33:09

.

  

=(B1>37609)*(B1<37681)*20+80
von: WF
Geschrieben am: 17.04.2003 - 14:49:43

.

  

Re: Warum nicht Wenn?
von: Michael
Geschrieben am: 17.04.2003 - 14:52:39

Vielen Dank habe es ausprobiert, ging supper.
Ich wußte ja das auf euch Verlass ist, aber dir besonderen dank Harald.
Bis die Tage Klaus

  

Re: Datum mit in eine Formel einbeziehen
von: MikeS
Geschrieben am: 17.04.2003 - 14:56:05


Hallo,



in A1 DeinDatum



in B1 die Formel:



=WENN(ISTLEER(A1);"";WENN(A1<=DATUM(2002;12;19);80;WENN(UND(A1>DATUM(2002;12;19);A1(2003;1;1));100;80)))



Ciao MikeS




 

Beiträge aus den Excel-Beispielen zum Thema "Datum mit in eine Formel einbeziehen"