Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Datum in Formel automatisch

Datum in Formel automatisch
04.11.2008 09:54:00
Bernd
Hallo,
könnt ihr mir bei folgender Aufgabe weiterhelfen:
In anhängender Datei ist in Zelle C1 eine Summenformel (=SUMME(B1:B31))
Ich will nun, dass anstatt der Zelle B1 diejenige Zelle in der Spalte B berücksichtigt ist, in der in Spalte A das aktuelle Datum steht.
z.B: Datum: 04.11.08 soll die Summenformel lauten: =SUMME(B4:B31)
oder Datum: 19.11.08 =SUMME(B19:B31)
Ich habe schon mit =heute() rumprobiert, komme aber zu keinem Ergebnis.
Ich hoffe, ich habe mein Problem verständlich beschrieben.
Könnt ihr mir da weiterhelfen?
Schonmal vielen Dank
Gruß
Bernd

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Datum in Formel automatisch
04.11.2008 10:21:32
selli
hallo bernd,
=SUMMENPRODUKT((A1:A31>HEUTE()-1)*(B1:B31))
gruß selli
AW: Datum in Formel automatisch
04.11.2008 11:06:40
Bernd
Hallo,
mit der Formel: =SUMMENPRODUKT((A1:A31>HEUTE()-1)*(B1:B31))
funktioniert's nicht ganz.
Ich habe die Datei nochmal hochgeladen.
https://www.herber.de/bbs/user/56491.xls
in Zelle D1 steht =Summe(B1:B4) Ergebnis:65
Nimmt man die obige Formel kommt als Ergebnis 66 raus, weil die Zelle B8 (wo in Zelle A8 der 08.12.08 steht, also nicht berücksichtigt werden soll) mit in die Rechnung eingeht.
Wie muss ich dei Formel ändern
Gruß
Bernd
Anzeige
AW: Datum in Formel automatisch
04.11.2008 11:14:00
Bernd
habe die Frage noch als offen markiert
AW: Datum in Formel automatisch
04.11.2008 11:28:01
Hajo_Zi
Hallo Bernd,
bilde in beiden Formel über den gleichen Bereich die Summe.
Gruß Hajo
AW: Datum in Formel automatisch
04.11.2008 11:32:44
Werner
Hallo Bernd,
und wie wär's hier mit:
Tabelle1

 E
114

Formeln der Tabelle
ZelleFormel
E1=SUMME(INDIREKT("B" & TAG(HEUTE()) & ":B31"))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Werner
Anzeige
AW: Datum in Formel automatisch
04.11.2008 11:33:52
Werner
... als Matrixformel!!!
Tabelle1

 E
114

Formeln der Tabelle
ZelleFormel
E1{=SUMME(INDIREKT("B" & TAG(HEUTE()) & ":B31"))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Werner
Anzeige
AW: Datum in Formel automatisch
04.11.2008 12:34:00
Bernd
Hallo,
jatzt komm ich zurecht.
Vielen Dank an alle!!!!!!!!
Gruß
Bernd
AW: Datum in Formel automatisch
04.11.2008 10:21:00
Rudi
Hallo,
=SUMME(BEREICH.VERSCHIEBEN(B1;TAG(HEUTE())-1;;;):B31)
Gruß
Rudi
AW: Datum in Formel automatisch
04.11.2008 10:23:17
Werner
Hallo Bernd,
so:
wobei in Zelle A1 das komplette Datum steht:
=SUMME(INDIREKT("B" & TAG(A1) & ":B31"))
Gruß
Werner
AW: Datum in Formel automatisch
04.11.2008 10:23:23
Hajo_Zi
hallo Bernd,
die Datei sehe ich nicht.
Tabelle1

 BCD
22  
32  
42  
52  
62  
72  
82  
92  
10204.11.200832
112  
122  
132  
142  
152  
162  
1721 
182  
192  
20   
21   

Formeln der Tabelle
ZelleFormel
B2=SPALTE()
B3=SPALTE()
B4=SPALTE()
B5=SPALTE()
B6=SPALTE()
B7=SPALTE()
B8=SPALTE()
B9=SPALTE()
B10=SPALTE()
C10=HEUTE()
D10=SUMME(INDIREKT("B" & TAG(C10) &":B31"))
B11=SPALTE()
B12=SPALTE()
B13=SPALTE()
B14=SPALTE()
B15=SPALTE()
B16=SPALTE()
B17=SPALTE()
B18=SPALTE()
B19=SPALTE()


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Anzeige

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige