Herbers Excel-Forum - das Archiv

Datumsformat in Formel

Bild

Betrifft: Datumsformat in Formel
von: rookie

Geschrieben am: 14.12.2006 12:22:39
Hallo Zusammen,
ich habe in beigefügter Arbeitsmappe ein Datumsproblem. Ich lese aus einem vorgegebenen Text das Datum heraus, welches aber meistens nicht ganz korrekt eingegeben wurde (z.b. 6.2.06). Ich müsste nun aber das korrekte Dautmsformat 06.02.2006 haben. Dies liess sich aber einer Umformatierung in TT.MM.JJJJ nicht bewerkstelligen...
hat jemand eine Idee wie ich dies machen könnte?
vielen Dank
Gruss
Yves
https://www.herber.de/bbs/user/38989.xls
Bild

Betrifft: AW: Datumsformat in Formel
von: AndreasG
Geschrieben am: 14.12.2006 12:26:43
Hallo Yves,
=WENN(A1="";"";DATWERT(GLÄTTEN(TEIL(A1;FINDEN("-";A1;1)+1;(FINDEN("-";A1;FINDEN("-";A1;1)+1)-1)-(FINDEN("-";A1;1)+1))))) und als Datum formatieren
Grüsse
Andreas
Bild

Betrifft: AW: Datumsformat in Formel
von: Fritz Hellbach
Geschrieben am: 14.12.2006 12:32:15
Versuch es mal mit dem Voranstellen von DATWERT:
=DATWERT(WENN(A1="";"";GLÄTTEN(TEIL(A1;FINDEN("-";A1;1)+1;(FINDEN("-";A1;FINDEN("-";A1;1)
+1)-1)-(FINDEN("-";A1;1)+1)))))
Bild

Betrifft: AW: Datumsformat in Formel
von: rookie
Geschrieben am: 14.12.2006 13:45:39
Besten Dank an Andreas und Fritz,
mit DATWERT ist mein Problem gelöst...
Gruss
und schönen Tag
yves
 Bild
Excel-Beispiele zum Thema "Datumsformat in Formel"
Datumsformatkonvertierung (von Heinrich Stuerzl) Anzeigen von Werten und Formeln
Zeile einfügen und Formeln und Werte übernehmen Formeln mit Zelladressen speichern
Zeilenumbruch in Formel erzwingen Aktueller Arbeitsblattname in Formel
Variable in Formel einbauen Ein Zeichen in einer Formel suchen
Variable in Excel-Formel einbauen. Summenformel unter Zahlenreihe eintragen