Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
912to916
912to916
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Umwandlung von Planperioden(KWs) in norm. Datum

Umwandlung von Planperioden(KWs) in norm. Datum
10.10.2007 17:34:43
Planperioden(KWs)
Hallo zusammen,
ich hab noch ein Problem, das ich nicht gelöst bekomme:
Ich habe eine Tabelle mit Datumsangaben, die in Form von Planperioden (ähnlich Kalenderwochen) angegeben sind. Wie kann ich in VBA die Planperioden in normale Datumsangaben überführen, um dann mit Ihnen rechnen zu können.
Hier ist die Äquivalenz zwischen Planperioden und Datumsangaben:
PP Datum
200701 01.01.07
200702 12.01.07
200703 23.01.07
200704 01.02.07
200705 12.02.07
200706 20.02.07
200707 01.03.07
200708 13.03.07
200709 22.03.07
200710 01.04.07
200711 12.04.07
200712 23.04.07
200713 01.05.07
200714 11.05.07
200715 23.05.07
200716 01.06.07
200717 13.06.07
200718 22.06.07
200719 01.07.07
200720 12.07.07
200721 23.07.07
200722 01.08.07
200723 13.08.07
200724 23.08.07
200725 01.09.07
200726 12.09.07
200727 21.09.07
200728 01.10.07
200729 12.10.07
200730 23.10.07
200731 01.11.07
200732 13.11.07
200733 22.11.07
200734 01.12.07
200735 10.12.07
200736 17.12.07
Bitte um Hilfe!!!! Danke schonmals im voraus.
Viele Grüße,
Roman

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Umwandlung von Planperioden(KWs) in norm. Datum
10.10.2007 22:18:36
Planperioden(KWs)
Hi
wenn keine bestimmte Rechenformel dahinter steckt und die Daten willkürlich gesetzt wurden, gehts nur über ne Hilfstabelle, mit der du dann über den SVERWEIS die Start- und End-Daten einer Planungsperiode abfragst:
bspw 1. Tag einer Planungsperiode:
=Sverweis(200719;A1:B37;2;1) ist 01.07.07
bspw. letzter Tag einer Planungsperiode:
= SVERWEIS(200719+1;A1:B37)-1 ist 11.07.07
Gruß, Daniel.
die 2. Formel geht natürlich nur, wenn deine Planungsperioden Zahlen sind.
für PP200736 geht die 2. Formel natürlich auch nicht, da müsstest du noch die Dummy-PP 200737 am Ende mit Startdatum 1.1.2008 einfügen.
Anzeige

316 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige