Microsoft Excel

Herbers Excel/VBA-Archiv

Datum in Formel einbinden (z. B. früher als...)?

Betrifft: Datum in Formel einbinden (z. B. früher als...)? von: Felix Bartelt
Geschrieben am: 31.10.2012 13:29:07

Wie kann ich ein Datum (das so geschrieben ist: 31.11.12) in eine Formel einbinden?
Z.B.: B1: Wenn Datum in A1 früher als 1.5.12 und später 31.3.12, ist, dann schreibe "rechtzeitig".

Gibt es eine Möglichkeit die Formel in B1 nach unten zu kopieren, so dass sie automatisch um einen Monat weiterspringt?
In B2 würde dann also stehen: Wenn Datum in A2 früher als 1.6.12 und später 31.4.12, ist, dann schreibe "rechtzeitig".

Vielen Dank für Eure Hilfe!

  

Betrifft: den 31.11. gibt es nicht ..... und von: WF
Geschrieben am: 31.10.2012 13:55:24

..... was Du machen willst, ist diffus.

WF


  

Betrifft: AW: den 31.11. gibt es nicht ..... und von: Felix Bartelt
Geschrieben am: 31.10.2012 14:10:06

Vielleicht sollte ich das besser erklären:
Das "rechtzeitig" war nur als Beispiel gedacht. Zweck meiner Tabelle ist es, alle Beträge aus Zellen zu summieren, die aus demselben Monat stammen.

Bisher habe ich das wie folgt gelöst: In Spalte A stand das Datum (allerdings so geschrieben 120131, was dem 31. Januar 12 entspricht).
In Spalte B der Betrag. In Zelle F1 sollten jetzt z. B. alle Beträge aus dem Januar 2012 summiert werden. Das hat mit dieser Formel auch super funktioniert:

F1=SUMMENPRODUKT(($A$1:$A$435>120100)*($A$1:$A$435<110200)*$B$1:$B$435)

Jetzt soll ich aber mit diesem Datumsfomat arbeiten 31.1.12, wofür meine Formel nicht geeignet ist.
Da muss es doch auch eine Formel für geben, mit der man feststellen kann, ob ein Datum größer ("später") als ein anderes ist?


  

Betrifft: AW: Datum in Formel einbinden (z. B. früher als...)? von: Klaus M.vdT.
Geschrieben am: 31.10.2012 14:19:58

Hallo Felix, (freundliche Anrede, der Anfang eines guten Postings)

Wie WF schon feststellte, gibt es den 31/11 nicht und deine Aufgabenstellung ist nicht ganz klar.
Ich hab mal interpretiert was du möchtest:
Es gibt ein Datum "Früher als" und ein Datum "später als". Die Werte in A sollen darauf geprüft werden.

https://www.herber.de/bbs/user/82410.xlsx

So in etwa?

Grüße,
Klaus M.vdT. ein freundliche Gruß am Ende runded das Posting ab


  

Betrifft: AW: Datum in Formel einbinden (z. B. früher als...)? von: UweD
Geschrieben am: 31.10.2012 14:20:41

Hallo

In E1 einmal ein festes Datum eintragen
und mit Hilfsspalten, die sich automatisch erweitern.

ginge das...

Tabelle1

 ABCDE
101.04.2012rechtzeitig  31.03.201201.05.2012
201.04.2012    30.04.201201.06.2012
301.04.2012    31.05.201201.07.2012
401.04.2012    30.06.201201.08.2012
501.04.2012    31.07.201201.09.2012
601.04.2012    31.08.201201.10.2012
701.04.2012    30.09.201201.11.2012
801.04.2012    31.10.201201.12.2012
901.04.2012    30.11.201201.01.2013
1001.04.2012    31.12.201201.02.2013
1101.04.2012    31.01.201301.03.2013
1201.04.2012    28.02.201301.04.2013

verwendete Formeln
Zelle Formel Bereich
B1 =WENN(UND(A1>=D1;A1<=E1);"rechtzeitig";"") 
D1 =DATUM(JAHR(E1);MONAT(E1)-1;0) 
B2 =WENN(UND(A2>=D2;A2<=E2);"rechtzeitig";"") 
D2 =DATUM(JAHR(E2);MONAT(E2)-1;0) 
E2 =DATUM(JAHR(E1);MONAT(E1)+1;1) 

Tabellendarstellung in Foren Version 5.49



Gruß UweD


  

Betrifft: AW: Datum in Formel einbinden (z. B. früher als...)? von: Felix Bartelt
Geschrieben am: 31.10.2012 15:00:06

Das klappt beides schon super. Vielen Dank!
Jetzt hätte ich noch die Frage, wie ich es machen könnte, ohne in den Spalten D und E Daten eintragen zu müssen.
Gibt es da irgendeine Formel für: Summe aus allen Zellen, neben denen Monat x als Datum steht?

Also ein Formel für die Zellen G5 bis G8 in dieser Tabelle?

https://www.herber.de/bbs/user/82411.xlsx


  

Betrifft: AW: Datum in Formel einbinden (z. B. früher als...)? von: Rudi Maintaire
Geschrieben am: 31.10.2012 17:09:15

Hallo,
G5: =SUMMENPRODUKT((TEXT($B$5:$B$8;"JJMM")=TEXT(F5;"JJMM"))*$C$5:$C$8)

Gruß
Rudi


  

Betrifft: AW: Datum in Formel einbinden (z. B. früher als...)? von: Felix Bartelt
Geschrieben am: 31.10.2012 17:38:50

Super. So einfach hätte ich´s mir gar nicht vorgestellt. Vielen Dank!


 

Beiträge aus den Excel-Beispielen zum Thema "Datum in Formel einbinden (z. B. früher als...)?"