Microsoft Excel

Herbers Excel/VBA-Archiv

Datumsreihe mit Formel generieren | Herbers Excel-Forum


Betrifft: Datumsreihe mit Formel generieren von: edie
Geschrieben am: 28.12.2009 13:52:20

Hallo zusammen,

wenn ich in die Zelle B1 das Startdatum und in die Zelle B2 das Enddatum eingebe soll
in der Spalte A2:A mithilfe einer Formel eine Datumsreihe gebildet werden.

Habe bei der Recherche eine Formel die Monatsweise eine Datumsreihe bildet gefunden:

In A2:=A1
In A3:=WENN(DATUM(JAHR($B$1);MONAT($B$1)+ZEILE()-1;TAG($B$1))<=$A$2;DATUM(JAHR($B$1);MONAT($B$1)+ZEILE()-1;TAG($B$1));"")

Kann die Formel angepasst werden damit es eine Tagesreihe generiert?

Danke für die Hilfe im Voraus.

Grüße

  

Betrifft: AW: Datumsreihe mit Formel generieren von: Daniel
Geschrieben am: 28.12.2009 14:06:20

HI
probiersmal mit dieser Formel

=WENN(($B$1+ZEILE()-2)<=$B$2;$B$1+ZEILE()-2;"")

Gruß, Daniel


  

Betrifft: AW: Datumsreihe mit Formel generieren von: edie
Geschrieben am: 28.12.2009 15:08:29

Hallo Daniel,

die Formel funktioniert, prima. Besten Dank.

Nur noch eine Zusatzfrage: Wie erreiche ich es, dass die Formel nach unten
automatisch kopiert wird bis zum Enddatum?

Nach unten "von Hand" kopieren ist sehr mühsam.

Kann man das realisieren?

Vielen, vielen Dank.

Grüße


  

Betrifft: AW: Datumsreihe mit Formel generieren von: Daniel
Geschrieben am: 28.12.2009 15:24:35

HI
ohne VBA, nein.
höchsten du schaust dir mal die funktion BEARBEITEN - AUSFÜLLEN - REIHE mit Endwert an.
da hast du dann aber keine Formlen, sondern Festwerte und musst auch noch den Ganzzahlenwert des Enddatums wissen.

ein VBA-Makro könnte so aussehen:

Sub test()
Range("A:A").Clear
Range("A2").Value = Range("B1").Value
Range("A2").DataSeries Rowcol:=xlColumns, Type:=xlChronological, Date:= _
        xlDay, Step:=1, Stop:=Range("B2").Value, Trend:=False
End Sub

Das Makro muss immer laufen, wenn ein Wert in B1 oder B2 geändert wird.

Gruß, Daniel


  

Betrifft: AW: Datumsreihe mit Formel generieren von: edie
Geschrieben am: 28.12.2009 15:40:17

Hallo Daniel,
Hallo robert,

das ist es, klappt wunderbar.

Die Formeln und das Makro werden in eine größere Prozedur eingebunden
deshalb ist: Nach unten "von Hand" kopieren sehr mühsam.

Besten Dank.

Grüße


  

Betrifft: AW: Datumsreihe mit Formel generieren von: Gert Seler
Geschrieben am: 28.12.2009 16:45:03

Hallo edie,
dann schreib uns doch einmal, was die "Prozedur" berechnen soll ?
Denn zum "einbinden" in eine größere Prozedur, sollte man von "VBA" mehr verstehen
als "Makros" aufzuzeichnen.

mfg
Gert


  

Betrifft: AW: Datumsreihe mit Formel generieren von: edie
Geschrieben am: 28.12.2009 20:14:46

Hallo Gert Seler,

ganz einfach und schlicht z.B. so:

Sub test()
Application.ScreenUpdating = False
Call Makro1
Call Makro2
Call Makro3
Application.ScreenUpdating = True
End Sub
Viele Grüße


  

Betrifft: ..dauert keine 2 sekunden.. von: robert
Geschrieben am: 28.12.2009 15:27:10

hi,

was ist so mühsam, eine formel zu kopieren?

hast du das noch nie gemacht ?

bzw.wie machst du es ?

gruß
robert


Beiträge aus den Excel-Beispielen zum Thema "Datumsreihe mit Formel generieren"