Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung - Mit Formel funkt. nicht | Herbers Excel-Forum


Betrifft: Bedingte Formatierung - Mit Formel funkt. nicht von: Arthur
Geschrieben am: 21.08.2012 13:01:11

Hallo zusammen

Ich habe eine bedingte Formatierung:

=$F$33=$A38 wird angewendet auf =$A$38:$E$63

Wenn ich in F33 eine Zahl hinschreibe funktioniert die b. Formatierung tadellos.
Wenn ich aber mit einem Sverweis zu einer Zahl komme in F33, funktioniert die b. Formatierung nicht.

Sprich:
Manuel 3 hinschreiben okay
=SVERWEIS($A$33;'Daten ("Werte" einfügen!)'!B:X;18;0) *100 ergibt auch 3, aber die b. formatierung funktioniert dann nicht.

Wie kann ich dies lösen? Es muss mit dem SVERWEIS klappen, nicht manuell.

Vielen Dank für eure wertvolle Hilfe!

Gruss
Arthur

  

Betrifft: AW: Bedingte Formatierung - Mit Formel funkt. nicht von: Rudi Maintaire
Geschrieben am: 21.08.2012 13:05:26

Hallo,
=SVERWEIS($A$33;'Daten ("Werte" einfügen!)'!B:X;18;0) *100 ergibt auch 3
wirklich? Nicht 3,0000000001 oder so?

Versuchs mal mit
=Runden(SVERWEIS($A$33;'Daten ("Werte" einfügen!)'!B:X;18;0) *100 ;0)

Gruß
Rudi


  

Betrifft: Dezimalzahlen sind ungenau - Runden von: Erich G.
Geschrieben am: 21.08.2012 13:14:50

Hi Arthur,
in F33 sollte die Zahl 3 stehen, hervorgegangen aus SVERWEIS(...)*100 - jedenfalls sieht die Zahl wie eine 3 aus.
Schreib doch mal in eine freie Zelle die Formel
=(F33=3)
Kommt da FALSCH raus?

Dann liegt das daran, dass SVERWEIS(...)*100 nicht genau, sondern nur ungefähr gleich drei ist.
Das reicht dann für die bed. Formatierung natürlich nicht aus.

Dezimalzahlen können in endlichen Computern nicht genau dargestellt werden.
Stell dir das mal mit 1/3 im Dezimalsystem vor - die Zahl ist seeeeehr lang, 0,3333333333333333...

Im Prinzip das Gleiche geschieht im PC - nur dass er im Binärsystem arbeitet.

Mögliche Abhilfe: Runden, also
=RUNDEN(SVERWEIS($A$33;'Daten ("Werte" einfügen!)'!B:X;18;0) *100;5)
wobei die 5 auch eine andere Zahl sein kann. Probiers einfach mal aus.

Vielleicht musst du auch A38 runden?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Dezimalzahlen sind ungenau - Runden von: Arthur
Geschrieben am: 21.08.2012 13:19:36

Hallo Erich

Genau, da lag das Problem wie ich schon bei der Hilfe von Rudi erwähnt habe.
Durch den SVERWEIS habe ich nicht genau 3 erhalten sonder 2.9 oder ähnlich.

Logisch kann Excel dann nicht eine andere Zelle einfärben, denn 2.9 ist ja nicht gleich 3, nur gerundet klappt es!

Vielen Dank auch für deinen Tipp

Gruss
Arthur.


Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung - Mit Formel funkt. nicht"