Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis funktioniert nicht

Betrifft: sverweis funktioniert nicht von: Andi
Geschrieben am: 28.08.2014 08:24:19

Hey,

ich habe folgendes Problem:
Ich importiere mit einem Makro ein Tabellenblatt und will dann auf einem anderen Tabellenblatt darauf via sverweis zugreifen.

Allerdings funktioniert der Sverweis nur, wenn ich das Suchkriterium (eine Zahl) mit ="..." schreibe. Wie kann ich die Sverweisfunktion so verändern, dass der Zahlenwert gefunden wird?

  

Betrifft: mit 1 multiplizieren von: WF
Geschrieben am: 28.08.2014 08:55:09

Hi,

statt z.B.:
=SVERWEIS(E1;A1:B9;2;0)
in E1 steht Deine Zahl

schreibst Du als Arrayformel:
{=SVERWEIS(E1;(A1:B9)*1;2;0)}

Salut WF


 

Beiträge aus den Excel-Beispielen zum Thema "sverweis funktioniert nicht"