Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SVERWEIS funktioniert nicht durchgehend

SVERWEIS funktioniert nicht durchgehend
06.06.2017 14:45:20
Klexy
Moin zusammen,
ich komm einfach nicht weiter.
In der angehängten Datei hab ich in Spalte F einen SVERWEIS, der mir bei der Bedingung "HO" zum Vergleichswert Spalte A MINUS 1 den Wert aus Spalte B ausgeben soll.
Also: in dunkelgrün soll hellgrün ausgeben, indem dunkelblau MINUS 1 (=hellblau) verglichen wird.
Das funktioniert bei 64,2 (dunkelblau MINUS 1 = hellblau) gut.
Das funktioniert bei 64,1 (rot MINUS 1 = rosa) NICHT.
Ich hab die Vergleichswerte in Spalte A als Standard und als Zahl formatiert - kein Unterschied.
Wo liegt der Hund begraben?
(Excel 2016 - in anderen Versionen nicht geprüft)
https://www.herber.de/bbs/user/114056.xls

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SVERWEIS funktioniert nicht durchgehend
06.06.2017 14:49:20
SF
Hola,
=WENN(C9"HO";"";SVERWEIS(RUNDEN($A9-1;1);$A$2:$B$20;2;0))

Gruß,
steve1da
AW: SVERWEIS funktioniert nicht durchgehend
07.06.2017 17:00:37
Klexy
Danke, Steve. Das funktioniert.
Aber warum gibt es einen Unterschied zwischen 64,1 und 64,2?
Wenn es ein Datum wäre mit krummen Bruchteilen von 1 würde ich es verstehen, aber eine Zahl mit einer gewöhnlichen Dezimalstelle?
Anzeige

337 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige