Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis bei Anrede funktioniert nicht | Herbers Excel-Forum


Betrifft: sverweis bei Anrede funktioniert nicht von: Michael
Geschrieben am: 15.11.2009 16:22:35

Hallo,

ich habe folgendes Problem:

Ich habe in einer Datei zwei Tabellenblätter. Die Aufgabe besteht darin anhand einer Vornamenliste einem Vornamen die Anrede Herr oder Frau zuzuordnen.

Tabellenblatt 1 (Name: Tabelle1) beinhaltet eine Liste mit Vor- und Nachnamen, sowie Adressen (für dieses Problem entscheidend sind natürlich nur die Vornamen), diese beginnen in B1 und stehen untereinander.

Tabellenblatt 2 (Name: Tabelle2) beinhaltet eine Liste mit Vornamen und dazugehörigem Geschlecht in der Form:
A1:Adalbert A2:Herr
B1:Adelgunde B2:Frau
C1:Manfred C2:Herr
usw.

Nun hätte ich gerne, dass bei dem jeweiligen Vornamen in Tabelle 1 die Anrede Herr oder Frau erscheint, dazu habe ich folgende Funktion benutzt:

=SVERWEIS(B1;Tabelle2!$A$1:$B$20221;2;0)

Das Problem ist, dass beim ersten Vornamen die Anrede hinzugefügt wird, bei den anderen aber leider nicht mehr, dort erscheint überall #NV.

Hat jemand eine Idee, wo das Problem liegt? Vielleicht hat auch jemand eine andere Lösungsmöglichkeit, ich bin da offen. Wichtig ist nur, dass die Vornamensliste verwendet wird, da auch Exoten unter den Vornamen sind und diese in der Vornamensliste berücksichtigt werden.

Grüße
Michael

  

Betrifft: AW: sverweis bei Anrede funktioniert nicht von: Daniel
Geschrieben am: 15.11.2009 16:33:12

Hi
die Formel ist prinziplell mal korrekt.
Um den Fehler finden zu können, solltest du mal deine Datei hochladen, Fehlermöglichkeiten gibts einige.
angefangen von Tipfehlern, über angeängte Leerzeichen usw.
Gruß, Daniel


  

Betrifft: AW: sverweis bei Anrede funktioniert nicht von: Michael
Geschrieben am: 15.11.2009 16:36:06

Hallo Daniel,

ich habe soeben den Fehler gefunden, Danke Dir trotzdem. Und zwar war hinter jedem Vornamen ein Leerzeichen, daher hat es nicht funktioniert.

Grüße
Michael


  

Betrifft: AW: sverweis bei Anrede funktioniert nicht von: Hajo_Zi
Geschrieben am: 15.11.2009 16:35:08

Hallo Michael,

die Formel siehtr eigentlich ok aus. Vielleicht solltest Du mal eine abgespeckte Version hochladen?

GrußformelHomepage


  

Betrifft: AW: sverweis bei Anrede funktioniert nicht von: fcs
Geschrieben am: 15.11.2009 16:49:34

Hallo Michael,

sinnvoller Weise schreibst du auch in Tabelle2 die Vornamen in einer Spalte untereinander und die Anrede in der Spalte rechts davon
A1: Vorname B1:Anrede
A2:Adalbert B2:Herr
A3:Adelgunde B3:Frau
A4:Manfred B4:Herr

Da kannst du dann auch fast beliebig viele Vornamen listen.
Bei deiner Anordnung in einer Zeile ist nach ca. 255 Voramen Schluß, weil du bei der Eingabe in Excel2003 in der letzten Spalte angekommen bist. Mit der Formel
=WVERWEIS(B1;Tabelle2!$A$1:$IV$2;2;0)
müßte es in deinen Tabellen so wie sie sind funktionieren. Macht aber wie geschrieben wenig Sinn.

Außerdem hast du das Problem mit Vornamen wie Eike oder Chris, die sowohl weiblich wie männlich benutzt werden.

Üblicherweise tragt man in Namenslisten das Geschlecht als "W"/"M" oder auch "F"/"M" in einer Spalte der Liste ein und generiert dann daraus bei Bedarf die Anrede.

Gruß
Franz


  

Betrifft: AW: sverweis bei Anrede funktioniert nicht von: Michael
Geschrieben am: 15.11.2009 18:10:14

Hallo Franz,

danke für den Hinweis, werde ich machen.

Grüße
Michael


Beiträge aus den Excel-Beispielen zum Thema "sverweis bei Anrede funktioniert nicht"