Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
444to448
444to448
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Hilfe - Wenn Formel funktioniert nicht ????

Hilfe - Wenn Formel funktioniert nicht ????
29.06.2004 20:12:53
Robert
Habe in Zelle C3 Anfangszeit stehen in Zelle D3 Endzeit stehen in Zelle F3 gesamt Stunden. In Zelle G1 steht 12:30, in Zelle G2 09:30, in Zelle H2 00:15, in Zelle I2 00:30.
Möchte nun die Arbeitszeit in Zelle F3 ermitteln, jedoch mit abzug von Früstück (zelle H2) und Mittag (zelle I2), wenn ich länger als 12:30 endzeit gearbeitet habe(zb.15:20), arbeite ich nur bis 12:30 dann soll nur zelle H2 ( 00:15) abgezogen werden, arbeite ich kürzer wie 09:30 dann darf weder Frühstück (H2)noch Mittag (I2) abgezogen werden. Leider funktioniert die Formel nicht schei....?
Formel =WENN($D3>$G$1;$D3-$C3-$H$2-$I$2;WENN($D3>$G$2<$G$1;$D3-$C3-$H$2;WENN($D3<$G$2;$D3-$C3)))
zeigt FALSCH an.............
Danke für eure Hilfe im vorraus.....
Robert

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Hilfe - Wenn Formel funktioniert nicht ????
29.06.2004 20:30:23
Uduuh
Hallo,
nach meiner Meinung geht folgendes nicht:
WENN($D3>$G$2<$G$1;
müsste glaub ich so sein:
wenn(und($d3>$g$2;$g$2<$g$1);
Gruß aus'm Pott
Udo
AW: Hilfe - Wenn Formel funktioniert nicht ????
29.06.2004 21:22:59
Robert
Hallo Udo............
Formel funktioniert soweit, wenn man aber als Endzeit in (D3)09:30 eingegeben hat erscheint
FALSCH......bei 12:30 kein Problem....???
woran könnte es liegen...???
Danke Robert
AW: Hilfe - Wenn Formel funktioniert nicht ????
30.06.2004 05:45:51
andre
Hallo Robert,
Du hast für das letzte wenn keine alte naive ;-) ...(WENN($D3<$G$2;$D3-$C3)))
wenn(bedingung;dann;sonst) sonst kommt eben falsch wenn die prüfung da hin will.
Das dürfte z.B. dann passieren, wenn Du den Vorschlag von Udo umsetzt. Es mücsste eher
wenn(und(d3>g2;d3<g1) sein.
Anzeige
AW: Hilfe - Wenn Formel funktioniert nicht ????
30.06.2004 22:49:33
Robert
Hallo Andre........habe leider keinen Ahnung was (d3>g2;d3<g1)bedeutet.....
Formel funktioniert leider immer noch nicht.........schade......
Es müßte doch eine möglichkeit geben, wenn man über 12:30 liegt 00:15 + 00:30 (sind beides Pausen)abzuziehen,
wenn man zwischen 09:30 und 12:30 liegt nur 00:15 abzuziehen und wenn man unter 09:30 liegt
keine Zeit abzuziehen..........
Robert......
AW: Hilfe - Wenn Formel funktioniert nicht ????
01.07.2004 05:38:48
andre
... also mit Excel gut solltest Du Dich etwas auskennen. Nochmal: Bei deinem letzten Wenn fehlt eine alternative. Gehe die Formel mal logisch durch und überlege, in welchem Fall das passiert.
Ansonsten richten sich Pausenzeiten im Normalfall nach der Anzahl der Arbeitsstunden. Ist das für 'ne Schule mit festen Pausen? Da müsstest Du aber auch was für (oder gegen) den Fall tun, wenn der Lehrer mitten in der Pause kommt ;-)
Anzeige

356 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige