Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

S-Verweis / Textvergleich funktioniert nicht

S-Verweis / Textvergleich funktioniert nicht
18.01.2016 12:05:41
Andreas
Hallo zusammen,
ich habe folgendes Problem:
Ich möchte in zwei Excel-Tabellen Artikelbezeichnungen miteinander vergleichen
und bei einer Übereinstimmung eine dazugehörige Art.-Nr. mit ausgeben.
Eigentlich mit dem S-Verweis kein Problem. Allerdings blieb der Erfolg bislang aus.
Meine Frage: Ist es überhaupt möglich Texte mit dem S-Verweis zu vergleichen?
Ich habe schon alles geprüft, Textlänge und Formatierungen sind überall gleich.
Die Formel sagt mir allerdings immer, dass dieser Text nicht in der Matrix vorkommt.
Es handelt sich um Artikelbezeichnungen, welche aus mehreren Wörtern mit Leerzeichen bestehen. Ist das eventuell ein Problem?
Meine Formel habe ich wie gewohnt im S-Verweis Format aufgebaut:
=SVERWEIS(B2;Tabelle2!A:B;1;FALSCH)
In Spalte 1 steht die Art-Nr. in der Such-Matrix, die ich in der anderen Tabelle mit ausgeben möchte.
Vorab vielen Dank für Ihre Hilfe!
Mit freundlichen Grüßen
Andreas

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: S-Verweis / Textvergleich funktioniert nicht
18.01.2016 12:20:00
Bernd
Hi,
lade doch eine Beispielmappe hoch, meist stellt sich dann im nachhinein heraus, dass es doch ganz anders als geschildert ist.
mfg Bernd

AW: S-Verweis / Textvergleich funktioniert nicht
18.01.2016 12:36:57
Daniel
HI
der SVERWEIS funktioniert auch mit Texten.
der Suchwert-Text (1. Parameter) muss aber genauso geschrieben werden wie die Texte in der Suchspalte (2. Parameter)
wenns nicht klappt und man den Unterschied nicht sofort sieht, können folgende Ursachen vorliegen:
- zusätzliche Leerzeichen am Textende
- es wird anstelle des normalen Leerzeichens (ASCII 32) das geschützte Leerzeiche (ASCII 160) verwendet.
Gruß Daniel

Anzeige
AW: S-Verweis / Textvergleich funktioniert nicht
18.01.2016 15:58:22
Andreas
Anbei eine Muster-Tabelle zu dem Problem.
Wie kann ich den prüfen ob ein normales Leerzeichen verwendet wird?
(ASCII 32) oder das geschützte Leerzeiche (ASCII 160) ?

SVerweis sucht nur in der ersten Spalte der Matrix
18.01.2016 16:20:47
Daniel
Hi
der SVerweis sucht den Suchbegriff immer nur in der ersten Spalte der Suchmatrix
dh. der SVerweis funktioniert nur, wenn der Suchwert (bei dir die Bezeichnung) in der Tabelle links vom auszugebenden Wert steht (Art-Nr).
steht der Suchwert rechts vom auszugebenden Wert (so wie bei dir), dann musst du die Kombination von Index und Vergleich verwenden:
=Index(Tabelle2!A:A;Vergleich(B2;Tabelle2!B:B;0))
Gruß Daniel

Anzeige
AW: SVerweis sucht nur in der ersten Spalte der Matrix
18.01.2016 16:29:34
Andreas
Hi Daniel!
Super! Das war der Fehler! Vielen Dank! Jetzt geht alles!

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige