Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenns mit Wortteilsuche = #Wert!

Betrifft: Zählenwenns mit Wortteilsuche = #Wert! von: Michel
Geschrieben am: 14.10.2020 17:04:01

Hallo zusammen,

ich habe folgendes Problem:

Ich möchte in eine Zählenwenns - Funktion mit (unter anderem) einer Wortteilsuche erstellen. Das zu suchende Wortteil soll sich hierfür in der Zelle A4 befinden.

Folgende Formeln funktionieren:

=ZÄHLENWENN(Tabelle1!$C$3:$C$20000;"="&"*"&A4&"*")
=ZÄHLENWENNS(Tabelle1!$C$3:$C$20000;"="&"*"&A4&"*")

Sobald jedoch ein weiteres Kriterium bei der Zählenwenns Funktion hinzukommt, erhalte ich einen #WERT! - Fehler

Kann mir jemand weiterhelfen? Ich bin mit meinem Latein am Ende und würde mich sehr über einen Lösungsansatz freuen

Betrifft: AW:SUMMENPRODUKT() von ZÄHLENWENN() ...
von: neopa C
Geschrieben am: 14.10.2020 17:12:37

Hallo Michel,

... wenn Dein 2. Suchwort z.B. in A5 steht, dann so:

=SUMMENPRODUKT(ZÄHLENWENN(C:C;"*"&A4:A5&"*"))


Allerdings, dürfen dann beide Suchwörter nicht in einer Zelle des Suchbereiches vorkommen, dann würde dies auch doppelt gezählt. Dann kann dafür jedoch ein andere Formel definiert werden.

Gruß Werner
.. , - ...

Betrifft: AW: AW:SUMMENPRODUKT() von ZÄHLENWENN() ...
von: Michel
Geschrieben am: 14.10.2020 17:37:52

Vielen Dank für die schnelle Hilfe, ich habe inzwischen das Register gelöscht und die Formel neu erstellt, und jetzt geht es, habe vermutlich einen anderen Fehler gemacht.


Vielen Dank noch einmal für schnelle Hilfe.

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 14.10.2020 18:00:58

Gruß Werner
.. , - ...

Betrifft: die "andere Formel" wäre
von: WF
Geschrieben am: 14.10.2020 17:44:40

{=ANZAHL(ZÄHLENWENN(C:C;"*"&A4:A5&"*"))}

WF

Betrifft: AW: nein, dem ist nicht so ...
von: neopa C
Geschrieben am: 14.10.2020 18:00:11

Hallo WF,

... das Ergebnis Deiner Formel ist immer 2, was sicherlich nicht gesucht ist.

Ich hatte allerdings auch vergessen, darauf hinzuweisen, das für meine Formel weder A4 noch A5 leer sein dürfen.

Das Ergebnis für eine UND-Bedingung würde ich so: =ZÄHLENWENNS(C:C;"*"&A4&"*";C:C;"*"&A5&"*")
ermitteln.

Gruß Werner
.. , - ...

Betrifft: stimmt - das war Blödsinn
von: WF
Geschrieben am: 14.10.2020 18:16:58

.

Betrifft: AW: Zählenwenns mit Wortteilsuche = #Wert!
von: Daniel
Geschrieben am: 14.10.2020 17:13:39

Hi
wie sieht denn deine Formel aus, wenn du ein zweites Kriterium aus?
sollen erstes und zweites Kriterium mit UND oder mit ODER verknüpft sein?

btw: warum "="&"*" und nicht "=*" ??

das Gleichheitszeichen brauchst du nicht.

Gruß Daniel

Betrifft: AW: Zählenwenns mit Wortteilsuche = #Wert!
von: Michel
Geschrieben am: 14.10.2020 17:37:12

Vielen Dank für die schnelle Hilfe, ich habe inzwischen das Register gelöscht und die Formel neu erstellt, und jetzt geht es, habe vermutlich einen anderen Fehler gemacht.


Vielen Dank noch einmal für schnelle Hilfe.