Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn gibt manchmal #Wert

Betrifft: zählenwenn gibt manchmal #Wert von: Franky
Geschrieben am: 20.08.2014 10:33:39

Hallo allerseits,

ich habe folgendes Problem:
Ich zähle die Menge eines bestimmten Eintrags in einem Excel-File mit folgender Formel aus:

=ZÄHLENWENN('[Zieldatei.xlsx]BOP'!$AU:$AU;D16)

Wenn die die Datei mit der Formel öffne, gibt Excel mir #Wert zurück, sobald ich allerdings die Zieldatei öffne, stimmen die Einträge.
Vielleicht sollte ich noch erwähnen, dass die Zieldatei aus ca. 8000 Zeilen besteht.
Das Problem tritt nicht nur bei mir auf, sondern bei allen, die mit der Datei arbeiten.
Beide Files sind xlsx.

Hat da jemand ne Idee, woran das liegen kann?

Danke im Voraus

Franky

  

Betrifft: AW: zählenwenn gibt manchmal #Wert von: Rolf.dW
Geschrieben am: 20.08.2014 10:55:01

Hallo Franky,

dieses nervige Problem kenne ich zur genüge. Warum das so ist, kann ich dir leider nicht sagen. Vermutlich hilft da wirklich nur, beim Öffnen der Datei mit 'Private Sub Workbook_Open() die 2. Datei ebenfalls zu öffnen.

Gruß, Rolf


  

Betrifft: AW: zählenwenn gibt manchmal #Wert von: Rudi Maintaire
Geschrieben am: 20.08.2014 12:22:25

Hallo,
das ist immer so.
Summewenn, Zählenwenn, Indirekt können nicht auf geschlossene Dateien zugreifen.

Gruß
Rudi


  

Betrifft: AW: zählenwenn gibt manchmal #Wert von: Franky
Geschrieben am: 20.08.2014 12:32:37

Okay, das wusste ich nicht. Ist aber schon seltsam, dass es z.B. mit sverweis geht.
Die Wege des Bill Gates sind unergründlich....

Trotzdem danke

Franky


 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn gibt manchmal #Wert"