SVerweis aus Access Datenbank funktioniert nicht

Bild

Betrifft: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 05.10.2015 10:51:07

Hallo Wissende,
ich habe eine Accessdatenbank in Excel eingefügt.
Jetzt soll aus dieser Tabelle per SVerweis geprüft werden ob die erste Spalte eine bestimmte Zahl vorhanden ist.
=WENN(ISTFEHLER(SVERWEIS(AC14;$A$32:$C$497;1;WAHR));0;SVERWEIS(AC14;$A$32:$C$497;1;WAHR))
AC14 ist die bestimmte Zahl.
Die Matrix funktioniert soweit es wird alles richtig angezeigt.
Allerdings findet Excel die Zahl AC14 nicht obwohl sie in der Matrix vorhanden ist.
Der oben genannte SVerweis liefert immer 0 als Ausgabe obwohl die gesuchte Zahl in der Matrix steht.
ändere ich in der Suchmatrix die Zahl manuel ab, funktioniert des SVerweis.
Hat jemand ne Idee ?
Gruß
Erik

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Martin
Geschrieben am: 05.10.2015 11:16:30
Hallo Erik,
vielleicht klappt es so:

=WENN(ISTFEHLER(SVERWEIS(T(AC14);$A$32:$C$497;1;WAHR));0;SVERWEIS(T(AC14);$A$32:$C$497;1;WAHR)) 
Viele Grüße
Martin

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: JoWE
Geschrieben am: 05.10.2015 13:36:48
Hallo,
hast Du die Suchmatrix händisch eingetragen? Ich vermute die Suchmatrix müsste in etwa so aussehen:
'=SVERWEIS(AC14;Tabelle_DeineDatenbank[#Alle];1;WAHR)'. So sieht's jedenfalls nach markieren der eingebundenen Access-Tabelle (der Suchmatrix) aus.
Gruß
Jochen

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 05.10.2015 11:44:40
Hallo Martin,
nein leider gibt er immer noch 0 aus !

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Martin
Geschrieben am: 05.10.2015 13:01:08
Hallo Erik,
ich rate jetzt auch nur.
1. Ist die Excel-Berechnung vielleicht auf "manuell" gestellt?
2. Ersetze "WAHR" durch "Falsch"
Viele Grüße
Martin

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 05.10.2015 13:07:15
Nein :-(
leider auch nicht.
Gruß
Erik

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: JoWE
Geschrieben am: 05.10.2015 13:39:57
sorry zuerst falsch positioniert:
Hallo,
hast Du die Suchmatrix händisch eingetragen? Ich vermute die Suchmatrix müsste in etwa so aussehen:
'=SVERWEIS(AC14;Tabelle_DeineDatenbank[#Alle];1;WAHR)'. So sieht's jedenfalls nach markieren der eingebundenen Access-Tabelle (der Suchmatrix) aus.

Gruß
Jochen

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 05.10.2015 14:44:51
Hallo Jochen,
ich habe einfach die Felder in Excel markiert, in der die Angaben der importierten Access Tabelle stehen.
Wie markiere ich den eine eingebundene Access-Tabelle richtig ?
Gruß
Erik

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 05.10.2015 14:52:40
Hab mal nen Link mit den 2 Dateien beigefügt.
Vielleicht ist es dann verständlicher !
Gruß
Erik
http://www.die-cubis.de/Test%20Locator.xls
http://www.die-cubis.de/WP30.mdb

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: JoWE
Geschrieben am: 05.10.2015 18:26:47
Erik,
ups, da scheint es einen deutlichen Unterschied zu Excel 2013 zu geben!!
Hatt die Version nicht beachtet.
Aber die Ursache istwas anderes: Der Wert in A5 ist ein Text (obwohl er wie eine Zahl aussieht).
Hingegen ist der Wert in C1 eine Zahl. Da unterscheidet Excel ganz "sauber".
Mache einen Doppelklick in A5, betätige dann die Entertaste.
Gruß
Jochen

Bild

Betrifft: AW: SVerweis aus Access Datenbank funktioniert nicht
von: Erik
Geschrieben am: 07.10.2015 10:37:54
Danke Jochen !
Das wars.
Gruß Erik

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVerweis aus Access Datenbank funktioniert nicht"