Microsoft Excel

Herbers Excel/VBA-Archiv

Filter mit 4 Kriterien über Formel | Herbers Excel-Forum


Betrifft: Filter mit 4 Kriterien über Formel von: Stefan
Geschrieben am: 25.01.2012 08:56:03

Hallo,
ich habe in Spalte D unterschiedliche Artikel.-Nr. und Bezeichnungen.
Der klassische Filter kann jedoch nur auf 2 Kriterien zugreifen.
Demnach hätte ich das Ganze gerne über eine Formel in Spalte E dargestellt und dann eben darüber den Filter gelegt.
D.h.:
Formel un Spalte E:
wenn in D die Kriterien "1/4", oder "BD" oder "QD" oder Leerzelle enthält, dann soll in D das Kennzeichen "relevant" angezeigt werden,...sonst eben leer.
Ich muss jedoch erwähnen, dass in Spalte D vor und nach den o.g. Kriterien noch andere Zahlen/Buchstaben als Artikel-Nr. aufgeführt sind.

Danke für Unterstützung.

Gruß,
Stefan

  

Betrifft: AW: Filter mit 4 Kriterien über Formel von: Josef Ehrensberger
Geschrieben am: 25.01.2012 09:38:19


Hallo Stefan,

so?

Tabelle3

 DE
1TestTest
2ec 1/4 testrelevant
3xxx 
4xxx BDrelevant
5xxx 
6xxx 
7QD xxxrelevant
8xxx 
9xxx 
10 relevant
11xxx 
12123 1/4 123relevant
13xxx 
14 relevant
15xxx 
16xxx 
17xxx 
18xxx 

Formeln der Tabelle
ZelleFormel
E2=WENN(SUMMENPRODUKT((ISTZAHL(FINDEN({"1/4";"BD";"QD"};D2)))+(D2="")); "relevant";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: geht einfacher von: WF
Geschrieben am: 25.01.2012 10:42:20

Hi Sepp,

=WENN(ANZAHL(FINDEN({"1/4";"BD";"QD"};D2));"relevant";"")

Salut WF


  

Betrifft: AW: geht einfacher und ... von: Josef Ehrensberger
Geschrieben am: 25.01.2012 10:47:56


Hallo Walter,

... so kriegt man auch die Leerzellen mit rein.

=WENN((ANZAHL(FINDEN({"1/4";"BD";"QD"};D2))+(D2=""));"relevant";"")





« Gruß Sepp »



  

Betrifft: AW: geht einfacher und ... von: Stefan
Geschrieben am: 25.01.2012 12:14:30

Hallo Walter und Sepp,

habe alle von Euch angegebenen Formeln getestet,....es wird jedoch auch beispielsweise bei folgendem Inhalt in D ein relevant angezeigt, obwohl keines der Kriterien gegeben ist:
G FRU VOLUMEN DQ154(17) 0412
G BB CREAM+ROLL ON PF30(5)+4 0112 DM

Liegt es an der Formel oder mache ich etwas falsch?

Danke und Gruß,
Stefan


  

Betrifft: nicht nachvollziehbar! von: Josef Ehrensberger
Geschrieben am: 25.01.2012 12:19:49


Hallo Stefan,

Tabelle3

 DE
1  
2G FRU VOLUMEN DQ154(17) 0412 
3G BB CREAM+ROLL ON PF30(5)+4 0112 DM 
4  

Formeln der Tabelle
ZelleFormel
E2=WENN((ANZAHL(FINDEN({"1/4";"BD";"QD"};D2))+(D2="")); "relevant";"")
E3=WENN((ANZAHL(FINDEN({"1/4";"BD";"QD"};D3))+(D3="")); "relevant";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: nicht nachvollziehbar! von: Stefan
Geschrieben am: 25.01.2012 13:04:31

hallo sepp,

sorry, fehler lag bei mir,....hab die formel falsch kopiert!
funktioniert wunderbar!

danke und gruß,
stefan


Beiträge aus den Excel-Beispielen zum Thema "Filter mit 4 Kriterien über Formel"