Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht mit Zusatzfrage | Herbers Excel-Forum


Betrifft: Formel gesucht mit Zusatzfrage von: Christina Verena
Geschrieben am: 03.01.2012 16:14:01

Guten Tag,

für folgende Tabelle wird eine kopierfähige Formel in G2 gesucht.
Wie könnte diese aussehen?

Zusatzfrage:
Angenommen, es gäbe weitere Kurse k4 bis k8, dann wäre die Auswertung immer aufwendiger.
Wie geht man in solch einem Fall dann vor?

Für Hilfen besten Dank im Voraus.

Gruß

Christina Verena

Tabelle1

 ABCDEFG
1TermineK1K2K3  Teilnehmernoch zu belegen
2T1JutaIrisUte  Jutakeinen
3T2IrisAnnaJuta  IrisK3
4T3UteJutaAnna  UteK2
5T4HeidiKimLinda  AnnaK1
6          KimK1, K3
7          HeidiK2, K3
8          LindaK1, K2
9          IngeK1, K2, K3
10             
11Gesucht: Kopierfähige Formel in G2           

Tabellendarstellung in Foren Version 5.46


  

Betrifft: AW: Formel gesucht mit Zusatzfrage von: CitizenX
Geschrieben am: 03.01.2012 18:04:23

Hi,

teste mal..

https://www.herber.de/bbs/user/78195.xlsm

Grüße
Steffen


  

Betrifft: Mein Testergebnis ... von: Christina Verena
Geschrieben am: 03.01.2012 18:29:04

Hallo Steffen,

ich danke Dir für Deinen Beitrag.
Legt man die ursprünglichen Daten zugrunde, so müsste bei Jutta der Text "Keine" erscheinen, da sie alle Kurse bereits belegt hat, bei Inge müsste K1, K2, K3 erscheinen, da sie noch keinen Kurs belegt hat.
Auch bei weiteren Testdaten stimmen die Ergebnisse nicht mit den gewünschten überein.
U.U. wird mit der benutzerdefinierten Funktion eine andere Fragestellung beantwortet.
Mit einer Reihe von Hilfsspalten sollte man die Aufgabe lösen können.
Allerdings entnehme ich Deinem Ansatz, dass bei einer Erhöhung der Kurszahl und der Teilnehmerzahl ohne VBA nichts zu machen sein dürfte.
Was meinst Du dazu?

Gruß
Christina Verena


  

Betrifft: AW: Mein Testergebnis ... von: Bernd
Geschrieben am: 03.01.2012 18:33:00

Hallo Christina Verena,

schau Dir mal meinen Lösungsvorschlag an:

https://www.herber.de/bbs/user/78196.xls


Gruß
Bernd


  

Betrifft: Vielen Dank ... von: Christina Verena
Geschrieben am: 04.01.2012 10:28:40

für Deine Monsterformel, die perfekt funktioniert.

Einen schönen Tag.

Gruß

Christina Verena


  

Betrifft: AW: Mein Testergebnis ... von: Reinhard
Geschrieben am: 03.01.2012 19:08:02

Hallo Christina,

Tabellenblatt: C:\DOKUME~1\ich2\LOKALE~1\Temp\[78196.xls]!Tabelle1
   │      A     │   B   │    C   │     D     │      E     │
---┼------------┼-------┼--------┼-----------┼------------┼
 1 │ Termine    │  K1   │   K2   │    K3     │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 2 │ T1         │ Juta  │  Iris  │    Ute    │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 3 │ T2         │ Iris  │  Anna  │   Juta    │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 4 │ T3         │  Ute  │  Juta  │   Anna    │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 5 │ T4         │ Heidi │  Kim   │   Linda   │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 6 │            │       │        │           │            │
---┼------------┼-------┼--------┼-----------┼------------┼
 7 │ Teilnehmer │       │        │           │ n. z. blg. │
---┼------------┼-------┼--------┼-----------┼------------┼
 8 │ Juta       │       │        │           │ keinen     │
---┼------------┼-------┼--------┼-----------┼------------┼
 9 │ Iris       │       │        │ K3,       │ K3         │
---┼------------┼-------┼--------┼-----------┼------------┼
10 │ Ute        │       │ K2,    │ K2,       │ K2         │
---┼------------┼-------┼--------┼-----------┼------------┼
11 │ Anna       │ K1,   │ K1,    │ K1,       │ K1         │
---┼------------┼-------┼--------┼-----------┼------------┼
12 │ Kim        │ K1,   │ K1,    │ K1,K3,    │ K1,K3      │
---┼------------┼-------┼--------┼-----------┼------------┼
13 │ Heidi      │       │ K2,    │ K2,K3,    │ K2,K3      │
---┼------------┼-------┼--------┼-----------┼------------┼
14 │ Linda      │ K1,   │ K1,K2, │ K1,K2,    │ K1,K2      │
---┼------------┼-------┼--------┼-----------┼------------┼
15 │ Inge       │ K1,   │ K1,K2, │ K1,K2,K3, │ K1,K2,K3   │
---┴------------┴-------┴--------┴-----------┴------------┴
Benutzte Formeln:
B8 : =WENN(ZÄHLENWENN(B$2:B$5;$A8)=0;B$1&",";"")
B9 : =WENN(ZÄHLENWENN(B$2:B$5;$A9)=0;B$1&",";"")
B10: =WENN(ZÄHLENWENN(B$2:B$5;$A10)=0;B$1&",";"")
B11: =WENN(ZÄHLENWENN(B$2:B$5;$A11)=0;B$1&",";"")
B12: =WENN(ZÄHLENWENN(B$2:B$5;$A12)=0;B$1&",";"")
B13: =WENN(ZÄHLENWENN(B$2:B$5;$A13)=0;B$1&",";"")
B14: =WENN(ZÄHLENWENN(B$2:B$5;$A14)=0;B$1&",";"")
B15: =WENN(ZÄHLENWENN(B$2:B$5;$A15)=0;B$1&",";"")
C8 : =B8&WENN(ZÄHLENWENN(C$2:C$5;$A8)=0;C$1&",";"")
C9 : =B9&WENN(ZÄHLENWENN(C$2:C$5;$A9)=0;C$1&",";"")
C10: =B10&WENN(ZÄHLENWENN(C$2:C$5;$A10)=0;C$1&",";"")
C11: =B11&WENN(ZÄHLENWENN(C$2:C$5;$A11)=0;C$1&",";"")
C12: =B12&WENN(ZÄHLENWENN(C$2:C$5;$A12)=0;C$1&",";"")
C13: =B13&WENN(ZÄHLENWENN(C$2:C$5;$A13)=0;C$1&",";"")
C14: =B14&WENN(ZÄHLENWENN(C$2:C$5;$A14)=0;C$1&",";"")
C15: =B15&WENN(ZÄHLENWENN(C$2:C$5;$A15)=0;C$1&",";"")
D8 : =C8&WENN(ZÄHLENWENN(D$2:D$5;$A8)=0;D$1&",";"")
D9 : =C9&WENN(ZÄHLENWENN(D$2:D$5;$A9)=0;D$1&",";"")
D10: =C10&WENN(ZÄHLENWENN(D$2:D$5;$A10)=0;D$1&",";"")
D11: =C11&WENN(ZÄHLENWENN(D$2:D$5;$A11)=0;D$1&",";"")
D12: =C12&WENN(ZÄHLENWENN(D$2:D$5;$A12)=0;D$1&",";"")
D13: =C13&WENN(ZÄHLENWENN(D$2:D$5;$A13)=0;D$1&",";"")
D14: =C14&WENN(ZÄHLENWENN(D$2:D$5;$A14)=0;D$1&",";"")
D15: =C15&WENN(ZÄHLENWENN(D$2:D$5;$A15)=0;D$1&",";"")
E8 : =WENN(D8="";"keinen";LINKS(D8;LÄNGE(D8)-1))
E9 : =WENN(D9="";"keinen";LINKS(D9;LÄNGE(D9)-1))
E10: =WENN(D10="";"keinen";LINKS(D10;LÄNGE(D10)-1))
E11: =WENN(D11="";"keinen";LINKS(D11;LÄNGE(D11)-1))
E12: =WENN(D12="";"keinen";LINKS(D12;LÄNGE(D12)-1))
E13: =WENN(D13="";"keinen";LINKS(D13;LÄNGE(D13)-1))
E14: =WENN(D14="";"keinen";LINKS(D14;LÄNGE(D14)-1))
E15: =WENN(D15="";"keinen";LINKS(D15;LÄNGE(D15)-1))

A1:E15
haben das Zahlenformat: Standard

Gruß
Reinhard


  

Betrifft: Vielen Dank von: Christina Verena
Geschrieben am: 04.01.2012 10:31:51

Reinhard für Deine Lösung. Eine Ergänzung für mehr Kurse und mehr Teilnehmer sollte damit für mich möglich sein.

Einen schönen Tag.

Gruß

Christina Verena


Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht mit Zusatzfrage"