Formelberechnung mit Buchstaben



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Formelberechnung mit Buchstaben
von: Thomas
Geschrieben am: 13.05.2002 - 09:13:12

Hallo,
ich möchte in einer Excel-Tabelle mit Buchstaben rechnen, ist dies möglich?
Beispiel: Der Buchstabe B = 8
Der Buchstabe G = 9
Wenn ich in eine Zelle B und in eine andere Zelle G eingebe, möchte ich in einer Summen-Zelle 17 stehen haben, ohne das sich die Buchstaben B und G in Zahlen umwandeln.

Ich würde mich über Tips riesig freuen

nach oben   nach unten

Re: Formelberechnung mit Buchstaben
von: Tobi@s
Geschrieben am: 13.05.2002 - 09:20:05

Hallo,

das funktioniert glaub ich nur, indem man eine eigene Funktion schreibt und die Buchstaben nicht wild durcheinander nummeriert sind.


nach oben   nach unten

So evtl.....
von: Rolf Kersjes
Geschrieben am: 13.05.2002 - 09:58:44

Hallo Thomas,

ich würde das mit einer verdeckten Spalte realisieren. Folgender Tabellenaufbau:


MS Excel von Rolf Kersjes an Thomas
 ABCDE
1B=sverweis(A1;$D$1:$E$7;2;falsch)  A2
2G=sverweis(A2;$D$1:$E$7;2;falsch)  B8
3=summe(B1:B2)    C4
4      D6
5      E5
6      F3
7      G9


Die Spalte B kannst du dann ausblenden.

Rolf

nach oben   nach unten

Re: Formelberechnung mit Buchstaben
von: Andreas
Geschrieben am: 13.05.2002 - 12:41:17

Hallo Thomas,

es gibt ja schon einen Vorschlag, aber hier noch mal eine etwas andere Variante.
In A1 steht B
in A2 steht G
In A3 nun die Summenformel so:
=SUMME(WAHL(CODE(A1:A2)-64;1;8;3;4;5;6;9))

Diese Formel ist eine Matrixformel, muss also mit STRG+SHIFT+ENTER abgeschlossen werden!
Die Formel funktioniert für Grossbuchstaben und weist in diesem Beispiel den folgenden Buchstaben folgende Zahlen zu:
A 1
B 8
C 3
D 4
E 5
F 6
G 8

(weitere Buchstaben sinngemäß ergänzen, siehe auch in der Hilfe unter WAHL-Tabellenfunktion)

Viel Spaß,
Andreas

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formelberechnung mit Buchstaben"