Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem mit Januar | Herbers Excel-Forum


Betrifft: Formelproblem mit Januar von: Sascha
Geschrieben am: 13.02.2012 18:11:34

Hallo Experten.

Ich versuche eine Statistik zu erarbeiten.
In meiner Formel werden 3 Kriterien beachtet. Darin enthalten der Monat eines Datums.

Die Statistik stimmt genau, ausser beim Monat Januar.
Gibt es spezielles das ich beim monat Januar beachten muss, oder warum zählt es mir da immer zuviele zusammen?

Hier die Formel:

=SUMMENPRODUKT((MONAT('Daten 2011'!$AF$2:$AF$3000)=1)*('Daten 2011'!$A$2:$A$3000=B6) *('Daten 2011'!$C$2:$C$3000="Herr")) 
Im Blatt Daten 2011 stehen in dern Spalten AF die Daten, Spalte A ein Kürzel und in Spalte C die Anrede

Liebe Grüsse
Sascha

  

Betrifft: *('Daten 2011'!$A$2:$A$3000>0) von: WF
Geschrieben am: 13.02.2012 18:25:17

Hi,

dieses Produkt musst Du noch einbauen.
0 (null) bzw. Leerzelle wird als Januar interpretiert.

Salut WF


  

Betrifft: AW: *('Daten 2011'!$A$2:$A$3000>0) von: Sascha
Geschrieben am: 13.02.2012 20:48:33

Hallo WF

Diese Formel ergibt noch immer ein falsches Ergebnis.... :-(
Das Datum "Januar" ist in der Spalte AF2:AF3000 enthalten. Also Habe ich das Produkt >0 auch bei AF eingefügt, aber das Ergebnis ist noch immer falsch.

=SUMMENPRODUKT((MONAT('Daten 2011'!$AF$2:$AF$3000=1)>0)*('Daten 2011'!$A$2:$A$3000=B3) *('Daten 2011'!$C$2:$C$3000="Herr")) 
Hast Du noch eine Idee?

LG Sascha


  

Betrifft: erstmal nen Syntaxfehler: Klammer von: WF
Geschrieben am: 13.02.2012 21:00:15

Hi,

monat(a1:a99=1) ist Quatsch
muss heißen:
monat(a1:a99)=1

WF


  

Betrifft: AW: erstmal nen Syntaxfehler: Klammer von: Sascha
Geschrieben am: 13.02.2012 21:08:59

ja sorry, hatte die falsche Formel durch Probieren gepostet. Diese Formel ist die richtige, funktioniert in jedem Monat nur nicht beim Januar...

=SUMMENPRODUKT((MONAT('Daten 2011'!$AF$2:$AF$3000)=1)*('Daten 2011'!$A$2:$A$3000=B3) *('Daten 2011'!$C$2:$C$3000="Herr")) 
Soll heissen: Wenn im Blatt Daten 2011 in der Spalte AF das Datum Januar(Monat) steht, und im Blatt Daten 2011 Spalte A dasselbe Kürzel wie im aktuellen Blatt bei B3 und im Blatt Daten 2011 Spalte C die Anrede Herr, dann Summenprodukt...

Wie gesagt, alles kein Problem, nur beim Januar. Warum das? Wird der Monat Januar anders behandelt als die restlichen Monate?

Gruss Sascha


  

Betrifft: lesen hilft ! von: WF
Geschrieben am: 13.02.2012 21:21:44

ergänze dieses Produkt:
*('Daten 2011'!$AF$2:$AF$3000>0)

hatte nur übersehen, dass es Spalte AF und nicht A ist.
WF


  

Betrifft: :-) lesen hilft Wirklich ! von: Sascha
Geschrieben am: 13.02.2012 21:40:51

Ja hast recht... Sorry
Ich hatte anstatt zu ergänzen, diesen Formelteil ersetzt... :-((

Jetzt funktionierts Prima :-)
Vielen Dank

Kannst Du mir auch noch erklären, warum es beim Januar so eine Prozedur braucht, und bei den anderen Monaten nicht?

Nochmals Dank und gute Nacht

Sascha


  

Betrifft: nochmal hilft lesen von: WF
Geschrieben am: 13.02.2012 21:46:55

in meiner ersten Antwort (oben) schrieb ich:
"0 (null) bzw. Leerzelle wird als Januar interpretiert."

WF


Beiträge aus den Excel-Beispielen zum Thema "Formelproblem mit Januar"