Habe Problem mit der Wenn Formel

Bild

Betrifft: Habe Problem mit der Wenn Formel
von: Marc Philipp
Geschrieben am: 29.09.2003 14:29:58

Hallo

Ich möchte einen Arbeitszeitplan mit Exel erstellen.
Horizontal Die täglichen Stunden
Vertikal die verschiedenen Mitarbeiter.
Für U und K soll 6,25 Std gerechnet werden
Für S und X soll 8,5 Std gerechnet werden.
und am ende Soll die monatliche Arbeitszeit jedes Mitarbeiters zusammenaddiert werden.

Wenn ich mit der "Wenn - oder " Formel arbeite habe ich Pro Zeile 31 Wenn Anweisungen und 1 Summe Anweisung. Dann wirft Exel mir eine Fehlermeldung raus "die Formel ist zu lang".

Wie kann ich das Problem lösen
Danke im Vorraus für eure Hilfe

Gruß
Marc

Bild


Betrifft: AW: Habe Problem mit der Wenn Formel
von: börni
Geschrieben am: 29.09.2003 14:40:33

hallo marc,

du kannst nur 7 mal "wenn" in einer formel verwenden (zumindest wars bis office 97 so)! also musst du dir da was anderes überlegen! du solltest die variablen u, k, s und x irgendwo fix definieren und dann diese definitionen zur berechnung hernehmen!

grüße


Bild


Betrifft: AW: Habe Problem mit der Wenn Formel
von: IngoG
Geschrieben am: 29.09.2003 14:43:50

HAllo Mark,
wenn in deinen Zellen B3:AF3 die stunden der MA bzw die Werte X,S,K,U stehen kannst Du mit folgender Formel rechnen:

=SUMME(B3:AF3)+SUMMENPRODUKT(((B3:AF3="X")+(B3:AF3="S")))*8,5+SUMMENPRODUKT(((B3:AF3="K")+(B3:AF3="U")))*6,25

ist zwar nicht besonders elegant sollte aber funzen
Gruß Ingo


Bild


Betrifft: ZÄHLENWENN - Addition mehrerer Kriterien
von: Boris
Geschrieben am: 29.09.2003 15:44:34

Hi Marc,

ne Alternative ist:

=SUMME(1:1)+SUMME(ZÄHLENWENN(1:1;{"u"."k"."s"."x"})*{6,25.6,25.8,5.8,5})

Bezogen auf Zeile 1.
"u" und "k" werden mit 6,25 gerechnet, "s" und "x" mit 8,5. Zudem werden die Stundeneinträge, die als Zahlen vorliegen, summiert.

Grüße Boris


Bild


Betrifft: AW: Habe Problem mit der Wenn Formel
von: Marc Philipp
Geschrieben am: 29.09.2003 20:48:19

Ihr habt mir sehr geholfen .
Mein Problem wurde gelöst. :-)))

mfg
M.Philipp


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Habe Problem mit der Wenn Formel"