Microsoft Excel

Herbers Excel/VBA-Archiv

Gültigkeitsprüfung mit Formel | Herbers Excel-Forum


Betrifft: Gültigkeitsprüfung mit Formel von: Gegga
Geschrieben am: 21.12.2009 08:26:05

Guten Morgen zusammen
Liegts an den niedrigen Temperaturen hier bei mir im Büro (16°) oder bin ich wirklich zu dumm? (Nein diese Frage muss nicht beantwortet werden :) )
Seit einer Stunde probiere ich für eine Zelle eine Gültigkeitsprüfung zu finden die folgendes prüft:

Wenn in Zelle A5 UND / ODER B5 ein Wert grösser 0 enthalten ist, HINWEIS

So langsam keimt bei mir der Verdacht auf, das ich die Gültigkeitsprüfung für etwas verwenden will, für was sie eigentlich nicht gedacht ist?

Weiss jemand Rat?

Vielen Dank

Greetz Gegga *bibber*

  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: ransi
Geschrieben am: 21.12.2009 08:34:03

Hallo GEgga

Versuch mal so:
Tabelle1

 AB
5  

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
A5Benutzerdefinidert =ZÄHLENWENN($A$5:$B$5;0)=0 
B5Benutzerdefinidert =ZÄHLENWENN($A$5:$B$5;0)=0 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: Gegga
Geschrieben am: 21.12.2009 08:43:35

Morgen Ransi

Nein funktioniert leider nicht (funktionieren schon, aber ned so wie ichmir das gedacht habe)

Geradeben les ich meine Fragestellung nochmals durch und stelle zu meinem Entsetzen fest, das ich das wichtigste vergessen habe (doch zu niedrige Temperaturen!!!)

In A5 und B5 können die Werte stehen. Die Gültigkeitsprüfung soll aber "anspringen" wenn ich in Zelle C5 eine Zahl eingeben will.

Also so sinngemäß, Ist in beiden Zellen A5 oder B5 kein Wert enthalten, darfste ne Eingabe vornehmen, wenn was drinsteht, lösche erst die Werte in A5 und / oder B5 damit man tippen darf.

So sinngemäß

Gruss


  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: ransi
Geschrieben am: 21.12.2009 08:57:08

HAllo

DAnn versuch mal dies:
Tabelle1

 ABC
511 

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
C5Benutzerdefinidert =ODER($A$5="";$B$5="") 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: Gegga
Geschrieben am: 21.12.2009 09:10:22

Nun funktioniert es wenn in beiden Zellen Werte stehen, dann kommt der Hinweis.
Ist jedoch nur eine der beiden Zellen mit einem Wert befüllt, kommt kein Hinweis...

???


  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: Gegga
Geschrieben am: 21.12.2009 09:10:22

Nun funktioniert es wenn in beiden Zellen Werte stehen, dann kommt der Hinweis.
Ist jedoch nur eine der beiden Zellen mit einem Wert befüllt, kommt kein Hinweis...

???


  

Betrifft: =UND($A$5<=0;$B$5<=0) von: Matthias L
Geschrieben am: 21.12.2009 09:09:59

Hallo

Du solltest Deine Frage besser definieren.

In Deiner ersten Frage wolltest Du einen Hinweis,
wenn in Zelle A5 UND / ODER B5 ein Wert grösser 0 enthalten ist.

Dann mußt Du also (kleiner,gleich Null) zulassen

benutzerdefiniert:
Formel:
in C5
=UND($A$5<=0;$B$5<=0)
Gruß Matthias


  

Betrifft: AW: =UND($A$5<=0;$B$5<=0) von: Gegga
Geschrieben am: 21.12.2009 09:20:44

Genau das gleiche wie bei Ransis Vorschlag.
Sind beide zellen befüllt funktionierts, ist jedoch nur eine der beiden befüllt gehts ned...

Nochmal: 3 "Möglichkeiten" gibt es (Wert 10 ist nur ein Beispielwert!!!)

Eingabe in C5 - PRÜFUNG - A5 Wert 10; B5 kein Wert - HINWEIS
Eingabe in C5 - PRÜFUNG - A5 kein Wert; B5 Wert 10 - HINWEIS
Eingabe in C5 - PRÜFUNG - A5 kein Wert; B5 kein Wert - KEIN HINWEIS

Ich hoffe so wirds richtig verstanden was ich will


  

Betrifft: ist leere Zellen ignorieren ohne Häckchen ? oT von: Matthias L
Geschrieben am: 21.12.2009 09:26:08




  

Betrifft: AW: Danke, das wars!!!! von: Gegga
Geschrieben am: 21.12.2009 09:32:46

Jetzt ja :)

Danke, jetzt funktioniert es...


  

Betrifft: hier noch eine Version... von: Tino
Geschrieben am: 21.12.2009 09:37:16

Hallo,

https://www.herber.de/bbs/user/66726.xls

Gruß Tino


  

Betrifft: AW: Gültigkeitsprüfung mit Formel von: Gegga
Geschrieben am: 21.12.2009 08:44:06

Sorry noch offen


Beiträge aus den Excel-Beispielen zum Thema "Gültigkeitsprüfung mit Formel"