Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit der Formel Subtrahieren | Herbers Excel-Forum


Betrifft: Problem mit der Formel Subtrahieren von: Roli
Geschrieben am: 17.11.2009 20:28:16

Guten Abend zusammen,
ich will mir eine Stromabrechnungstabelle machen und mit der habe ich mein Problem.
In der Spalte A habe ich meine Monate,in Spalte B gebe ich den jeweiligen Zählerstand ein,
und in Spalte C will ich den jeweiligen Monatsverbrauch.So habe ich C2 die Formel =B2-B1 und darunter =B3-B2 usw.Die unterste Zelle in der Spalte C will ich den Verbrauch addieren =Summe(C2
:C13).Jetzt ist das Problem das ich in der untersten freien Zelle in C eine minus Zahl bekomme.
Wie bekomme ich das richtig hin.Vielen dank

  

Betrifft: AW: Problem mit der Formel Subtrahieren von: Josef Ehrensberger
Geschrieben am: 17.11.2009 20:44:18

Hallo Roli,

so?

Tabelle3

 ABC
1MonatZählerstandVerbrauch
2jan12345 
3feb134561111
4mrz145671111
5apr156781111
6mai167891111
7jun178901101
8jul189011011
9aug19012111
10sep203451333
11okt21234889
12nov  
13dez  
14Summe 8889
15   

Formeln der Tabelle
ZelleFormel
C3=WENN(B3>0;B3-B2;"")
C4=WENN(B4>0;B4-B3;"")
C5=WENN(B5>0;B5-B4;"")
C6=WENN(B6>0;B6-B5;"")
C7=WENN(B7>0;B7-B6;"")
C8=WENN(B8>0;B8-B7;"")
C9=WENN(B9>0;B9-B8;"")
C10=WENN(B10>0;B10-B9;"")
C11=WENN(B11>0;B11-B10;"")
C12=WENN(B12>0;B12-B11;"")
C13=WENN(B13>0;B13-B12;"")
C14=SUMME(C3:C13)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Problem mit der Formel Subtrahieren von: Roli
Geschrieben am: 17.11.2009 20:58:10

Hallo Sepp,
Vielen Dank für die schnelle Antwort,deine Lösung funktioniert perfekt!!!
Merci und einen schönen Abend,grussRoli


Beiträge aus den Excel-Beispielen zum Thema "Problem mit der Formel Subtrahieren"