Problem mit Formel

Bild

Betrifft: Problem mit Formel
von: Thomas
Geschrieben am: 04.11.2003 11:32:04

Hallöchen

Ich hab ein Problem mit folgender Formel:
=WENN(ZEILEN($1:1)>ZÄHLENWENN($B$1:$B$25;$F$1);"";INDEX($C$1:$C$25;KKLEINSTE(WENN((B$1:B$25=$F$1);ZEILE($1:$25));ZEILEN($1:1))))

So funktioniert sie ja noch. Wenn ich sie allerdings in die nächste Zeile kopiere, kommt immer #Zahl!

Als ich die Formel für was ähnliches bekommen habe klappte alles.
Da standen auch noc diese {} klammern, aber dann zeigt er mir die Formel als Text. wenn ich versuche die Formel mit den Klammern aus der anderen tabelle zu kopieren löscht er Excel einfach die Klammern.

Bin für jede Hilfe dankbar.

Schon mal danke im voraus.

Gruss Thomas

Bild


Betrifft: AW: Problem mit Formel
von: Mac4
Geschrieben am: 04.11.2003 11:34:44

Hallo Thomas,

hier handelt es sich um eine Matrixformel. Nach Eingabe der Formel diese nicht mit Enter, sondern mit der Tastenkombi Strg+Shift+Enter abschließen!

Marc


Bild


Betrifft: AW: Problem mit Formel
von: Jürgen
Geschrieben am: 04.11.2003 11:40:12

Hallo Thomas,
geschweifte Klammern weißen darauf hin, dass es eine Array-Formel ist.
D.h.Abschluß der Formel mit Strg+Shift+Enter!
Ich hoofe das hilft.
Gruß
Jürgen
Ansonsten mal die Tabelle hochladen


Bild


Betrifft: AW: Problem mit Formel
von: Thomas
Geschrieben am: 04.11.2003 11:43:48


Danke Marc.

Du hast mir sehr geholfen.
Jetzt sehe ich klarer.
War ja klar, großes Problem, kleine Lösung

Nochmals Danke.

Gruss Thomas


Bild

Beiträge aus den Excel-Beispielen zum Thema " Problem mit Formel"