Microsoft Excel

Herbers Excel/VBA-Archiv

Formel mit zwei Bedigungen | Herbers Excel-Forum


Betrifft: Formel mit zwei Bedigungen von: Marcel
Geschrieben am: 11.12.2009 08:50:13

Moin, moin!

Ich möchte gerne folgende Formel haben:

Es wird vergleichen Spalte A von zwei Tabellenblätern (Blatt1 und Blatt2) - dort ist im Bereich A2-A100 jeweils eine Zahl und bei Identität dieser Zahl soll eine weitere Bedigung erfüllt sein. Aus Spalte B (B2-B100) soll in beiden Blättern abgeglichen werden ob aus einer Zahlenkette die letzte Zahl =2 ist.

Hatte dies mit Rechts(B2;1)=2 versucht, kriege es aber nicht hin.

Wenn diese beiden Bedingungen erfüllt sind, soll der Wert aus Spalte C (Blatt 2) in Spalte C der passenden Zeile in Blatt 1 geschrieben werden, ansonsten leer bleiben.

Ich kann hier irgendwie nichts hochladen. Wird gesperrt durch unsere EDV. Ich hoffe, ihr könnte mir dennoch helfen. Vielen Dank für eure Bemühungen und ein schönes Wochenende!

Marcel Dirks

  

Betrifft: AW: Formel mit zwei Bedigungen von: Mike
Geschrieben am: 11.12.2009 08:53:04


Hey Marcel,

hast Du den Link https://www.herber.de/forum/file_upload.html schon mal probiert?

Wie meinst Du dies "im Bereich A2-A100 jeweils eine Zahl und bei Identität dieser Zahl soll eine weitere Bedigung erfüllt sein" genau?

Danke und Gruss, Mike


  

Betrifft: AW: Formel mit zwei Bedigungen von: Marcel
Geschrieben am: 11.12.2009 09:12:42

Hallo Mike,

also in Spalte A stehen im Bereich A2-A100 in jeder Zeile Zahlen z.B. 1,2,3,4 usw. (in beiden Blättern - aber eben nicht identische Zahlen). Jetzt muss zunächst einmal geprüft werden, ob der Wert z.B. aus A3 in zweiten Tab.-Blatt im Bereich A3-A100 ist. Wenn das so ist, muss die zweite Prüfung kommen.


  

Betrifft: AW: Formel mit zwei Bedigungen von: {Boris}
Geschrieben am: 11.12.2009 09:10:29

Hi Marcel,

Hatte dies mit Rechts(B2;1)=2 versucht, kriege es aber nicht hin.

Die Funktion RECHTS liefert als Rückgabewert den Datentyp "TEXT".

=Rechts(B2;1)="2"

Grüße Boris


  

Betrifft: AW: Formel mit zwei Bedigungen von: Marcel
Geschrieben am: 11.12.2009 09:27:31

Danke. Das erklärt schon mal eine Fehlerquelle. Wie muss ich denn den ersten Part und den Zweiten verknüpfen?


  

Betrifft: AW: Formel mit zwei Bedigungen von: {Boris}
Geschrieben am: 11.12.2009 09:34:49

Hi Marcel,

ich kapier´s auch nicht ganz. Brauchst Du ne Summe über alle Kombinationen? Dann ist das "Summieren mit mehreren Bedingungen; http://excelformeln.de/formeln.html?welcher=61

Grüße Boris


  

Betrifft: AW: Formel mit zwei Bedigungen von: Marcel
Geschrieben am: 11.12.2009 09:47:04

Nee, keine Summe. Also noch ein Versuch:

Es gibt zwei Tab-Blätter (Blatt 1 = Ziel und Blatt 2 = Quelle)
Jeweils in Spalte A (Bereich A3 bis A100) mit Zahlen

Hierzu muss ein erster Vergleich stattfinden. Wenn z.B. die Zahl aus A3 im Blatt 1 in Spalte A aus dem Blatt 2 im Bereich A3-A100 gefunden wird ist die erste Bedingung.

In Spalte B ist auch jeweils eine Zahlenkette zu jedem Datensatz. Hier muss aber die letzte Zahl = 2 sein.
Daher mein Versuch mit dem Rechts...

Wenn beide Bedingungen erfüllt sind, soll der dazugehörige Wert aus Spalte C aus dem Blatt 2 in Zelle C3 in Blatt 1 geschrieben werden. Wenn A3 aus Blatt 1 in Blatt 2 nicht zu finden ist, bleibt C3 leer. Diese Formel kann ich dann entsprechend kopieren. Verständlicher?


  

Betrifft: hast Du .. Formel mit zwei Bedigungen von: Mike
Geschrieben am: 11.12.2009 09:56:32


Hey Marcel,

hast Du den Link (mit einer Beispielsdatei Deines Problems) https://www.herber.de/forum/file_upload.html schon mal probiert?

Gruss
Mike


  

Betrifft: AW: hast Du .. Formel mit zwei Bedigungen von: Marcel
Geschrieben am: 11.12.2009 09:58:33

Nee, ich kann hier ja nichts hochladen. Leider. Unsere Firewall verhindert das. Sonst hätte ich das ja bereits getan. Darum hatte ich es im ersten Beitrag gleich geschrieben.


  

Betrifft: keiner eine Idee? von: Marcel
Geschrieben am: 11.12.2009 10:58:43

Hat keiner Idee und kann mir helfen?


  

Betrifft: so könnte von: Mike
Geschrieben am: 11.12.2009 11:17:12


Hey Marcel,

so könnte es funktionieren:


Tabelle1

 ABCDEFGHI
2  Blatt 1      Blatt 2     
3        ABHilfsspalteCD
4                 
53gefunden    25555522CWert2 
64gefundenCWert4  355533CWert3 
75gefunden    43444422CWert4 
87#NV#NV  555555CWert5 
9        6    CWert6 
10                 

verwendete Formeln
Zelle Formel
B5 =WENN(SVERWEIS(A5; E5:E14; 1; FALSCH); "gefunden"; "")
C5 =WENN(UND(B5="gefunden"; SVERWEIS(A5; E5:G14; 3; FALSCH)="2"); SVERWEIS(A5; E5:H14; 4; FALSCH); "")
G5 =RECHTS(F5;1)
B6 =WENN(SVERWEIS(A6; E6:E15; 1; FALSCH); "gefunden"; "")
C6 =WENN(UND(B6="gefunden"; SVERWEIS(A6; E6:G15; 3; FALSCH)="2"); SVERWEIS(A6; E6:H15; 4; FALSCH); "")
G6 =RECHTS(F6;1)
B7 =WENN(SVERWEIS(A7; E7:E16; 1; FALSCH); "gefunden"; "")
C7 =WENN(UND(B7="gefunden"; SVERWEIS(A7; E7:G16; 3; FALSCH)="2"); SVERWEIS(A7; E7:H16; 4; FALSCH); "")
G7 =RECHTS(F7;1)
B8 =WENN(SVERWEIS(A8; E8:E17; 1; FALSCH); "gefunden"; "")
C8 =WENN(UND(B8="gefunden"; SVERWEIS(A8; E8:G17; 3; FALSCH)="2"); SVERWEIS(A8; E8:H17; 4; FALSCH); "")
G8 =RECHTS(F8;1)
G9 =RECHTS(F9;1)

Füllfarben und Muster
Zelle Rot Grün Blau Color Muster Farbe
A2 255255065535   
B2 255255065535   
C2 255255065535   
E2 20425520413434828   
F2 20425520413434828   
G2 20425520413434828   
H2 20425520413434828   
I2 20425520413434828   
G3 19219219212632256   
Zellen mit Füllfarbe automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: noch .. etwas fixierter von: Mike
Geschrieben am: 11.12.2009 11:19:35


... nicht dass es noch Probleme mit dem Sverweis gibt .. ;-) (Zellen fixiert)


Tabelle1

 ABCDEFGHI
2  Blatt 1      Blatt 2     
3        ABHilfsspalteCD
4                 
53gefunden    25555522CWert2 
64gefundenCWert4  355533CWert3 
75gefunden    43444422CWert4 
87#NV#NV  555555CWert5 
9        6    CWert6 

verwendete Formeln
Zelle Formel
B5 =WENN(SVERWEIS(A5; $E$5:$E$14; 1; FALSCH); "gefunden"; "")
C5 =WENN(UND(B5="gefunden"; SVERWEIS(A5; $E$5:$G$14; 3; FALSCH)="2"); SVERWEIS(A5; $E$5:$H$14; 4; FALSCH); "")
G5 =RECHTS(F5;1)
B6 =WENN(SVERWEIS(A6; $E$5:$E$14; 1; FALSCH); "gefunden"; "")
C6 =WENN(UND(B6="gefunden"; SVERWEIS(A6; $E$5:$G$14; 3; FALSCH)="2"); SVERWEIS(A6; $E$5:$H$14; 4; FALSCH); "")
G6 =RECHTS(F6;1)
B7 =WENN(SVERWEIS(A7; $E$5:$E$14; 1; FALSCH); "gefunden"; "")
C7 =WENN(UND(B7="gefunden"; SVERWEIS(A7; $E$5:$G$14; 3; FALSCH)="2"); SVERWEIS(A7; $E$5:$H$14; 4; FALSCH); "")
G7 =RECHTS(F7;1)
B8 =WENN(SVERWEIS(A8; $E$5:$E$14; 1; FALSCH); "gefunden"; "")
C8 =WENN(UND(B8="gefunden"; SVERWEIS(A8; $E$5:$G$14; 3; FALSCH)="2"); SVERWEIS(A8; $E$5:$H$14; 4; FALSCH); "")
G8 =RECHTS(F8;1)
G9 =RECHTS(F9;1)

Füllfarben und Muster
Zelle Rot Grün Blau Color Muster Farbe
A2 255255065535   
B2 255255065535   
C2 255255065535   
E2 20425520413434828   
F2 20425520413434828   
G2 20425520413434828   
H2 20425520413434828   
I2 20425520413434828   
G3 19219219212632256   
Zellen mit Füllfarbe automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: noch .. etwas fixierter von: Marcel
Geschrieben am: 11.12.2009 11:39:16

Super. Das klappt. Danke


  

Betrifft: vielleicht so... von: Tino
Geschrieben am: 11.12.2009 11:26:27

Hallo,


https://www.herber.de/bbs/user/66518.xls

Gruß Tino


  

Betrifft: AW: vielleicht so... von: Marcel
Geschrieben am: 11.12.2009 11:45:42

Danke. Gucke ich mir gleich auch noch mal an. Sieht gut aus, da ich keine Hilfsspalten brauche.


  

Betrifft: AW: vielleicht so... von: Mike
Geschrieben am: 11.12.2009 12:07:00


(kleiner Kommentar am Rande)

... das ist mal wieder eine IT-Logik, download geht aber upload nicht .. ;-)

Gruss
Mike


  

Betrifft: AW: vielleicht so... von: Marcel
Geschrieben am: 11.12.2009 12:22:02

Jo, das kannst den IT'lern hier im Hause echt sagen. Die Excel-Datei kann ich öffnen, aber z.B. ein Word oder PowerPoint Dokument darf ich nicht öffnen... bekloppt ,oder...


  

Betrifft: AW: vielleicht so... von: Marcel
Geschrieben am: 11.12.2009 12:20:45

Hier habe ich noch eine Frage/Anmerkung:

Beispiel:

Tabelle1 Zelle A93 (=92) wird gefunden in Tabelle 2 in Zelle A9

Bedingung 1 erfüllt

Nun erfolgt der zweite Abgleich in Tabelle 2 Spalte B:

Hier muss die letzte Zahl = 2 sein (trifft zu da 92 in Spalte B steht)

Wenn diese Bedingung auch erfüllt ist, soll der dazugehörige Werte aus Spalte C (=Test8) in Tabelle 1 – Zelle C93 stehen.

Wenn nicht beide Bedingungen erfüllt sind, soll die Zelle C93 leer bleiben.

In deinem Bsp. steht aber nun Text7 (das gehört zu 93). Ist also falsch. Hier müsste dir Formel also angepasst werden, oder?


  

Betrifft: AW: vielleicht so... von: Tino
Geschrieben am: 11.12.2009 12:32:18

Hallo,
da war noch ein Fehler, mach in der Formel

aus ZEILE($1:$99)

dies ZEILE($2:$100)



Gruß Tino


  

Betrifft: AW: vielleicht so... von: marcel
Geschrieben am: 11.12.2009 12:41:20

danke


Beiträge aus den Excel-Beispielen zum Thema "Formel mit zwei Bedigungen"