WENN-Formel mit VBA



Excel-Version: Excel 97/2000
nach unten

Betrifft: WENN-Formel mit VBA
von: Nina
Geschrieben am: 02.05.2002 - 09:19:37

Hallo,

ich habe ein kleines Problemchen:
Die WENN-Formel in einer Zelle soll dynamisch mit VB generiert werden.
Der Code
Worksheets("Tabelle1").Range("A1").Formula = "=WENN(B1=10; 1; 2)"
führt allerdings zu einem
Laufzeitfehler '1004': Anwendungs- und objektdefinierter Fehler"
Ich habe auch schon probiert, das "WENN" durch "IF" zu ersetzen - kein Chance, das zum Laufen zu bekommen.

Übrigens: auf die WENN-Formel verzichten und alles komplett mit VBA zu lösen ist nicht möglich.

Freue mich über jede Hilfe - es ist dringend!

Grüße,
Nina

nach oben   nach unten

Re: WENN-Formel mit VBA
von: Volker Croll
Geschrieben am: 02.05.2002 - 09:28:06

Hallo Nina,

es muss heissen:

Worksheets("Tabelle1").Range("A1").FormulaR1C1 = "=IF(RC[1]=10, 1, 2)"

kannst Du ganz einfach herausbekommen, wenn Du den Makrorecorder startest (EXTRAS > MAKROS > AUFZEICHNEN) bevor Du die Formel eingibst.

Gruss Volker

nach oben   nach unten

Re: WENN-Formel mit VBA
von: Nina
Geschrieben am: 02.05.2002 - 09:30:29

Hallo Volker!

Danke für die schnelle Antwort!

Gruß,
Nina


nach oben   nach unten

Re: WENN-Formel mit VBA
von: Lars
Geschrieben am: 03.05.2002 - 13:58:51

Hi ich hatte das selbe Prob und hab dann folgendes rausgefunden.
Probiers mal mit:
Worksheets("Tabelle1").Range("A1").Formula = "=IF(B1=""10""; 1; 2)"
nach oben   nach unten

Das soll bei Dir funktionieren ? Staun ...
von: Volker Croll
Geschrieben am: 03.05.2002 - 17:47:05

Hallo Lars,

Nina schrieb schon, dass auch Deine Version zu "Laufzeitfehler '1004': Anwendungs- und objektdefinierter Fehler" führt.

Gruss Volker

nach oben   nach unten

Re: Das soll bei Dir funktionieren ? Staun ...
von: lars
Geschrieben am: 05.05.2002 - 10:54:49

Hi

Stimmt die ; müssen ja auch , werden
sorry


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "WENN-Formel mit VBA"