Microsoft Excel

Herbers Excel/VBA-Archiv

ZÄHLENWENN funktioniert nicht mit "<"

Betrifft: ZÄHLENWENN funktioniert nicht mit "<" von: Matthias Pospiech
Geschrieben am: 19.09.2004 18:00:12

Ich benutze:
=ZÄHLENWENN(Rohdaten!E2:E43;"< 50 %")~f~

das zählt mir aber 0 Einträge.

Wenn ich hingegen nach
=ZÄHLENWENN(Rohdaten!E2:E43;"50 %")

suchen lasse und nur einen Eintrag dahingehend ändere
zählt Excel den Beitrag wieder.

das gleiche gilt für ">"
????

Matthias

  


Betrifft: AW: ZÄHLENWENN funktioniert nicht mit "<" von: Ramses
Geschrieben am: 19.09.2004 18:04:36

Hallo

vermutlich sind die Zellen mit den Prozentwerten als Text formatiert

Tabelle1
 ABC
1ZahlErgebnis 
250%2 
345%  
430%  
575%  
6   
7TextErgebnis 
850%0 
945%  
1030%  
1175%  
12   
Formeln der Tabelle
B2 : =ZÄHLENWENN(A2:A6;"< 50%")
B8 : =ZÄHLENWENN(A8:A12;"< 50%")
 




Gruss Rainer


  


Betrifft: AW: ZÄHLENWENN funktioniert nicht mit "<" von: Matthias Pospiech
Geschrieben am: 19.09.2004 18:09:29

Das ist richtig, die Zellen sind als Text deklariert und müssen das auch sein.

Die Daten werden aus einer Textdatei importiert und ich weiß prinzipiell nicht welchen Inhalt die Zellen haben werden. Prinzipiell könnte da also auch "< 50 Prozent" stehen.
Die Zellen in Zahlen umzuwandeln ist somit keine für mich wirkliche nutzbare Lösung.

Matthias


  


Betrifft: AW: ZÄHLENWENN funktioniert nicht mit "<" von: Ramses
Geschrieben am: 19.09.2004 18:24:13

Hallo

dann hast du ein Problem !
Text ist Text und Zahl ist Zahl.

Du kannst Text nicht auf einen Parameter mit "<" abfragen.

Das ist genauso als wenn du ein Lexikon abfragen würdest, zähle mir alle Daten kleiner Bohrturm. Was würdest du dann erwarten ? ;-)

Gruss Rainer


  


Betrifft: AW: ZÄHLENWENN funktioniert nicht mit "<" von: Matthias Pospiech
Geschrieben am: 19.09.2004 18:29:08

Das Problem ist schon klar. Das grundliegende Problem ist ja auch, dass ich kleiner und größer überhaupt nicht auswerten will. Was ich möchte ist ganz stur Strings zählen.

Gelöst habe ich das ganze jetzt dadurch, dass ich den Text auf < und > durchsuchen lasse und durch "_kleiner" und "_größer" ersetze...

keine elegante Lösung, aber es funktioniert jetzt wenigstens

Matthias


  


Betrifft: AW: ZÄHLENWENN funktioniert nicht mit "<" von: Matthias Pospiech
Geschrieben am: 19.09.2004 18:05:48

Ich sehe gerade, dass Excel < und > auswertet.

Ich habe aber nur Text in den Zellen stehen und möchte ihn auch als Text auswerten.
D.h. diese Funktion von Excel zum Eingrenzen des Ergebniswertes möchte ich _nicht_ nutzen.

Geht das irgentwie, wenn auch mit einer anderen Makrofunktion ?

Matthias


  


Betrifft: SUMMENPRODUKT() von: Jörg Gradert
Geschrieben am: 19.09.2004 20:31:51

Hallo Matthias,

=SUMMENPRODUKT((Rohdaten!E2:E43="<50%")*1)

Gruss Jörg