Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Funktion mit Uhrzeitformat

Betrifft: Wenn Funktion mit Uhrzeitformat von: Andreas
Geschrieben am: 02.09.2014 15:28:06

Hallo,

ich benötige mal wieder Hilfe ;-)

Ich habe folgendes, ich nutze Hilfsspalten als Eingabe von Zeiten mit Dezimalzahl
A1 7,75 und B1 zeigt dann 7:45 Uhr bis hier alles super Formel A1/24.

Jetzt kommt mein Problem:
1. Wenn ich A1 leer lasse, soll in B1 auch kein Wert (Zeit) stehen
2. Statt der Zeiteingabe muss ich häufig Kürzel verwenden z.B. F, R, U oder D, diese Eingaben sollen dann auch in B1 übernommen werden.

Ich hatte es mit folgender Formel in B1 vergebens versucht


;WENN(ODER(A1="F";A1="R";A1="U";A1="D");(A1/24))
Wäre für Hilfe dankbar, vielleicht kann jemand die Formel korrekt eintragen!

Andreas

  

Betrifft: AW: Wenn Funktion mit Uhrzeitformat von: Hajo_Zi
Geschrieben am: 02.09.2014 15:29:42

Hallo Andreas,

=WENN(ODER(A1="F";A1="R";A1="U";A1="D");A1;(A1/24))

GrußformelHomepage


  

Betrifft: AW: Wenn Funktion mit Uhrzeitformat von: Andreas
Geschrieben am: 02.09.2014 15:39:59

Halo Hajo,

das war ja super schnell, danke! Funktioniert auch soweit bis auf, wenn die B1 leer bleibt zeigt A8 noch 0:00 an


  

Betrifft: AW: Wenn Funktion mit Uhrzeitformat von: Hajo_Zi
Geschrieben am: 02.09.2014 15:41:09

=Wenn(A1="";"";WENN(ODER(A1="F";A1="R";A1="U";A1="D");A1;(A1/24)))

Gruß Hajo


  

Betrifft: AW: Wenn Funktion mit Uhrzeitformat von: Andreas
Geschrieben am: 02.09.2014 15:45:50

Vielen Dank alles Super!!

Gruß Andreas


  

Betrifft: AW: Wenn Funktion mit Uhrzeitformat von: Rudi Maintaire
Geschrieben am: 02.09.2014 15:49:42

Hallo,
uder so:
=WENN(A1="";"";WENN(ISTZAHL(A1);A1/24;A1))

Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Funktion mit Uhrzeitformat"