WENN-Formel mit 2 WENN´s

Bild

Betrifft: WENN-Formel mit 2 WENN´s
von: Reservist
Geschrieben am: 25.10.2003 23:03:11

Guten Abend

Scheitere wieder mal an sichelich einfache Formel. Da es spät wird und ich wenigstens diesen Teil abgeschlossen haben möchte brauche ich wieder mal
Eure Hilfe.

Hier nichtfunktionierende Versuche
=WENN(UND(V79<>"";X79*(100%+Z79);0);"";WENN(V79>99;RUNDEN(X79*(100%+Z79);-1);""))
=WENN(UND(V79<>"";V79>99);RUNDEN(X79*(100%+Z79);0;(X79*(100%+Z79));-1);"")

Herauskommen soll:
wenn nichts - dann nichts
wenn Wert - dann auf ganze Zahl gerundet
wenn Wert über 100 - dann auf 10-ner gerundet

Danke schon mal vorab
Gruß Thorsten

Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Ramses
Geschrieben am: 25.10.2003 23:11:19

Hallo

probier mal:

=WENN(V79="";"";WENN(V79<100;RUNDEN(X79*(100%+Z79);0);RUNDEN(X79*(100%+Z79);-1)))

Gruss Rainer


Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Reservist
Geschrieben am: 25.10.2003 23:16:53

Danke Rainer,

funktioniert wie gewollt.

Ein schönen Sonntag noch,
Gruß Thorsten


Bild


Betrifft: BTW: Was soll denn (100%+Z79) bezwecken?
von: Boris
Geschrieben am: 25.10.2003 23:14:05

Hi Thorsten,

...denn das 100% macht imho Null Sinn...

Grüße Boris


Bild


Betrifft: Betrag incl. MwSt berechnen...
von: Ramses
Geschrieben am: 25.10.2003 23:19:43

Hallo Boris,

denke ich zumindest :-)

Da 100% = 1 wird der Betrag mit 1.16, oder was ihr gerade als MwSt-Satz habt bzw. in Z79 steht, multipliziert.

Gruss Rainer


Bild


Betrifft: Sag ich doch - 100% macht Null Sinn;-)) oT
von: Boris
Geschrieben am: 25.10.2003 23:23:03

Grüße Boris


Bild


Betrifft: AW: BTW: Was soll denn (100%+Z79) bezwecken?
von: Reservist
Geschrieben am: 25.10.2003 23:24:52

Hi Boris,

"Z79" ist eine prozentformatierte Zelle. Dieser Wert wird per Hand eingetragen und ändert sich in jeder Zeile. In dieser Zelle soll also auch sichtbar stehen
z.B. Aufschlag 15%.
Wenn's einfacher geht - bin ich für deinen Hinweis, Hilfe dankbar.

Gruß Thorsten


Bild


Betrifft: Erklärung..
von: Ramses
Geschrieben am: 25.10.2003 23:28:30

Hallo

wie du schon schreibst: prozentformatiert
Wenn du in die Zelle schreibst 100% und dann das Standardformat der Zelle wählst, wirst du sehen, dass real in der Zelle 1 steht.
Excel formatiert einfach um, bzw. dividiert die Eingabe 10% automatisch durch 100. Dann steht in der Zelle real 0.4

du kannst di Formel also auch schreiben (1+Z79) und kommst auf das gleiche.

Gruss Rainer


Bild


Betrifft: AW: Erklärung..
von: Reservist
Geschrieben am: 25.10.2003 23:42:25

Hallo Boris,

funktioniert.

In Zukunft werde ich`s nach deiner Methode machen, da noch etwas kürzer.
Falsch war es mit den 100% aber nicht.

Also, besten Dank,
Gruß Thorsten


Bild


Betrifft: AW: Sorry
von: Reservist
Geschrieben am: 25.10.2003 23:50:11

Sorry Rainer,

habe wohl eben Namen verwechselt.

Danke
Gruß Thorsten


Bild


Betrifft: O.K. - insofern macht es Sinn :-) oT
von: Boris
Geschrieben am: 25.10.2003 23:30:39




Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Reinhard
Geschrieben am: 25.10.2003 23:17:54

Hallo Thorsten,
=WENN(A1<>"";WENN(A1>=100;10*RUNDEN(A1/10;0);RUNDEN(A1;0));"")
da ich X79*(100%+Z79 nicht durchblicke musst du dir die letzten beiden A1 anpassen, die ersten beiden A1s durch V79 ersetzen.
Gruß
Reinhard


Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Reservist
Geschrieben am: 25.10.2003 23:58:31

Hallo Reinhard,

auf die Schnelle komme ich hiermit noch nicht klar. Der prozentuale Aufschlag fehlt wohl. Schau`s mir aber später nochmal an.

Auf jeden Fall Danke
Gruß Thorsten


Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Klaus-Dieter
Geschrieben am: 25.10.2003 23:22:50

Hallo Thorsten,

etwa so?

Tabelle1
 AB
2WertErgebnis
3123120
411,211
512,812
6  
Formeln der Tabelle
B3 : =WENN((A3)>100;GANZZAHL(A3/10)*10;WENN((A3)<>0;GANZZAHL(A3);""))
B4 : =WENN((A4)>100;GANZZAHL(A4/10)*10;WENN((A4)<>0;GANZZAHL(A4);""))
B5 : =WENN((A5)>100;GANZZAHL(A5/10)*10;WENN((A5)<>0;GANZZAHL(A5);""))
B6 : =WENN((A6)>100;GANZZAHL(A6/10)*10;WENN((A6)<>0;GANZZAHL(A6);""))
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruß Klaus-Dieter


Bild


Betrifft: AW: WENN-Formel mit 2 WENN´s
von: Reservist
Geschrieben am: 25.10.2003 23:32:42

Hallo Klaus-Dieter,

danke für Antwort, ist ja enorm was meine kleine Frage hier auslöst.
War eigentlich schon mit der ersten Antwort zufrieden. Schaue mir
aber alle Formeln an.

Andere Frage
Wie bekomme ich so ein Tabellenausschnitt in`s Fragefeld ?

Gruß Thorsten


Bild


Betrifft: AW: Tabelle darstellen
von: Marcus Rose
Geschrieben am: 26.10.2003 07:08:25

Hallo Thorsten,

Dafür brauchst Du ein Tool, wie die Excel Jeanie. Diese bekommst Du unter :
http://www.haserodt.de/ejh_do/ex_jean_info.htm .Wenn Du diese richtig in Dein Excel eingebunden hast, kannst Du einen Teil Deiner Tabelle markieren und die Jeanie aufrufen. Dann wählst Du kompakt und fügst diesen Teil in Deinen Thread ein ... Ist ganz einfach (Und hilft auch manchmal um sich ein besseres Bild von dem Problem zu machen)


Gruß Marcus
Das Forum lebt auch von den Rückmeldungen der Fragesteller


Die neue Excel-Homepage für Anfänger

Eine kleine Formelsammlung


 Bild

Beiträge aus den Excel-Beispielen zum Thema " WENN-Formel mit 2 WENNs"