Wenn/ Dann Funktion

Bild

Betrifft: Wenn/ Dann Funktion
von: Bendio
Geschrieben am: 25.02.2005 12:16:15
Hallo, ich habe eine Liste erstellt zum Auswerten und habe dazu die wenn funktion genutzt. Jetzt möchte ich aber eine dritte möglichkeit der Auswertung haben und nicht nur wie im Beispiel nur zwei.
1. Möglichkeit es sind die Disziplinen abgelegt und bestanden =X
2. Möglichkeit es sind die Disziplinen abgelegt und nicht bestanden =0
und nun möchte ich, wenn gar nichts abgelegt bzw eingetragen worden ist =-
und das habe ich bis jetzt leider nicht hinbekommen.
Hoffe ich habe mich halbwegs verständlich ausgedrückt.
Bedanke mich an der Stelle schon mal für die Hilfe.
Gruß Bendito

Bild

Betrifft: AW: Wenn/ Dann Funktion
von: Matthias
Geschrieben am: 25.02.2005 12:20:35
Hilft Dir das weiter?:
=WENN(A3<>"";(WENN(A3="bestanden";"x";"0"));"-")
MFG MLB
Bild

Betrifft: AW: Wenn/ Dann Funktion
von: Harald Kapp
Geschrieben am: 25.02.2005 12:20:51
Hallo Bendito,
du kannnst Bedingungen schachteln (bis zu 7):
Wenn("es sind die Disziplinen abgelegt und bestanden";X;Wenn("es sind die Disziplinen abgelegt und nicht bestanden ";0;""))
Im Klartext wäre das etwa:
Wenn "es sind die Disziplinen abgelegt und bestanden" dann
Ergebnis = X
Sonst Wenn "es sind die Disziplinen abgelegt und nicht bestanden " dann '1. Bedingungnicht erfüllt, also 2. Bedingung prüfen
Ergebnis = 0
Sonst 'Weder Bed.1 noch Bed.2 sind erfüllt
Ergebnis = "" ' leerees Ergebnis
Ende der Wenn-Abfrage

Gruß Harald
Bild

Betrifft: AW: Wenn/ Dann Funktion
von: Daniel
Geschrieben am: 25.02.2005 12:23:16
Hallo,
Es ist möglich Wenn Formelnd zu verschachteln.
Wenn(Bedingung1;Dann1;Wenn(Bedingung2;Dann2;Dann3))
Gruss
Daniel
Bild

Betrifft: AW: Wenn/ Dann Funktion
von: Bendito
Geschrieben am: 25.02.2005 13:09:35
Hi,
erstmal danke für die wahsinns schnellen Antworten.
Ich habe jetzt versucht mehrere Wenn Funktionen zu verschachtel, aber ich bin was Exel angeht noch ein Laie und jedesmal hatte ich einen Fehler in der Formel obwohl ich die Formel ja nur weitergeführt habe also praktisch abgeschrieben. Ich habe in der Zelle I11
dann "#WERT" stehen.
Oder es heist zu viele Argumente, ich lade die Mappe jetzt mal zum Server hoch vielleicht seht ihr dann mein Fehler denn ich gemacht habe besser.
Gruß Bendito
Bild

Betrifft: AW: Wenn/ Dann Funktion
von: wolfram
Geschrieben am: 25.02.2005 14:06:49
Bei tiefen Verschachtelungen ergibt sich Dein Problem (#WERT oder zu viele Argumente) meist durch eine falsche Anzahl von Klammern. Selbst, wenn man noch so genau hinschaut, am Ende fehlt meist eine oder man hat eine zu viel. Hilft nur, abzuzählen, dass genau so viele öffnende wie schließende Klammern da sind! ;-)
Ich verstehe nicht, dass Excel hierfür noch keine elegantere Lösung bietet, so eine Art Formelgenerator!?
Bild

Betrifft: AW: Wenn/ Dann Funktion
von: Gert Seler
Geschrieben am: 25.02.2005 15:05:29
Hallo Bendito,~f~
SpaltenTitel= A "Namen"; B "Prüfung_abgelegt"; C "Prüfung bestanden"; D "Ergebnis".
Formel in D2:
'=WENN(B2="";"An Prüfg. nicht teilgenommen.";WENN(UND(B2<>"";C2="x");"Prüfg. Bestanden.";"Prüfg. Nich bestanden."))
Erklärung: Wenn kein Wert in B2;"An Prüfung nicht teilgenommen.";WENN(UND(
in B2 ein Wert steht und in C2 "x"; dann schreibe "Prüfung bestanden"; sonst
schreibe "Prüfung nicht bestanden.
Eine extra Wert für "Prüfung abgelegt und nicht bestanden" kann hier wegfallen.
mfg
Gert
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn/ Dann Funktion "