wenn dann Funktionen



Excel-Version: 2000
nach unten

Betrifft: wenn dann Funktionen
von: Sebastin Surmann
Geschrieben am: 30.04.2002 - 19:17:29


Ich habe eine preisliste und dazu eine kalkulation

es ist auch soweit gut außer ich brauche eine eine verschachtelte Funktion die mehr als 7 kann.

z.B. Preisliste enthälte 20 Codes (582a) in A1:A10
die Beschriftung zu den Codes steht in b1:b10 die er mir in einer andern Mappe z.B. zelle A3 anzeigen soll wenn ich den jeweilligen code eingegeben habe.

Meine Lösung bis 7 codes war =wenn(A3=A1;b1;wenn(A3=A2;B2;wenn(A3=A3;B3 u.s.w. bis 7 wenn dann Bedigungen.))))))))

nach oben   nach unten

=SVERWEIS() o. T.
von: Rolf, Lgh.
Geschrieben am: 30.04.2002 - 19:20:04


nach oben   nach unten

Re: wenn dann Funktionen
von: Hajo
Geschrieben am: 30.04.2002 - 19:20:48

Hallo Sebastian

bei mehr als 7 wenn sollte mann Sverweis oder ähnliche Funktionen einsetzen.

347. Mehr als 8 Wenn
=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;)))))
von WF


Gruß Hajo


nach oben   nach unten

Re: wenn dann Funktionen
von: Sebastin Surmann
Geschrieben am: 01.05.2002 - 11:04:51

Ich meinte das ein bißchen anders nochmal ein beispiel
Spalten
Zeilen E(codes) F
8 1 gut
9 2 schlecht
10 3 sauber
11 4 breit
12 5 klein
13 6 schmal
14 7 dünn
15 8 dick
16 9 rot
17 10 grün
18 11 braun
19 12 schwarz
20 13 lila

=WENN(A8=E8;F8;WENN(A8=E9;F9;WENN(A8=E10;F10;WENN(A8=E11;F11;WENN(A8=E12;F12;WENN(A8=E13;F13;WENN(A8=E14;F14;WENN(A8=E15;F15;"falsch"))))))))

er soll mir in der Zelle wo ich die Formel rein schreibe den Text aus der Spalte f anzeigen zu den jewiligen codes.

Ich habe es schon so mit deiner Lösung versucht aber es klappt nicht so richtig.


nach oben   nach unten

Re: wenn dann Funktionen
von: Rolf, Lgh.
Geschrieben am: 01.05.2002 - 11:57:37

Formatiere mal Deine Tabelle (Auszug) siehe https://www.herber.de/forum/whatsnew.htm.
Rolf
nach oben   nach unten

Re: wenn dann Funktionen
von: Sebastin Surmann
Geschrieben am: 01.05.2002 - 13:07:39

Danke Rolf aber ich komme immer noch nicht weiter vielleicht kannst du mir weiter helfen.

Welche Formel benötige ich den oder wie sieht sie aus, um in einer zweiten Tabelle nach Eingabe der Artikelnummer automatisch die Artikelbezeichnung den _Einkaufswert und den Verkaufswert angezeigt zu bekommen. Nach dem ich die Ausgangstabelle habe.

Vielleicht kannst du mir mal ein Beispiel machen.


nach oben   nach unten

Re: wenn dann Funktionen
von: Rolf, Lgh.
Geschrieben am: 01.05.2002 - 18:41:51

Ich weiß leider immer noch nicht, wie Deine Tabellen aussehen. Hier ein selbstgestricktes Beispiel für SVERWEIS:

MS Excel von Rolf, Lgh. an Sebastin Surmann
 ABCD
1CodeArtikelPreis 
215Äpfel11,25
39Äpfel22,10
410Birnen1,15
518Bananen0,99
612Pflaumen1,50
713Kirschen1,80
814Erdbeeren1,75
9     
10Eingabe_CodeArtikelPreis 
1113Kirschen1,80
12     
13Formel_in_B11:=SVERWEIS(A11;A2:C8;2;FALSCH) 
14Formel_in_C11:=SVERWEIS(A11;A2:C8;3;FALSCH) 

Gruß Rolf

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "wenn dann Funktionen"