Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1548to1552
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Verschachtelte Wenn-Formel mit Oder falsch

Verschachtelte Wenn-Formel mit Oder falsch
18.03.2017 12:46:09
ViGo
Hallo zusammen!
ich habe eine Formel geschrieben, die leider das falsche Ergebnis auswirft!
Wenn eine Zahl die Bedingung erfüllt (Wert muss entweder zwischen a oder b liegen), dann soll sie mit x multipliziert werden. Wenn das nicht der Fall ist, dann soll geprüft werden, ob die zweite Bedingung erfüllt ist (Wert muss entweder zwischen c oder d liegen). Wenn diese Bedingung dann erfüllt ist, dann soll sie mit y multipiziert werden, ansonsten mit z.
So sieht diese Formel aus:
=+WENN(ODER(A7=$A$2;A7=$B$2);A7*$C$2;WENN(ODER(A7=$A$3;A7=$B$3);A7*$C$3;A7*$C$4))
Allerdings gibt sie nicht das erwartete Ergebnis aus. Könnt ihr mir da vielleicht weiterhelfen? Ich hab eine Beispielmappe angehängt, damit das ganze besser nachvollzogen werden kann.
https://www.herber.de/bbs/user/112266.xlsx
VG, ViGo

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Verschachtelte Wenn-Formel mit Oder falsch
18.03.2017 12:57:56
Peter
Hallo ViGo,
habe das Format vom Bereich A2:B4 geändert, so das dort nur Zahlen stehen und die Zeichen nur angezeigt werden. Dann kannst du die Index-Formel nehmen (B7:B9).
https://www.herber.de/bbs/user/112267.xlsx
Gruß
Peter
AW: Verschachtelte Wenn-Formel mit Oder falsch
18.03.2017 13:15:34
ViGo
Oh super, hat geklappt! Vielen Dank für deine Hilfe, Peter!
Einen schönen Samstag noch!
VG, ViGo
AW: Verschachtelte Wenn-Formel mit Oder falsch
18.03.2017 13:00:16
AlterDresdner
Hallo ViGo,
ohne die Datei gesehen zu haben, ein Denkvorschlag:
Wert muss zwischen a und b liegen: =Wenn(und(Wert>=a;Wert und nicht ODER(A7=$A$2;A7=$B$2). Das liefert True nur für =a oder =b.
Gruß der AlteDresdner
Anzeige
AW: Verschachtelte Wenn-Formel mit Oder falsch
18.03.2017 13:02:49
fcs
Hallo ViGo,
hier musst du mit UND als Funktion arbeiten, da ja beide Bedingungen gleichzeitig erfüllt sein müssen.
Das &gt= und &lt darf nicht bei den Vergleichswerten stehen,sondern muss mit in die Formeln.
Für deinen Fall gibt es eine einfachere Alternative mit SVERWEIS, die insbesondere dann von Vorteil ist, wenn du mehr als nur 3 Wertebereiche hast.
Gruß
Franz
Tabelle1

 ABCD
1Kriterien:  
2012250% 
312480200% 
4480 150% 
5    
6PrüfwertFormelergebnisErwartes Ergebnisalternativ-Formel
72555
8200400400400
9500750750750

Formeln der Tabelle
ZelleFormel
B7=+WENN(UND(A7>=$A$2;A7<$B$2); A7*$C$2;WENN(UND(A7>=$A$3;A7<$B$3); A7*$C$3;A7*$C$4))
C7=+A7*C2
D7=A7*SVERWEIS(A7;$A$2:$C$4;3;WAHR)
B8=+WENN(UND(A8>=$A$2;A8<$B$2); A8*$C$2;WENN(UND(A8>=$A$3;A8<$B$3); A8*$C$3;A8*$C$4))
C8=+A8*C3
D8=A8*SVERWEIS(A8;$A$2:$C$4;3;WAHR)
B9=+WENN(UND(A9>=$A$2;A9<$B$2); A9*$C$2;WENN(UND(A9>=$A$3;A9<$B$3); A9*$C$3;A9*$C$4))
C9=+A9*C4
D9=A9*SVERWEIS(A9;$A$2:$C$4;3;WAHR)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige

327 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige