formel wenn mit formel und???

Bild

Betrifft: formel wenn mit formel und???
von: karli
Geschrieben am: 26.09.2003 20:10:15

GUTEN ABEND FORUM Schwierige formel
ich möchte in einer wenn-formel,mehrere "UND" formeln einfügen!
ich brauche folgende begriffe die ich in diese untenstehende formel
mit "UND"ergänzen möchte;da ich ja nur 7 wenn abfragen machen kann;
und ich wenn ich die "UND"lösung habe, noch wenn befehle danach reinpacken muß.

begriffe die der user eingeben kann in B11:
D = Dienstreise/Dienstweg
X = Ausbildung
F = Feiertag
wenn in B11 EINER DIESER ANFANGSBUCHSTABEN STEHT DANN SOLL
"08:15"in der zelle stehen wo die formel eben drinnen ist.
und meine formel dazu!

MEINE FORMEL DEZEIT!
=WENN(B11="";"";REST(C11-B11-F11;1))

hoffe es kann jemand diese nuss knacken
danke
karli

Bild


Betrifft: AW: formel wenn mit formel und???
von: PeterW
Geschrieben am: 26.09.2003 20:15:29

Hallo Karli,

ist das nicht eher eine Oder-Verknüpfung, also =WENN(ODER(B11="X";B11="D";B11="F");"08:15";"")

Gruß
Peter


Bild


Betrifft: AW: formel wenn mit formel und???
von: karli
Geschrieben am: 26.09.2003 20:44:15

hi Peter
vielen dank das du die schwieriege fomel angehst!
ja du hast recht es ist die "oder" formel.
ich bin anfänger und weis noch nicht welche ich nehmen soll.
aber ich möchte sie in meine bestehende formel reingeben geht das überhaupt??
und wie mach ich das.
danke
karli


Bild


Betrifft: AW: formel wenn mit formel und???
von: PeterW
Geschrieben am: 26.09.2003 20:49:59

Hallo Karli,

es gibt fast immer eine Formellösung (für die es allerdings andere Spezialisten hier gibt). Du solltest das gesamte Problem schildern. Mir ist beispielsweise nicht klar, warum du in deiner bestehenden Formel B11 als Zahl behandelst?

Gruß
Peter


Bild


Betrifft: AW: formel wenn mit formel und???
von: karli
Geschrieben am: 26.09.2003 21:06:58

hi peter
vielen dank für die mühe
in der zelle b11 wird die die uhrzeit eingegeben wann der arbeitsbeginn ist
in der zelle c11 wird das arbeitsende eingegeben
in der zelle d11 wird ermittelt wieviele stunden gearbeitet wurde
das ist die formel in d11:
=WENN(B11="";"";REST(C11-B11-F11;1)))
und da hätte ich noch zusätzlich die "oder" abfrage rein
weil zb.wenn ein feirtag ist und es wird statt der uhrzeit ein F eingetragen weil
es ja bezahlt wird und daher 8:15 stunden drinnen stehen soll

danke karli


Bild


Betrifft: AW: formel wenn mit formel und???
von: PeterW
Geschrieben am: 26.09.2003 21:20:29

Hallo Karli,

könnte das weiter helfen?
=WENN(B11="";"";WENN(ODER(B11="X";B11="F";B11="D");"8:15"*1;REST(C11-B11-F11;1)))
B11 muss als Zeit formnatiert sein.

Gruß
Peter


Bild


Betrifft: AW: Peter ist ein Genie vielen dank???
von: karli
Geschrieben am: 26.09.2003 21:32:43

HI PETER
PERFEKT VIELEN DANK ECHT SUPER!!
gruss
karli


 Bild

Beiträge aus den Excel-Beispielen zum Thema " formel wenn mit formel und???"