Microsoft Excel

Herbers Excel/VBA-Archiv

wenn finden text1 oder text2 dann "ST" oder "nix"

Betrifft: wenn finden text1 oder text2 dann "ST" oder "nix" von: Matthias
Geschrieben am: 15.10.2014 16:59:29

Hallo liebe Excel-Fachmänner und -frauen,

ich sitze hier an einem Problem eine ODER-Funktion einzubauen und komme nicht weiter.
Ich hoffe ihr habt Lust mir zu helfen.
Was ich will ist einfach. Ich habe ein Feld in dem "Stk" oder nun neuerdings auch "BG" stehen kann. Wenn dort nichts steht soll Excel auch nichts in die Übertragszelle schreiben, wenn dort "Stk" oder "BG" steht, soll er "ST" schreiben.
Bisher hat diese Formel gut funktioniert (ohne BG):

=WENN(ISTFEHLER(FINDEN("Stk";INDIREKT("Datenimport!$C"&A14)));"";"ST")

Am liebsten wäre mir soetwas wie =FINDEN("Stk"oder"BG";Zelle)... oder ihr habt einen Tipp für mich wie ich das einfacher hinbekomme.

Besten Dank.

  

Betrifft: VERGLEICH()e anstelle FINDEn() ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 17:08:09

Hallo Matthias,

... wenn es nicht auf die Groß-/Kleinschreibung ankommt, dann z.B. so: =WENN(ISTNV(VERGLEICH(INDIREKT("Datenimport!$C"&A14);{"Stk"."BG"};));"";"ST")

Gruß Werner
.. , - ...


  

Betrifft: es geht auch FINDEN() ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 17:14:51

Hallo Matthias,

... dann nur andersherum: =WENN(ISTZAHL(FINDEN(INDIREKT("Datenimport!$C"&A14);"StkBG"));"ST";"")


Gruß Werner
.. , - ...


  

Betrifft: AW: es geht auch FINDEN() ... von: Matthias
Geschrieben am: 15.10.2014 17:21:36

Ahh das ist ja super, FINDEN spuckt ja immer Zahlen aus. Passt und funktioniert.
Vielen lieben Dank.


  

Betrifft: Was mich nur wundert... von: {Boris}
Geschrieben am: 15.10.2014 18:13:43

Hi Werner,

...dass Du nicht INDIREKT in INDEX korrigiert hast ;-)

Für Matthias noch zur Ergänzung:

Wenn Du mehrere Werte mit FINDEN überprüfen möchtest, dann kannst Du die Funktion ANZAHL nehmen:

=WENN(ANZAHL(FINDEN({"BG"."ST"."XYZ"};INDEX(Datenimport($C:$C;A14))));....

Dadurch weißt Du schonmal, ob einer der Suchbegriffe überhaupt vorkommt.

VG, Boris


  

Betrifft: Tippfehler... von: {Boris}
Geschrieben am: 15.10.2014 18:15:05

...passiert, wenn man zuviel aus der Hand schreibt ;-)

=WENN(ANZAHL(FINDEN({"BG"."ST"."XYZ"};INDEX(Datenimport!$C:$C;A14)));....

VG, Boris


  

Betrifft: Da staunt der Laie, und der Fachmann wundert sich von: neopa C (paneo)
Geschrieben am: 16.10.2014 15:29:23

Hallo Boris,

... und ich bin jetzt ganz perplex und hab dafür auch keine Erklärung, außer der vielleicht, dass ich gestern offensichtlich mal wieder völlig kopflos war ;-)

Gruß Werner
.. , - ...


  

Betrifft: ich habe es mal mit Zählenwenn versucht von: Tino
Geschrieben am: 15.10.2014 18:34:10

Hallo,
noch eine Variante

 ABC
1414STDies ist ein Test BG

Formeln der Tabelle
ZelleFormel
B14{=WENN(MAX(ZÄHLENWENN(INDEX($C:$C;A14); {"*Stk*"."*BG*"}))>0;"ST";"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Gruß Tino


  

Betrifft: Groß-/klein von: {Boris}
Geschrieben am: 15.10.2014 18:54:00

Hi Tino,

...wenn man zwischen GROSS-/kleinschreibung nicht unterscheiden muss, ist das natürlich eine gute Variante.

VG, Boris


  

Betrifft: stimmt Zählenwenn unterscheidet da nicht oT. von: Tino
Geschrieben am: 15.10.2014 19:18:21

Gruß Tino


 

Beiträge aus den Excel-Beispielen zum Thema "wenn finden text1 oder text2 dann "ST" oder ""