Zellenhintergrundfarbe mit "Wenn()" auslesen

Bild

Betrifft: Zellenhintergrundfarbe mit "Wenn()" auslesen
von: hogro
Geschrieben am: 25.11.2003 11:12:20

In der Zelle A1 soll der Wert der Zelle A10 nur ausgelesen werden, wenn der Hintergrund in A10 z.B. "Gelb" ist.
Mfg. Horst

Bild


Betrifft: AW: Wenn() und eigene Funktion
von: Galenzo
Geschrieben am: 25.11.2003 11:37:35

Hallo,
zum Auslesen der Hintergrundfarbe einer Zelle mußt du eine eigene Funktion schreiben.
Zum Beispiel:


Function ColorIndex(Quellzelle As Range) As Integer
    Application.Volatile
    ColorIndex = Quellzelle.Interior.ColorIndex
End Function


Diese schreibst du in ein Standardmodul. Danach ist die Funktion unter "Benutzerdefiniert" zu finden und wie die anderen Excel-Funktionen zu benutzen.
Also kannst du mit "=COLORINDEX(A1)" den Farbindex der Hintergrundfarbe von Zelle A1 abfragen. Diesen kannst du dann in eine WENN-Abfrage einbauen, also z.B.:
=WENN(COLORINDEX(A1)=12;A10;0)

Viel Erfolg!


Bild

Beiträge aus den Excel-Beispielen zum Thema " Zellenhintergrundfarbe mit "Wenn()" auslesen"