Microsoft Excel

Herbers Excel/VBA-Archiv

Wort aus einer Zelle in Datenbank auslesen


Betrifft: Wort aus einer Zelle in Datenbank auslesen von: Stephan
Geschrieben am: 25.10.2017 09:48:00

Hallo an alle Excel-Superuser da draußen,

ich möchte Euch aus Verzweiflung um Hilfe bitten.

1. Worum geht es:
Ich habe eine Datenbank erstellt, aus welcher ich für eine Auswertung Werte (mittels "DBAUSZUG...") herausziehe und auf "Treffer" mit einem Eingabewert vergleiche.

Die Eingabewerte können Zahlen aber auch Fließtexte sein.

2. Zu meinem Problem:
Ich möchte aus den "Fließtexten" in der Datenbank entsprechend des Eingeabewertes ein einzelnes Wort auslesen und bekomme bei meiner Lösung nur eine Fehlermeldung.

3. Bisher habe ich mit einer "WENN-Funktion" ganz einfach die Werte verglichen.
Bsp.: =WENN(A1=DBAUSZUG(.........);"OK";"NICHT")

3.1 Mittels "SUCHEN(B)" konnte ich die Problematik mit dem "Wort" in einem Fließtext finden lösen.
Eröffnete aber ein weiteres: Habe ich "ähnliche Begriffe". z.B. Ich suche nach "Vier" und bekomme im Fließtext Treffer1:"Drei,Eins,Vier" & Treffer2:"Eins,AltVier" beidemale einen "Treffer" obwohl ich nur exakt das eine Wort "Vier" als Treffer haben möchte.

4. So kam ich zu einer neuen Lösung welche wie folgt aussieht:
=TEIL(Fließtext;FINDEN(Eingabewert;Fließtext;Text_Zeichenbeginn);LÄNGE(Suchwert))

Mit der Formel unter "4." konnte ich genau mein gesuchtes Wort auslesen. Allerdings verträgt sich die Formel NICHT in Kombination mit der Formel unter "3.1".

Sobald ich meinen "Fließtext" als "DBAUSZUG-Formel" in die Formel unter "4." implementiere, bekomme ich nur den Fehlerwert "#Value!"

Hier kommt Ihr in´s Spiel, da ich nun mit meinem Latein am Ende bin.

Hat von Euch jemand eine Idee (gewünscht erstmal ohne VBA) wie ich dieses Problem Lösen kann?

Ein Beispiel-File lässt sich gerade nicht hochladen, kann die Datei nicht "sehen" obwohl es eine .xlsx-Datei ist.

Grüße & Danke vorab für Eure Hilfe!

Stephan

  

Betrifft: AW: Wort aus einer Zelle in Datenbank auslesen von: ZD14
Geschrieben am: 25.10.2017 10:02:04

Wenn deine Werte immer mit einem Komma getrennt sind, könntest du folgende Formel verwenden:

=WENN(ISTFEHLER(SUCHEN(VERKETTEN(",";Eingabewert);Fließtext));"NICHT";"OK")

sollte die Abgrenzung auch nach hinten erfolgen, musst du die Formel mit einem UND erweitern.

LG


  

Betrifft: AW: Wort aus einer Zelle in Datenbank auslesen von: Stephan
Geschrieben am: 25.10.2017 10:50:29

Hallo ZD14,

SPITZE, vielen dank hat funktioniert!


Gruß
Marf3x


Beiträge aus den Excel-Beispielen zum Thema "Wort aus einer Zelle in Datenbank auslesen"