Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1052to1056
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zahl aus best. Zelle auslesen

Zahl aus best. Zelle auslesen
02.03.2009 15:51:14
klaus
Hallo!
Folgende Tabelle soll dargestellt werden:
Tabelle1

 AB
1Spalte 1nur 90 (für Anzahl Werte >2 und
210019,12,15,70,70,8,90,901
3100160
410009,10016,10019,10021,12,16,19,2,24,70,77,8,9,901
5 0
610009,77,99,88,10019,10021,12,16,19,2,24,70,77,8,9,900


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Die Formel für das Finden der Zahl und der 0/1 Ausgabe hab ich bereits: =ISTZAHL(FINDEN("x90x";"x"&WECHSELN(Tabelle1!$A2;",";"x")&"x"))*1 . Nun muss da irgendwie noch die Bedingung rein, dass in der Zelle mind. 3 Werte und maximal 14 Werte stehen dürfen (ist diese Bedingung nicht erfüllt, soll unbedingt eine 0 ausgegeben werden). Des Weiteren soll auch eine 0 ausgegeben werden, wenn die Zelle leer ist. Mir ist klar, dass ich auch einfach einen Filter anwenden könnte, der alle Zellen mit 2 Kann mir da jemand weiterhelfen?
Danke!

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zahl aus best. Zelle auslesen
02.03.2009 16:08:25
D.Saster
Hallo,
zähl doch die ,
=Länge(A2)-Länge(Wechseln(A2;",";""))
Gruß
Dierk
AW: Zahl aus best. Zelle auslesen
02.03.2009 16:11:24
klaus
Ja, das hab ich bereits gemacht. Du meinst also, dass ich in die Formel einen Verweis auf meine Hilfsspalte (in der die Anzahl der Werte steht) einbauen kann?!
AW: Zahl aus best. Zelle auslesen
02.03.2009 16:17:47
D.Saster
Hallo,
Du meinst also, dass ich in die Formel einen Verweis auf meine Hilfsspalte (in der die Anzahl der Werte steht) einbauen kann?!


Ja sicher.
=wenn(oder(c214);0;.....
Gruß
Dierk

AW: Zahl aus best. Zelle auslesen
02.03.2009 16:33:45
D.Saster
so geht's:
=(UND(LÄNGE(A2)-LÄNGE(WECHSELN(A2;",";""))>2;LÄNGE(A2)-LÄNGE(WECHSELN(A2;",";"")) Gruß
Dierk
AW: Zahl aus best. Zelle auslesen
02.03.2009 16:25:59
And
Hallo,
hier ein Beispiel ( "," dürfen nur zwischen den Werten stehen)
Tabelle1

 ABCD
1    
2 Spalte 1nur 90 (für Anzahl Werte >2 und <15) 
3 10019,12,15,70,70,8,90,90,ab1 
4 10016,33,550 
5 10009,10016,10019,10021,12,16,19,2,24,70,77,8,9,901 
6  0 
7 10009,77,99,88,10019,10021,12,16,19,2,24,70,77,8,9,900 
8    
9    
10 Wenn 90 nicht vorhanden dann 0 ansonsten 
11 Wenn Anzahl "Komma" >1 und <14 dann 1 ansonsten 0 
12    

Formeln der Tabelle
ZelleFormel
C3=WENN(ISTFEHLER(FINDEN(90;B3)); 0;WENN(UND((LÄNGE($B3)-LÄNGE(WECHSELN(KLEIN($B3); KLEIN(","); "")))/LÄNGE(",")>1;(LÄNGE($B3)-LÄNGE(WECHSELN(KLEIN($B3); KLEIN(","); "")))/LÄNGE(",")<14); 1;0))
C4=WENN(ISTFEHLER(FINDEN(90;B4)); 0;WENN(UND((LÄNGE($B4)-LÄNGE(WECHSELN(KLEIN($B4); KLEIN(","); "")))/LÄNGE(",")>1;(LÄNGE($B4)-LÄNGE(WECHSELN(KLEIN($B4); KLEIN(","); "")))/LÄNGE(",")<14); 1;0))
C5=WENN(ISTFEHLER(FINDEN(90;B5)); 0;WENN(UND((LÄNGE($B5)-LÄNGE(WECHSELN(KLEIN($B5); KLEIN(","); "")))/LÄNGE(",")>1;(LÄNGE($B5)-LÄNGE(WECHSELN(KLEIN($B5); KLEIN(","); "")))/LÄNGE(",")<14); 1;0))
C6=WENN(ISTFEHLER(FINDEN(90;B6)); 0;WENN(UND((LÄNGE($B6)-LÄNGE(WECHSELN(KLEIN($B6); KLEIN(","); "")))/LÄNGE(",")>1;(LÄNGE($B6)-LÄNGE(WECHSELN(KLEIN($B6); KLEIN(","); "")))/LÄNGE(",")<14); 1;0))
C7=WENN(ISTFEHLER(FINDEN(90;B7)); 0;WENN(UND((LÄNGE($B7)-LÄNGE(WECHSELN(KLEIN($B7); KLEIN(","); "")))/LÄNGE(",")>1;(LÄNGE($B7)-LÄNGE(WECHSELN(KLEIN($B7); KLEIN(","); "")))/LÄNGE(",")<14); 1;0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige

375 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige